W25Q64JVSIQ BIOS Bricked by bad flashing

Hello, I’m a little noob about mod bios, so please help me. I have a HUANANZHI X79 2.49 MOTHERBOARD V2.1 and I tried to change the bios for a modded one. The thing is that the new bios work, but not like I wanted, so I try to back to the stock one. Here is when the problems arrived, I flashed the stock one with FPT (downloaded from the official page) and bricked my motherboard.

I have a CH341A programmer, the adapter for using it with the chip welded and various programs to use it, but the thing is that I can´t find the correct chip on some, others have it but don’t erase the content of the chip, etc.
Please help me back to life my motherboard, I’m desesperate because I use the pc for everything :frowning:
I have a backup.rom from AFUdos of the modded bios that worked at the start, the .rom that the official page give to users and nothing more.
Thanks a lot for reading me and I hope you can help me with that.

BACKUP.rar (1.65 MB)

W25Q64JV (SSIQ) https://www.winbond.com/resource-files/W…2021%20Plus.pdf
CH341A (1.29 up), ASprogrammer, Colibri, NeoProgrammer, Flashrom
This the SPI ID on software search: W25Q64JV

EDIT: The pdf has info about it…did u only tried Neo?

Thanks for responding friend! First, I use NeoProgrammer and I can read the chip content, but when I try to erase the content it says "Warning, probable erasure failure, check protection bits in status registers."
I can’t erase or write on the chip.
When I press the Unprotect button on the program, it says old protection register:00000000(0x00)
New protection register:00000000(0x00)
But when I try to erase again, it says the same old thing. There is a specific form to unprotect the chip?

New information. When I try to unprotect, enter to register status and it is protected, I unchecked the option and write for unlock, but when I read again it becomes protected again, like the beggining, someone knows something about that? Information about the chip or anything?

first of all you have to use the latest version Neoprogrammer from 4pda forum.
From the symptoms you describe it seems to me that you are using a test clamp directly on the motherboard. This rarely gives good results. it is better to unsolder the chip.