[W8.1] Optical Drive noise when external drive is connected / iTunes is launched

Hi everyone,

I was not sure which section my problem can fit in so I decided to post it in the Windows topic.
Yesterday I formatted my PC and I installed everything new with the latest drivers. The problem I encounter is quite strange : when I connect an external drive OR when I launch iTunes (yes iTunes, I’m not joking) on my PC, the optical drive make a noise. From time to time, my optical drive also makes this noise, with no apparent reason. This noise is exactly the same when I boot my PC up. It is like an initialisation sound.
It is very strange because I didn’t have this problem before neither with an external drive nor iTunes.
I think it is related to one of the driver I installed (I didn’t install anything for the optical drive though) and more precisely the Intel AHCI driver… I’m not sure but it’s one of the only thing that changed after the new install…
And I don’t get why the optical drive would be triggered by iTunes or when an external drive is connected…

EDIT : my AutoPlay in windows is disabled, “put hard disks to sleep” is also disabled.

Have someone a clue?
Thanks in advance.

I found a related topic which explains my problem maybe better : http://forum.notebookreview.com/threads/…n-empty.597557/


@Hannay :

Until now I have no idea regarding the reason for the noise, which is coming from your optical drive.
If possible, I recommend to connect the optical drive to a non-Intel SATA port.

Furthermore it would be a good idea to create a signature with the main OS and hardware details.

Yep, I’ll do that !

ok so, I solve the problem. I had earlier a big issue with the AHCI driver, my computer froze completely. The event viewer showed a lot of errors with Disk and iAstorA… I de-installed the and installed the AHCI driver and since I’ve got no problem anymore !

EDIT : Well I spoke too soon… The problem came again. I’ve tried with the and the problem is still the same…

Hum, I’ve restarted my computer and the problem was gone for 5 minutes. And it did it again… It’s really weird…

@ Hannay:

Is your optical drive empty?
What does the Disk Management and the Windows Explorer show regarding your optical drive?

Yes, it’s empty. And it works good !
The explorer shows the DVD icon with the appropriate letter. Disk Management shows CD-ROM 0 and below DVD with the letter.

Well now I’ve de-installed the AHCI driver. I’m running with the microsoft ones and the problem is gone since 10 minutes. I have no idea why the new AHCI drivers are messing up so much with my laptop…

A screenshot of what the Intel AHCI driver triggered yesterday : http://hpics.li/f19a6fe

I doubt, that your problem has been caused by any of the Intel AHCI drivers. Otherwise many other users would have reported about a similar issue.
I suspect, that your optical drive itself has a problem with the Intel RST(e) AHCI driver. That is why I recommended to connect it with a non-Intel SATA port, which is running in IDE mode.
Another test option would be to replace the optical drive temporarily by another model.
There are some optical drives, which do not work properly in AHCI or RAID mode, whereas other models don’t have a problem with a non-IDE mode. Some years ago I had an optical drive, which was not able to boot in AHCI mode.

The problem is that I can’t test these options easily.

I think you’re right, my optical drive has problems with the AHCI drivers. BUT I didn’t have any of these problems before when I was running with the previous version of the AHCI driver (v12 for example). So I think it’s caused by the new ones… What exactly, I don’t now… Maybe I’ll call Dell/Alienware later then…