Which NVMe Drivers are the best (performance related)?

@Dekal

You have everything in place for PCIe 4.0 support (as I wrote in the other thread). Is your BIOS (Gen3 - Gen4) set correctly? Could there be a PCIe lane conflict?

For example.

@westlake

Look here: Asus B450 and X470 Motherboards That Support PCIe 4.0 (Updated) | Tom's Hardware

That’s why I want to mod the motherboard BIOS as I described in the other thread.

It was removed on later updates by new AMD AGESA implementation, what do you want mod if you cant touch the AGESA firmware.
I see no reports on latest bios versions that even with a Ryzen 5000, that the B450 will support Gen4 PCIe or M.2 PCIe Gen4.
So your stuck with a Gen4 NVMe in @ Gen3 bandwidth, the CrystalDiskMark bench numbers are correct in performance.

@westlake The publication in TOM’s is back from 2019 and no timestamp on the EDITs on that post… so for all that matters all that info on the subject suggests that was only high speculation during that period, my opinion only.

@Dekal

Sorry, but I still don’t understand why PCIe 4.0 shouldn’t work with your configuration. The linked article doesn’t describe anything like that, in fact it says it works.

That’s all I can add to the topic. Nowhere have I seen any comments that PCIe 4.0 is generally disabled in new BIOSes for cheaper PCHs. It is odd, though, that within a given line (e.g. B450) it works with some motherboards and not with others. Anyway, this topic is not relevant here, there is another topic for it.

@westlake

In addition to my knowledge that PCIe 4.0 does not work with this mainboard when using the latest BIOS version, further statements from users of the mainboards with B450 and x470 can be found on the net, which suggest that PCIe 4.0 with the newer BIOS versions versions was really switched off again. This can also be read from the text.

Quote1:

Users today may find a PCIe 4.0 option available in their pre-X570 motherboards. However, users should expect this option to be disabled when final retail BIOSes are released to implement full performance and stability for new 3rd Gen Ryzen processors.As pre-X570 motherboards were not designed with PCIe 4.0 in mind, their designs may be incapable of running PCIe 4.0 signaling with the requisite stability and performance. To ensure a reliable and consistent experience in the field, PCIe 4.0 will not be an option ultimately available to pre-X570 motherboards. Users may continue with a beta BIOS if they desire, but performance and stability cannot be guaranteed.

I haven’t seen this said beta BIOS until today. Even a request from Asus for such a BIOS has not been successful so far.

Quote2:

Edit: These BIOS revisions will likely be used widely to unlock PCIe 4.0 on these motherboards, but to retain that functionality, you will not be able to update to newer firmwares in the future that lock out support. That means you’ll eventually lose out on the performance-boosting BIOS updates that AMD is known for.

These statements are very speculative. But there is also a direct answer from AMD on the net, which clearly proves that PCIe 4.0 has been deactivated again for these chipsets.

@MeatWar

For me this is known. I know how to evaluate the benchmark values ​​correctly.

@westlake

MeatWar is most likely right. But let’s discuss this further in the thread I opened:

I’m not giving up on getting a BIOS MOD just yet.

@Dekal

What do you mean with “NVMe SSD Settings” and “Default Settings”?

@Fernando

I ran 2 different benchmarks in CrystalDiskMark.

1.) In the “Settings” menu, selected “NVMe SSD” + Benchmark

2.) In the same menu “Default” + Benchmark

1 Like

@Dekal
Thank you very much for your quick reply. Your information was very important for me, because I hadn’t yet realized this specific CDM “Settings” option for tests with an NVMe SSD.
As a result of your useful post I have instantly done some new CDM tests with my Samsung 990 Pro and got nearly unbelievable results:
AMD X570+1TB Sams.990Pro+Phison1500

Maybe I should do some new performance comparison tests with the optimized CDM settings.

2 Likes

@Fernando

You’re welcome! :grin:

Here I have a few more registry entries for unlocking settings in the Windows power options.

So one can better tune/test the SATA/NVMe drive.

NVMe Registry Settings - Power Plan.rar (5.5 KB)

EDIT: I think these settings only work when using the Windows driver, but I don’t know for sure.

1 Like

@Dekal
With modern Windows Operating Systems it can be done much easier by doing a right-click onto the “Start” button and choosing the “Power Options”. Look here:

@Fernando

Interesting. Is that Windows 11?

Even if I hardly expect any performance differences, I would like to install a different driver for my Samsung NVMe SSD 990 PRO 1TB for testing. I want to test the Phison and Micron driver…

Currently, my system boots in non-RAID mode using the Windows Storage driver. AMI Native NVMe Driver Support is enabled in the BIOS.

What is this option for anyway?

What confuses me a bit is the following…

To find out whether a specific “Storage Driver” will work with your currently in-use AHCI/RAID/NVMe Controller, you should extract the downloaded driverpack, open its *.INF file(s) by using any text editor and looking for matching VendorID (VEN_xxxx) and DeviceID (DEV_xxxx).

Both a different VendorID and DeviceID are displayed in the device manager. Is it still safe to test these drivers? Or could it happen that Windows no longer starts?

@Dekal
Yes, I am running Win11 Version 22H2 Build 22621.1192.
Just to show, that a Samsung 990 Pro SSD user cannot expect huge performance differences by changing the in-use NVMe driver, here are the benchmark results I got with my AMD X570 chipset system.
These were the drivers I have tested:

  1. Microsoft’s generic Win11 v22H2 in-box NVMe driver stornvme.sys (wrongly dated 06/21/2006)
  2. Samsung’s NVMe driver v3.3.0.2003 WHQL (dated 01/21/2020, install has to be forced)
  3. Intel’s RST NVMe driver v17.11.3.1007 WHQL (dated 09/30/2022, install has to be forced)
  4. Phison’s generic NVMe driver v1.5.0.0 WHQL (dated 02/23/2018)
  5. Mikron’s NVMe driver v2.1.19.0 WHQL (dated 08/03/2021, install has to be forced)

Here are the benchmark results I got:
AMD X570+1TB Sams.990Pro+MS stornvme
AMD X570+1TB Sams.990Pro+Samsung_3302003
AMD X570+1TB Sams.990Pro+Intel_171131007
AMD X570+1TB Sams.990Pro+Phison1500
AMD X570+1TB Sams.990Pro+Micron21190

To prevent any problems while trying to change the in-use NVMe driver I recommend to set a Restore Point before starting the tests. Don’t try to delete any storage driver!

1 Like

@Fernando

OK, Thanks. If i can’t start again, what options do i have while booting?

@Dekal
If you cannot boot directly, press F8. Then you will see alternative boot options. One of them is to restore the system as it was before you had set the Restore Point. For details look >here<.
So don’t worry about a not bootable system.

1 Like

Hi Fernando

At the beginning i would like to thank for great job you have been doing especially for win xp enthusiasts but also for w7 and other older windows systems fans.

Me and my cousin we have problem with nvme (probably generic) driver. On a daily basis i use win 10 x64, but my cousin still use win 8.1 x64. Some time ago he tried nvme drivers proposed by you to obtain better performance results of nvme disk. Most of them were working well apart from micron drivers, versions from 2.1.17.0 - 2.1.19.0 . These indicated versions weren’t working at all. They refused to get installed. While trying to get installed they were showing that they weren’t digitally signed. Additionally after choosing and confirming ‘have disk’ option system showed: “This device driver is not recommended to install, because windows operating system can’t figure out whether it is compatible with hardware that you have”. After going ahead system showed next message: “Windows system encountered issue while installing driver software for the device. / Windows system found driver software for the device, but encountered error while trying to install it. / The software were passing compatibility tests based on requirements that enable obtaining windows logo on various windows system versions and may not be compliant with this version”.

The version 2.1.5.0 (from win-raid website) of micron driver works well (system showed that it is digitally signed).

What do we do wrong with versions 2.1.17.0 - 2.1.19.0 on win8.1 that they don’t work? Do they need to be digitally signed to get started and work as version 2.1.5.0 ?

Best regards

Luca44

Hello luca44,
welcome to the Win-Raid Forum!
Since I am travelling these days I cannot help you. Maybe I will give you support next week.
Regards
Dieter (alias Fernando)

@luca44
All your named Micron NVMe drivers have been digitally signed by Microsoft, but may not support the same Micron NVMe Controllers.
Which are the HardwareIDs of the NVMe Controller, which is not supported by a specific Micron NVMe driver? To find them please expand the “Storage Controllers” section of the Device Manager, right-click onto the specific (or all) listed NVMe Controller(s) and choose the options “Properties” > “Details” > “Property” > “HardwareIDs”.

@Fernando
Sorry for delay in the conversation I was sick for last few days - nasty flu. The nvme disk we have problem with is adata xpg sx8200 pro 1TB (pcie3.0). Its vendor id is ‘1cc1’ and hardware id is ‘8201’.

@luca44
PCI\VEN_1CC1&DEV_8201 are the HardwareIDs of the Disk (here: “XPG SX8200 Pro SSD”), but I asked you for the HardwareIDs of the related NVMe Controller, which is shown within the “Storage Controllers” section of the Device Manager. You cannot install any third party driver for the Disk (only for its in-box Storage Controller.