Widespread virtualization (VT-d) issue on Haswell i5s, H97 mobos, and nVidia cards?

Hello everyone, it just so happens that my project has landed in my possession and (unfortunate) testing, four H97 motherboards (one Gigabyte H97M-D3H v1.0, one Gigabyte H97M-D3H v1.1, and two Asus H97M-E/CSM), and I can replicate an odd issue on all of them.

I had the v1.0 Gigabyte board for about a year running a Hackintosh via an external boot loader. It should be noted that using a Haswell i3 with the v1.0 board for all that time was a fantastic setup, even all of the sleep functionality of OSX worked flawlessly on that board…as long as you were using the integrated Intel video.

I got an itch to get a 4k monitor and get a little better performance from Final Cut, so I got a Viewsonic low end 4k monitor, a Gigabyte Graphics Cards GV-N75TOC-2GL 750ti, and while I was at it an i5 4460. It took some searching, but I managed to find a 400w TFX PSU to drive the new vid card (this is in a microatx desktop case) and upon initial installation all seemed to be well.

After running into a few issues with the vid card I double checked the bios settings and found some things not right, namely VT-d after I couldn’t get virtualbox to run a Win32 install I have for some ancient CAD programs. After enabling VT-d, the board bricked. No power, no buttons, no lights, nada. I chalked it up to random death after extended use and being relatively happy with the board, ordered a new one from Amazon, and this time got a v1.1 revision. Set it all up, initially okay, and the same thing. Checked bios settings, found VT-d disabled, turned it on, and the same thing, brick!

I did a bit more testing this time and found that removing the nVidia card and starting it back up forced a reset, and I was able to get defaults restored that way, but that doesn’t solve my problem. I figured this is a Gigabyte issue, so I boxed up the new v1.1 mobo for RMA back to Amazon and went and bought an open box Asus H97M-E locally. Upon setting everything up on the Asus board I was angrily greeted by some corporation’s secure boot image, which turned out to be difficult to be rid of. I was able to disable secure boot temporarily by deleting their keys from the bios but upon trying to flash a new bios, same story as the Gigabyte, brick…or so I thought. Being an open box from a local store I just returned it and bought a new Asus H97M-E from the same store.

Since I’ve got so much time in all of this, what’s another few hours? I figured I would try Ozmosis as an OSX loader (a boot loader injected into the BIOS with custom settings, for those unfamiliar, that allows native installation of OSX on supported boards). That was a day or so of study and research but I got it up and running, and it seems to work fine. After editing/flashing my previously used serial numbers and what not from the bootloader I was using before, it booted into a retail El Capitan installation right away and installed without issue. I had to go back later and add a couple of nVidia settings to force it to load the nVidia drivers at boot, so I wound up flashing it twice, both times without any trouble.

The last thing I did this afternoon was try to open virtualbox and…not again, VT-x disabled error. I rebooted into the bios, enabled VT-d and blammo! Brick again!

This time I meticulously started to troubleshoot by trial/error and found that simply unplugging the displayport cable on the vid card would trigger a bios settings reset. As soon as the displayport cable is unplugged the machine fires right up, with the default secure boot keys enabled prompting me to change my settings to appease Bill Gates or whoever is in charge over there, despite the fact that I don’t even own any Windows machines (yes, I REALLY hate ‘secure’ bios BS. Screw you Microsoft, if you want to control what I can and can’t put on a motherboard, you pay for the motherboard, how’s that?)

Anyways, enough soapbox.

In learning about the injection of a bootloader into the bios of these H97 boards it seems that the bios for them are all coming from a common vendor, yes?

If that’s the case, I think I’ve found a common problem to all of them, at least the 4 I’ve tested (each having multiple bios revisions).

I have used Gigabyte bios firmwares for their H97 of both F7 and F8b, and have used Asus bios firmwares on those two boards of 2402 and 2702, and all of them exhibit the same flaw with VT-d on this CPU.

It should be noted that this is most definitely related to the presence of the video card. If I remove the video card and use the on-board video over HDMI, I can enable VT-d (had to do so to use a win32 tool to edit this bios for the Asus board).

Anyone have any ideas?

Welcome at Win-RAID Forum and thanks for your report!

I have a lot of them, but unfortunately none regarding your question.
Hoping, that you will get some tips from other Forum members
Dieter (alias Fernando)


Have you tried updating the BIOS of your nVidia card? If it’s UEFI mode perhaps try Legacy boot?

Failing that, since you say on-board video works with VT-d, I’d try a different video card model, perhaps another brand? It sounds like a video BIOS/driver issue.

In the past we used to have issues with Hyper-V and integrated video drivers to the extent that we disabled that and put a cheap ATI card in there for VGA video. The Intel drivers would BSOD once Hyper-V was enabled and no amount of BIOS updates or video driver updates would help. With later hardware we had issues in UEFI mode and Hyper-V which again were not fixed by BIOS updates but by booting in Legacy mode. Perhaps somebody can cook fixed BIOSes but for us the work-arounds were faster ;(

I too suspect an issue with nVidia here, no I haven’t tried to update the nVidia BIOS, will give that a try when I get some time this weekend.

One more thing since you mentioned 750Ti - I presume you know the BIOS power settings are very low so the card cannot really automatically boost much. If you modify the BIOS via MaxwellEditor you can easily bump it to the rated 75W from the really low 35W or so most are set. Sorry if you know this already :wink:

I did not know that, and that would explain why the machine can’t sleep properly, I’ll bet.

Sorry I don’t visit here often yet - the BIOS stuff for modding ME has not arrived yet ;(

See “How to Increase the GeForce GTX 750 Ti Power Target Limit” e.g. (http://cryptomining-blog.com/tag/gtx-750-ti-tdp/) is a step-by-step on how to do it. Naturally it works on other nVidia cards also done 980 with Maxwell 2 editor and so on. Not sure it has anything to do with sleep - it’s just for boost/overclocking. Good luck!