Wifi-Card not detected after Biosflash


I got a Problem with my Asus Notebook and really no idear what to do, but lets start at the beginning:
A few weeks ago I flashed a moded Bios (just some menus unlocked with AMIBCP 4.53). I performed the flash in DOS with AFUDOS and somehow it crashed while flashing and the notebook shut itself down. It was like death, so I decided that I will have to flash a new rom external with my Raspberry PI. To do that I first had to build a new rom, because Asus just gives 6mb Updatefiles but the Bios-chip got 8mb, so ME, GBE and the discriptor region was missing. With a guide (I can post a Link of it if needed) that I found it was not a big problem. When I finally flashed the rom using the PI, everything was working as before, but the Wifi-Card was not detected at all (windows and ubuntu). Lan is working in ubuntu, but windows cannot install a driver.

What I allready I tried:
-Reset Bios
-Flash older Bios (once with ME,GBE aso and once mainbios only)
-Change Wifi-Card

Model:Asus R513CL
CPU:Core i3 3217U
GPU: Geforce 710
Chipset: HM76
Bios-Version: 207 (newest, 206 also tested)
Bios-Chip: Winbond 25X/Q Series

If some infos are missing please ask.
I would be happy with every help, I dont need Lan, but Wifi would be nice to have again.



Btw sorry for bad english :wink:

I’m not sure, but I think Asus Bios have to be set up with the correct MacAddress, otherwise you’ll have problems similar to what you say.

If it was changed, try to solve with this:

How to change the MAC address of FM under DOS

For example, we want to change the Mac address on this 92-E5-BA-F9-AD-C4
write commands (where the last two characters of the command have a MAC address that repeats twice)
bt.exe will find in this archive “ASUS_BIOS Tools 2.0”
After each command, press Enter.

bt.exe -C CNFG / W C2 92
bt.exe -C CNFG / W C3 E5
bt.exe -C CNFG / W C4 BA
bt.exe -C CNFG / W C5 F9
bt.exe -C CNFG / W C6 AD
bt.exe -C CNFG / W C7 C4

bt.exe -C CNFG / W D7 92
bt.exe -C CNFG / W D8 E5
bt.exe -C CNFG / W D9 BA
bt.exe -C CNFG / W DA F9
bt.exe -C CNFG / W DB AD
bt.exe -C CNFG / W DC C4

ASUS_BIOS TOOLS 2.0.zip (42.8 KB)

It works…?

Hi, I am realy sorry for responsing that late, I tought there would come an email when some answers. I first noticed it this morning, when I watched in the forum again. Im totaly sorry about that.

Back to topic. I tried your idear, but it seems it doesnt help. Once I used the lan-mac in both parts, once the wifi-mac and also wifi-mac in one and lan-mac in the other part. Nothing worked.
I also tested everything in Ubuntu, since am able to the mac adress out there.
Btw. I noticed that Ubuntu always used the mac-adress given in this part:
bt.exe -C CNFG / W D7 92
bt.exe -C CNFG / W D8 E5
bt.exe -C CNFG / W D9 BA
bt.exe -C CNFG / W DA F9
bt.exe -C CNFG / W DB AD
bt.exe -C CNFG / W DC C4
so maybe the other one is for wifi when this is for lan?