Wifi pci-e cards not recognized on Lenovo Thinkcentre SFF machines - blacklist issue?

In the office we have two Lenovo m720s SFF machines. Recently purchased two AC-7260 AC1200 generic wifi x1 cards and when I plugged them in both machines failed to recognize them in Windows 11 device manager. Both times the cards were missing in action. The m720s has two x1 slots plus an x16 slot and I tried all of them. Not only that I tried an old Atheros Killer wifi card and an AX200 wifi pci-e adapter. These cards were verified in other machines as working. Interestingly enough the Killer card had a NGFF m.2 card I could remove and able to install on the motherboard of the m720s where there was an m.2 ngff unoccupied slot available and that worked. So not a blacklist issue since if the Killer card was being blacklisted it wouldn’t have worked in the m.2 wifi slot. My best guess is that they sold me non- functional pci-e slots on both machines. Researching the issue showed that I am not the only one having the issue. Lenovo has a history of whitelisting so not sure whats going on in that could they whitelist what goes into the pci-e slot specifically but not the m.2 slot. Doesn’t make sense. Furthermore in UEFItool was able to find a module that contains a lot of wifi device vendor ids. The AC1200 card was not listed (its m.2 variant was however) and even found the device id of the Killer card but can’t say if it was a blacklist or whitelist as they Killer card was listed a couple lines down like this:

86 80 95 08 86 80 8E 08 86 80 8F 08 86 80 88 08 86 80 85 00 86 80 B2 08 86 80 B4 08 86 80 66 31 86 80 F3 24 86 80 F4 24 86 80 FD 24 86 80 26 25 86 80 F0 9D 86 80 70 A3 86 80 DC 31 EC 10 76 81 EC 10 79 81 EC 10 23 B7 EC 10 8B 81 EC 10 21 88 EC 10 22 B8 EC 10 21 C8 8C 16 3E 00 8C 16 32 00 8C 16 34 00 8C 16 41 00 8C 16 42 00 8C 16 36 00 86 80

In anycase not sure whats going on. If anyone can help or advise? Not interested in flashing anything with a usb flasher as these machines are work machines and no guarantee it will fix anything. As the Killer card was in that list above makes no sense why not show up via PCI-E x 1 slot!


Not an expert by any metric, but I was thinking of keying, i.e. what each M.2 connector is designed and connected to, but looking at the specs for the M720 there is at least 1 M.2 keyed for WiFi:

So… blacklisting?! Is it still a thing these days? I mean, the cards were tested somewhere else and they work on usual busses, PCIe for the WiFi, USB for BT; they’re not CNVi cards. Check in both M.2 connectors just in case, but I find it bizarre if they still resorted to blacklisting / whitelisting hardware nowadays :disappointed:

I thought of coming back to this, maybe it’s for nothing but, did your machine come with a WiFi card? I’m asking because you mentioned you were able to find some of the PIDs listed in the firmware with UEFITool, I am wondering if the one it came with (or one of the accepted ones for that matter) could be replaced with one of the cards you have.

I haven’t attempted anything like it before so I’d welcome someone with experience to chime in. Flashing the modified firmware needn’t be directly with a programmer, I’m sure the lock to flash using Intel’s FPT from Windows would need to be disabled first, but that’s it.

I’ll see if I have some time during the weekend to look into what could be done.


Unfortunately the system (both of them as I have two) did not come with wifi cards. Just an empty m.2 wifi slot. As for the whitelist I discovered most of the vendor ids found belonged to intel and some Qualcomm devices. I only had a Killer wifi module, that had matching vendor ids, to test inside the m.2 NGFF slot and that worked as long as it was plugged in the m.2. Placing it in a pci-e adapter along with a three other cards I owned were not detected and ghosted by the system.

I posted a help request with the Lenovo support forum and this is what I was told:

All the Wifi cards listed as compatible with this system are M.2 cards, no PCIe x1; secondarily, the cards need to have a Lenovo FRU (part) number on the card itself, unmarked cards, even if a correct model, can be unrecognized. I have read that this is to comply with some countries’ RF regulations. Upgrades are possible, as evidenced by this thread, but it uses a different BIOS, and I have yet to read of anyone installing a Wifi 6 card in your system.

So apparently the only way to use a wifi card according to that poster was to use approved devices and only special lenovo devices if you are worthy to want to use the pci-e slot you paid money for it most likely won’t work. The other way is to mod the bios which I am not wanting to do as these are my work machines in the office and don’t want to risk a brick and furthermore no guarantee it will do anything for the pci-e slot which they out right block. Tested on both machines!

Also the usb headers on the system board are not standard and so would not work for BT anyhow but as I understand you don’t need BT if all you want is wifi. It should be recognized at the very least. For right now using USB wifi adapters. That’ll show them!


Jesus man! WTF! Not only the card needs to be one that’s approved, but also coming from them; so if one went to say, Mouser, and ordered one module of those that actually shipped with some submodels of the M720, it would work, or not. It’s bizarre…

What I meant is that, internally, M.2 slots for WiFi cards are wired both to a PCIe bus and a USB bus, a combined WiFi + BT card actually don’t connect it all via PCIe, the BT part goes over the USB bus. Still, I think you’re correct in that if you just wanted WiFi and for some reason there was only a PCIe bus involved you’d get it.

I was able to find a picture that shows it:

BT going over USB

That’s from a laptop that has an MT7921 card (it’s a combo WiFi 6 / BT 5.sth), it’s connected to the M.2 slot for WiFi cards, but looking at the hierarchy of connected USB devices one can see that the BT part over there.

And no, the laptop doesn’t have so many USB ports haha, in fact, that one and the one of the webcam are internal and not accesible (I’m sure the processor or PCH support more, but are not exposed for users to use), and other entries are 2 representations for the same physical one: USB 3.x ports appear twice in that tree.

Anyway, it’s a shame that whitelisting is a thing and to that extent, I can only imagine what it must feel like, it’s not that you don’t have the ports, the system is actively preventing you from using them. I guess it could make sense in a controlled, large enterprise, with OOB managed and all, but there should still be a way to disable it if the end user wanted to.

Best of luck!

Just got an email from their tech support department that they would like to investigate this further. Its like they have no idea whats going on. Not only that speaking with their techs is like speaking to someone who is reading written responses what to say like they have no real ability to problem solve on their own.

Yeah… it’s usually like that with first level tech support, one needs to be patient sometimes. I believe they do have scripts or procedures to follow geared more towards basic troubleshooting, it’s only when (if) they don’t deal with the issue that the case gets escalated.

Was browsing things to read in my feed when I came accross this article: https://www.tachytelic.net/2022/07/lenovo-thinkcentre-m92-nvme/?amp

The author details how to unlock the firmware on Lenovo machines for flashing custom roms by jumping a pair of service pins called ME-DIS and putting the machine in sleep mode so no need to use an usb programmer. In the article he details how he modified his lenovo for nvme support by inserting my nvme_express driver into the bios file. Then he shut down the pc and removed the jumper.If this works should make it a lot easier to flash a whitelist modified bios on my Lenovo machine. If I ever find the time.