Will a BIOS Update change my ME Firmware?

Hello @ everyone,
i was looking for new Drivers/Software etc. for my Motherboard, an Asrock z77 Pro3. And i found a new Beta Bios. The desctription tells me that it would do an CPU Microcode update. I´m not sure if i should install this (i mean Flash it) because a few years ago i tried to update my ME firmeware. It was successfull - but after updating the firemware i got error Messages when i used the MeManuf-Tool. And now i am afraid to use this new Biosupdate because i dont know if this will Change/overwrite my ME Firmware - and if it does, will it update the Firmware without any Problems.
I would be very glad if someone could explain to me what could happen if i try to update my bios based on the facts i told. Thanks.


It should update the ME firmware itself, without issue, if a ME update change is included which is likely.
Please post your current ME version, and a link to the BIOS update and I will check and see if it’s a newer ME version in the BIOS update.

I am actually at work, will give you the info later that day - thank you.

Here is the new bios* and my actuall Firmware:

*the bios.zip has been downlaoded directly from Asrock and then uploaded - 100% virus-free !!

Z77 Pro3(2.20)ROM.zip (4.36 MB)


No problem, whenever you have time

OK, here are the Infos you Need. But i am still not sure if it would be a good idea to Flash my bios when MEManuf reports some Errors. For sure i made a screenshot of the error-messages, maybe you can tell me something about and maybe how to fix it - before i Flash my bios? Thanks for your help so far.


That error simply means your missing a file from the folder (vsccommn.bin). Please download the latest package from here and run it again

Also run meinfowin too and post an image, need to see this to see your current ME version so you can know if new BIOS has same or updated version.
but your worries I think are nothing to worry about, if that is the error that scared you initially about updating BIOS/ME, that’s only missing file error not messed up ME.

To run MEinfowin or MEmanufacturer from the above package, go to each apps respective folder, then into folder where you see win/win64/DOS etc and select the Win/Win32 folder hold shift and press right click, then choose open command window here.
Then type in the apps name MEManufWin or MeInfoWin

That BIOS you uploaded contains the following. You can always test this yourself with ME Analyzer, drag and drop BIOS files on it - https://github.com/platomav/MEAnalyzer/r…1.70.0_r141.rar


thank you for you Information about the Errors i get running the MeManuf.

My current ME Firmware is, so i would downgrade my firmeware if i Flash my bios. That wouldn´t cause any Problem i guess - in that case asrock would not offer this bios, right?
It is also interessting that the firmeware in this new bios nealy meets my Driver Version perfectly: FM and Driver - is that anything i should Keep in mind? Or is it less important?

No, ME wont usually downgrade itself, unless you choose to do so with a flashing method, even if it did you can re-update anyway. People often fight their boards trying to downgrade ME, so it happening automatically by BIOS update would be out of the ordinary.
Plus, you are not on the latest ME firmware anymore anyway, the latest for 8.1 is now So you can update the BIOS, then re-update to the latest firmware using FW Update tool.
You are on a version that was probably never in your BIOS, you updated outside of a BIOS update, that’s why your BIOS is that version vs what’s in the latest BIOS. Driver can/should probably be updated as well, I didn’t check, but if you want the latest for security reasons you want the latest ME FW and driver.

Thank you very much, your information is very helpfull. I will try to Flash my bios, than i will update my ME FW to the latest Version and than i install the latest ME Driver (i know not to uninstall the current Driver before updating my ME FM).

Thanks alot for your help !!! Best regards, Eisenhauer

You’re welcome! And yes, that’s correct, leave the driver installed until your done updating the FW, then you can update the driver last.

Hi, it´s me again, Eisenhauer.
Unfortunately i cannot update my firmeware. Everthing i try Ends in this error: ERROR 8716: Invalid Usage. This sounds like i am not able to use the update tool correclty. Could be.
I have saved the ME Tools for my System on my ssd where Windows is installed, this is the path: C:ME Tools…etc. I have opend the command window with admin-rights. The new Firmware is coied to the same path where the FWUpdlWin64.exe is saved. I used this command:

C:ME Tools\C:\FWUpdate\Local-Win64\FWUpdLcl64.exe -update_8.1.70.1590_1.5MB_PRD_RGN.bin

Also the -generic command Ends up in ERROR 8716.

What did i wrong? I would be very thankfull if you could tell a noob how to use the update-tool. Thank you.

fwupdlcl -f ME-File-Name.bin

That is all you need to enter, I don’t know where you got this file (-update_8.1.70.1590_1.5MB_PRD_RGN.bin), but if it’s not from here in the firmware download thread be careful, you only want file named
And that command format you entered is wrong (Maybe that’s why name looked off to me). That’s probably the only issue. Here is direct link from the ME FW thread - https://mega.nz/#!WQFWgLYC!Yfg7eR58o4wZY…a_oI3ymqVn3aCQI

So command with that file would be >> fwupdlcl -f

If you continue to have issues with the x64 version, use regular 32bit like I gave in the example command above.
-generic is not needed. And make sure you are in command prompt (Black window), not shell (blue window)

Hi Lost_N_Bios,

ist Eisenauer again. Sorry for disturbing you, but all my ideas to upgrade my ME FM dont work. Is it possible to make a step by step procedure for me? I know, this is a very noob question, but i think that i have a big Problem somewhere in the Intel ME. I am not able to Flash my ME FM with the Tools from this page. And i get the same Errors like before.
Sry for asking this, but a have opend the command window with admin-rights. I think so. I klick here and klick the right mouse button an choose "open as admin", is that correct (please check my file i uploaded)?

The next step is to use the commands for updating the ME FM - but it dont work. What is the mistake?

Thank you very much for your answer and ideas.


Yes, you can do like your image. Or, on the FW Update folder, hold shift and right click open command window here should work too (But maybe not if you are not admin account on the PC, I am not sure)

But, if you do like your image, you then have to have the command prompt at the folder that contains the ME file and the FW Update tool fwupdlcl (Navigate to that folder - via CD command)

Show me image of this folder open, with ME FW in it and fwupdlcl all in same folder, then show me the command prompt in same image you are trying to use, with command typed in

have u changed the bios? hows it working / any opions?
i have same computer, almost same parts and im also wondering do i dare care, want cant update the bios to 2.20 BETA . . .

any advice?



@mAXiMAL - not sure who you are asking what there? If you want to ask specific person you have to tag them with @ directly in front of their name, like I did you at beginning.

i was asking from anyone who could or should know how this beta bios from Asrock works, or not work.

Sorry if i messed the conversation, my bad … :slight_smile:


@mAXiMAL - It’s OK, and a valid question, but you have to tag people so they know you asked, otherwise they will never see your question since most aren’t here all the time