Win 10 AMD RAID 5

Hi,

Somehow between Win 8 and moving to Win 10 my RAID drivers were lost by the OS.

Set up is
SSD Boot Drive
4X 1000GB RAID 5
Windows and lots of apps installed. The RAID 5 has 10 years of data on it… stuff I absolutely can’t lose.

Motherboard is Gigabyte GA-990FXA-UD7 (Rev 3)

AOMEI Raid manager installed

Now the issue is resolved by reinstalling windows and loading the AMD drivers during install. At least in theory.

Problem is that this requires I do the reinstall after booting to Windows which I can’t do when the BIOS is setup for RAID.

Is there some tool that gets around this or a means to load the RAID drivers via edits to the Registry?

Yani

@ Yani:
Welcome at Win-RAID Forum!

Questions:
1. On which disk is the boot sector (MBR/GPT)?
2. On which disk is the system drive C:?
3. Which is your current SATA mode within the BIOS?

Regards
Dieter (alias Fernando)

Boot is on the SSD. It’s GPT. All disks are GPT

The BIOS has 3 settings IDE, SATA and RAID

Only the RAID setting is usable as RAID BUT I am currently using SATA as that will boot without loading the AMD RAID driver.

The SSD is set as “RAID Ready”.

@ Yani:

If you don’t want to do a fresh OS install in RAID mode (which would be the better choice), you should set a restore point and then try the following:
1. Expand the “IDE ATA/ATAPI Controllers” section of the Device Manager and look for the AMD SATA Controller, which is currently managing your system drive.
2. Right click onto the Controller and choose the “Update Driver Software” option.
3. Then choose “Search for Driver Software on my Computer” > “Let me pick…”.
4. Hit the “Have Disk” button and browse to the suitable AMD RAID driver files.
5. Double click onto the correct *.inf file and force the installation of the related RAID driver.:
6. Ignore all warnings, that zou are going to install a not matching driver.
7. While doing the required reboot enter immediately the BIOS and set the AMD SATA Controller to “RAID”.
8. Save the altered BIOS setting and reboot.
9. Now you should boot into the OS in RAID mode and all your RAID array partitions should be visible.

Good luck!

Windows determines that my current driver is best and refuses to install the RAID driver.

I think it would have to be done by manual edits and file copies.

You have to force the installation of the "wrong" driver by hitting the "Have Disk" button.

Doesn’t allow it. Just returns the message above.

Which driver version did you try to install and which *.inf file did you select?

ahcix64s.inf

The only way to force it more would require a bigger hammer. :wink:

ahcix64s.inf


If you really want help, you should answer my questions.
I wanted to know the exact name and version of the AMD RAID driver, which you have tried to install.
Additional question:
The driver of which device (please post the device name) within which Device Manager section did you try to update resp. to change?

Motherboard http://www.gigabyte.com.au/products/prod…spx?pid=3567#ov

AMD SATA RAID Driver (Preinstall driver, press F6 during Windows* setup to read from floppy) 3.3.1540.33 0.38 MB 2012/10/25

http://www.gigabyte.com.au/products/prod…spx?pid=3567#dl
Content of the ahcix64s/ahcix64s.INF file:

; Copyright 2013 Advanced Micro Devices, Inc.
;
[Version]
signature="$Windows NT$“
Class=SCSIAdapter
ClassGUID={4D36E97B-E325-11CE-BFC1-08002BE10318}
CatalogFile=ahcix64s.cat
Provider=%ATI%
DriverVer=03/11/2013, 3.8.1540.11
;

[DestinationDirs]
DefaultDestDir = 12 ; DIRID_DRIVERS

[SourceDisksNames]
3426=windows cd

[SourceDisksFiles]
ahcix64s.sys=3426

[ControlFlags]
ExcludeFromSelect=*

[Manufacturer]
%ATI%=ATI, ntamd64.6.2

[ATI.ntamd64.6.2]
%NapaDesc%=Napa_Inst,PCI\VEN_1002&DEV_4392&CC_0104
%NapaDesc%=Napa_Inst,PCI\VEN_1002&DEV_4393&CC_0104
%NapaDesc%=Napa_Inst,PCI\VEN_1022&DEV_7802&CC_0104
%NapaDesc%=Napa_Inst,PCI\VEN_1022&DEV_7803&CC_0104

[Napa_Inst]
CopyFiles = @ahcix64s.sys

[Napa_Inst.Services]
AddService = ahcix64s,0x00000002,Napa_Service_Inst, Napa_EventLog_Inst

[Napa_Service_Inst]
ServiceType = %SERVICE_KERNEL_DRIVER%
StartType = %SERVICE_BOOT_START%
ErrorControl = %SERVICE_ERROR_NORMAL%
ServiceBinary = %12%\ahcix64s.sys
LoadOrderGroup = “SCSI Storport"
AddReg = pnpsafe_pci_addreg

[Napa_EventLog_Inst]
AddReg = Napa_EventLog_Inst.AddReg

[Napa_EventLog_Inst.AddReg]
HKR,EventMessageFile,%REG_EXPAND_SZ%,”%%SystemRoot%%\System32\IoLogMsg.dll”
HKR,TypesSupported,%REG_DWORD%,7

[pnpsafe_pci_addreg]
HKR, Parameters\Device, EnableQueryAccessAlignment, %REG_DWORD%, 0x00000001
HKR, Parameters\PnpInterface, 5, 0x00010001, 0x00000001
HKR, Parameters,BusType,0x00010001,0x00000008
HKR, Settings\CAM, EnableALPEDisableHotplug, 0x00010001, 0xffffffff
HKR, Settings\CAM, EnableCCC, 0x00010001, 0x00000000
HKR, Settings\CAM, CCCTimeoutValue, 0x00010001, 10
HKR, Settings\CAM, CCCCompletionValue, 0x00010001, 32
HKR, Settings\CAM, NCQEnableDiskIDBits, 0x00010001, 0xffffffff
HKR, Settings\CAM, EnableHIPM, 0x00010001, 0xffffffff
HKR, Settings\CAM, EnableDIPM, 0x00010001, 0x00000000
HKR, Settings\CAM, EnableHDDParking, 0x00010001, 0x00000001
HKR, Settings\CAM, CAMTimeOutValue, 0x00010001, 0x00000005
HKR, Settings\CAM, EnableAN, 0x00010001, 0x00000001
HKR, Settings\CAM, EnableAPS, 0x00010001, 0x00000000

[Strings]

;Localizable Strings
ATI= "Advanced Micro Devices, Inc."
Desc= "AMD AHCI Compatible RAID Controller Driver"
NapaDesc= "AMD AHCI Compatible RAID Controller"
ATI_Raid_ControllerDesc= “AMD RAID Console”

;Non-Localizable Strings

SERVICE_BOOT_START = 0x0
SERVICE_SYSTEM_START = 0x1
SERVICE_AUTO_START = 0x2
SERVICE_DEMAND_START = 0x3
SERVICE_DISABLED = 0x4

SERVICE_KERNEL_DRIVER = 0x1
SERVICE_ERROR_IGNORE = 0x0
SERVICE_ERROR_NORMAL = 0x1
SERVICE_ERROR_SEVERE = 0x2
SERVICE_ERROR_CRITICAL = 0x3

REG_EXPAND_SZ = 0x00020000
REG_DWORD = 0x00010001

SPSVCINST_ASSOCSERVICE=0x00000002


EDIT by Fernando: I have set the posted complete content of the INF file into a “spoiler” (to save space within this thread).

@ Yani:
You still haven’t answered my question regarding the device name, whose driver you have tried to update.
Additional remark:
Are you sure, that the AMD RAID driver, which you have tried to install, definitively will support the AMD RAID Controller of your system?
Have you compared the HardwareIDs of your on-board AMD RAID Controller with the HardwareIDs, which are listed within the ahcix64s.inf file?

I’m not sure what I’ve missed here.

The RAID is part of the motherboard. It was working perfectly under Win 8. It did take a bit to understand the various bios and other setting initially.

The way it is set up the boot disk must be on the primary set of 6 ports. As it boots from an SSD that requires the SSD to be set as “RAID Ready” in the disk set up utility.

In any case I have been using it for over a year under Win 8.

The device name is
IDE ATA?ATPI Controllers
Standard SATA AHCI Contoller

Yani

This is an AHCI Controller and not an IDE or RAID one.
Please check the HardwareIDs of the listed "Standard SATA AHCI Controller" by doing a right click onto it and choosing the options "Properties" > "Details" > "Property" > "HardwareIDs".
Furthermore look into the "Storage Controllers" section of your Device Manager (if this section is listed at all). Which devices are listed there and which HardwareIDs do they have?

Hardware IDs IDE ATA/ATAPI

PCI\VEN_1002&DEV_4391&SUBSYS_B0021458&REV_40
PCI\VEN_1002&DEV_4391&SUBSYS_B0021458
PCI\VEN_1002&DEV_4391&CC_010601
PCI\VEN_1002&DEV_4391&CC_0106

Under 'Storage controllers’

Marvell 91xx SATA 6G Controller (2 copies both with a yellow ! triangle)
PCI\VEN_1B4B&DEV_917A&SUBSYS_B0001458&REV_12
PCI\VEN_1B4B&DEV_917A&SUBSYS_B0001458
PCI\VEN_1B4B&DEV_917A&CC_01018F
PCI\VEN_1B4B&DEV_917A&CC_0101

Marvell 91xx SATA 6G Controller
PCI\VEN_1B4B&DEV_917A&SUBSYS_B0001458&REV_12
PCI\VEN_1B4B&DEV_917A&SUBSYS_B0001458
PCI\VEN_1B4B&DEV_917A&CC_01018F
PCI\VEN_1B4B&DEV_917A&CC_0101

Microsoft Storage Space Controller
Root\Spaceport

@ Yani:
Thanks for the HardwareIDs of your SATA Controllers.
My conclusions:

  1. Your AMD SATA Controller is obviously running fine in AHCI mode.
    I do not recommend to switch it to “RAID” mode from within Windows. If you want to install Windows in RAID mode, you may have to integrate or load a suitable AMD RAID driver
    The only thing you can do is to install an original AMD AHCI resp. AHCI compatible RAID driver instead of the generic MS AHCI one, but I doubt, that you will benefit from this action.
  2. Your on-board Marvell SATA Controller is currently running in IDE mode, but obviously not properly working.
    I recommend to uninstall the listed copies of the Marvell SATA Controllers from within the Device Manager, to reboot and then to look into the “Storage Controllers” section of the Device Manager again.

Question: Which HDDs/SSDs/Optical Drives are connected to the Marvell SATA ports of your mainboard?

"Which HDDs/SSDs/Optical Drives are connected to the Marvell SATA ports of your mainboard?"
Usually it is the DVD and a removable HD. I see no need for those Marvell RAID drivers. The Marvell post don’t seem to accept any boot device which is no big deal.
I have to get the RAID disks working as they have all files on them. Should I delete the Marvell stuff and attempt to install the AMD RAID drivers in their place?

Yani

No, this will neither work nor solve your problem.

This is what I recommend to do (don’t worry about your RAID5 data!):
1. Create a bootable USB Flash Drive containing your special sort (32/64bit, Home/Pro) of Win10 by using the tool named Rufus.
2. Save your important personal data, which are currently on your SSD (containing the boot sector and the system drive C:).
3. Unplug all your HDDs and Optical drives.
4. Enter the BIOS and set the AMD SATA Controller to “RAID”.
5. Boot off the USB Flash Drive and start a fresh install of Win10.
6. If your SSD should not been automaticly detected, load the appropriate 32bit resp. 64bit AMD RAID driver.
7. Delete all SSD partitions, which are shown by the Win10 Setup.
8. Choose the desired size of your future system partion and install Win10 onto it.
9. Once the OS is up and the internet connection works, run Windows Update and install all offered updates.
10. Make sure, that there are no devices with a yellow flag listed within the Device Manager. If required, install the missing drivers via WU or manually (if you know and have the matching drivers).
11. Shut down and power off your computer.
12. Reconnect all your HDDs and Optical Drives to the same ports, where they are connected now.
13. Power on your computer and let it boot into the freshly installed Win10.
14. Now the OS should automaticly detect your RAID5 array incl. its partitions and data.

Good luck!

That’s what I’m avoiding of course as I do graphics, web design and video editing and have a mountain of software installed. Software with multiple updates.

Yani

It is your decision, but this is the safest way to get access to your RAID5 data.
Additional benefit: You will get a much better performance, because you start with an absolute clean OS and the latest Software versions without any old garbage.