win 11 corrupted after update

My aunt’s laptop (DELL VESTRO) stopped working after a recent standard windows 11 update.
It’s restarts to a black “Updating your PC” screen to a black “Restarting” screen and then shuts down and infinitely repeat. I’m not sure what more can i try.
I tried to uninstall the update via windows repair tool and it didn’t help.
She didn’t backed up the PC or made a restore point.
Is there anything else to do before reinstalling windows? and if not, how can i get her office license on the new OS if i cant boot it? I’m able to boot an external OS to retrieve any files.

Try to look on the product model support page, to see what was the update about.

Its seems that most likely, the cmos was reset and specific bios configuration was reverted, this can cause the storage controllers to change mode and one of these behaviours is like you described.
Ex.: RAID to AHCI, UEFI to Leagcy, etc…
What’s the origin of her office license, OEM, Retail Key, Digital key…
Maybe attached to MS account, etc

EDIT: I didn’t said to change anything… i said it could be something similiar, you dont even know if its a SATA SSD, NVMe or HDD…

Its for education, not sure what the origin was and she doesn’t ether.
I tried booting the OS on my laptop and the error reproduced.
From RAID to ACHI it wouldn’t boot, from UEFI to LEGACY it didn’t found boot option other then the microsoft repair tool on an external thumb drive

EDIT: Its an NVME drive, as you suggested i tried to change just in case (with no success).
it was a good idea to make sure i didn’t miss any thing and i thank you for it and asking for more advise on how to get the OS repaired or extracting the product key and office license for a new OS.
as for the update, my cousin was no help, i don’t know what it was for