Win 7 on AMD Ryzen Athlon 300U / Lenovo L340-15API (81LW0086RK) + road to a working ELAN touchpad?

This instruction tells the initial Win 7 setup on a Ryzen laptop and how to get “AMD I2C Controller” driver working, in hope that you will find out how to get a touchpad working - touchpad that’s hiding behind this “AMD I2C Controller” aka ACPI/AMDI0010 device. Touchpad itself has ACPI/ELAN0628 or similar IDs, and may have the following markings on its’ main chip: Elan 33380C-3100 1931 BTS1982W. Please share your steps here if you’ll succeed!

1) During the installation of Win 7 (took the Gen2 version if it matters) - on some stages, and after the installation - the USB ports aren’t working, so you can’t use the USB mouse or copy the files from USB flash. Also, the network controller drivers aren’t installed from the box. So, you’ll need to boot from a Linux LiveUSB (i.e. Linux Mint 19.3 - it has absolutely everything working from the box!), download the AMD_Chipset_Software 2.04.04.111 and DriverPack Solution (offline version with network drivers included), then copy this stuff to a Win 7 partition and reboot to it. By the way, Win 7 boots successfully only at 50% attempts: sometimes it freezes at the very beginning (obvious from a stuck animation of Win 7 logo) - in this case you have to turn off/on by the power button.

2) After booting to an installed Win 7, using a keyboard go to “Ease of Access Center” - and, using the Tab/Arrows/Space/Enter keys, in a section “Make the keyboard easier to use” choose the “Turn on Mouse Keys” then in subsection “Set up Mouse Keys” adjust the sensivity to a maximum. After that, while a Num Lock is turned on - you’ll be able to control a mouse cursor by 12346789 numpad buttons - move a cursor, 5 - left mouse button, + - right mouse button. Then, after a real USB mouse will work after getting the USB ports work, you’ll need to disable this virtual mouse by pressing a Num Lock again - so that it doesn’t interfere.

3) Install the AMD Chipset Software 2.04.04.111 and the network drivers from DriverPack Solution. Then you need to download and install r04qa01w.exe - A) link (suggested in a “B)” thread) - although it’s from Thinkpad A275. However, if you’ll just launch “C:\AMDI2C\dpinst64.exe” (because a setup.exe refuses to launch) - then on a device ACPI/AMDI0010 it will attempt to install a Win 10 driver which will not work. But, if you’ll go to “C:\AMDI2C\Packages\Drivers\SBDrv\I2C”, you’ll see three folders: W7, W764A, WT64A. Take a amdi2c.cat and amdi2c.sys from W764A and copy them with replacement to a folder WT64A, and after that launch this dpinst64.exe again. It will install the Win 7 x64 drivers for ACPI/AMD0010 on ACPI/AMDI0010 - and, surprisingly, it works! :slight_smile: Maybe these devices are really the same, just a different ID.

A) download [dot] lenovo [dot] com/pccbbs/mobiles/r04qa01w.exe
B) forums [dot] lenovo [dot] com/t5/%D0%A1%D0%B5%D1%80%D0%B8%D1%8F-300/Lenovo-IdeaPad-320-%D0%BD%D0%B5-%D1%80%D0%B0%D0%B1%D0%BE%D1%82%D0%B0%D0%B5%D1%82-%D1%82%D0%B0%D1%87%D0%BF%D0%B0%D0%B4/m-p/4000025?page=2
C) forums [dot] lenovo [dot] com/t5/%D0%A1%D0%B5%D1%80%D0%B8%D1%8F-300/lenovo-ideapad-l340-15api-%D0%B8-win-7/m-p/4578755?page=1#5044490

After that, behind a ACPI/AMDI0010 I see a ACPI\ELAN0628 touchpad (ELAN company). Downloaded the 6yst09af09mc.exe drivers from this laptop’s section on Lenovo site - and, regardless of Windows 7 mentions at .inf files, drivers couldn’t start up correctly even if you’ll add a line “%ELANHIDDeviceDesc% = ETD_HID_Group9_WIN10_Inst, ACPI\ELAN0628 ; ClickPad for LCFC L340 AMD Picasso platform” to a file “C:\ELAN_Touchpad\ELAN_22.4.18.1\Source\ETD.inf” - it’ll run into “not enough resources (code 12)” problem. Also I’ve tried to install the Win7 drivers Synaptic, which I found by searching at DRP site by searching a string ACPI\PNP0C50 (it was mentioned in Compatible ID of ELAN0628 and I hoped they’re compatible) - but touch still doesn’t work. Any suggestions?

As for the Vega 3 graphic drivers for Athlon 300U 's integrated GPU ( PCI\VEN_1002&DEV_15D8&SUBSYS_380817AA&REV_C5 ) : I’ve got them by modding the “Win7-Radeon-Software-Adrenalin-2020-Edition-20.4.2-Apr23” drivers for Win 7 / RX Vega 56 , using this video’s instruction - youtube [dot] com/watch?v=4gq-FZGB5yo . Basically:



Only issue is that AMD control panel doesn’t open (works in a system tray but crashes before opening the interface) - but the video driver is working OK and the games are flying! Hopefully canonkong would do a better mod of this driver (see a " win-raid [dot] com/t5648f52-Solution-Win-Win-x-Ryzen-APU-Video-driver-Update-Vulkan-OpenCL-API-support-3.html " thread) for a working control panel. Driver for a multimedia controller (audio over HDMI ?) has been installed by auto-find from the unpacked AMD drivers folder - in a similar way but without any modifications.

Now, with this work and some help from Driverpack Solution for boring stuff like the network controller drivers and webcam, all the drivers are present and working - except this crappy touchpad! Please share your tips for a working touchpad here, and especially at win-raid [dot] com/t3802f52-Request-Win-compatible-Intel-I-O-drivers-for-the-Touchpad-of-ASUS-Notebooks-6.html

Hello qmastery, thanks for the resolution. I have same notebook Lenovo ideapad L340-15api and touchpad problem there on windows 7 pro 64 bit, but i have the error code 12 in my device manager((. I took the 6yst09af09mc.exe drivers and open the "ETD.inf". I was surprised, this driver have win7 support, but any Device ID is not written in amd64 directory. The all devices registred in windows 10 directory named " amd64.10.0". I took my device ID and copy to amd64, it is Win7 directory. After that I installed this driver in manual mode, Windows 7 saw the device, but driver not installed, because of error: driver is intended for other version Windows. Further i start found "ETD_HID_Group9_WIN10_Inst" and renamed it as ETD_HID_Group9_WIN7_Inst in all founded positions. After all the manipulations, windows 7 succes instal driver, but after reboot in device manager I saw error: there are not enough free resources to operate this device.error code 12. Is there a solution to this problem?

We have successfully ported the driver to win7, but the win7 system is missing some key files like msgpioclx.sys, and the GPIO driver cannot be driven correctly,so the touchpad can not work on win7,but they can work on win8 above.

Ok. May you please send this ported driver to me by mail: mogilevchikbg@mail.ru, I’ll be very thankful))