Win10 fresh install on NVMe M.2 RAID0 (no drive detected)

Hi there,

I have allready and flawless installed two systems with:
Z170 Chipset (ASUS Z170 Deluxe, ASRock Z170 Extreme7+)
2x Samsung (950 Pro 500GB on ASUS, SM951 500GB on ASRock) in Raid0
Windows 10 Pro 14393.0 and 14393.447

On ASUS I installed 14393.0 and selected RST-drivers (F6-Files, on ASRock I installed 14393.447 with preintegrated drivers in boot.wim and install.wim (by MSMG-Toolkit).
RAID0 was created in UEFI over Rapid Storage Submenue.

Systems are running smooth and are now updated at 14393.693 with updated RST-drivers

I have another ASRock Z170 Extreme7+
have 2x Samsumg 960 Evo 500GB
Did UEFI Update to 7.30, CSM disabled, Sata-Settings on RAID, M.2 Remapping for M.2-1 and M.2-2, Storage UEFI only, created Raid0 in RST-Submenu, Info says bootable,
Created USB-Stick with 14393.693 and integrated 15.2 RST drivers.
No drive is shown to install at.

Alternative tries:
14393.0 without integrated drivers and driver folder at Stick with RST
14393.447 without integrated drivers and driver folder with RST 15.0 (from Intel Site)

Secure Boot enabled and disabled same behavior,
CSM Disabled and enabled with UEFI only same behavior.

Any hints?!

How and into which WIM files did you integrate these Intel RST(e) drivers?
Did you try to load these drivers separately?

Have you already watched >this< YouTube video?

Did driver integration in boot.wim and install.wim (and winre.wim in install.wim):

Mounting all indexes,
Dism /Image:D:\Win10\Mount /Add-Driver D:/Win10/x64/Drivers /Recurse
In folder were RST-Drivers

Did same with MSMG-Toolkit from Mydigitallife.
(Toolkit only uses Index 2 of boot.wim)

It worked in two cases, i am curious why it doesn’t work with 3rd Board, which is the same like the 2nd board.
So it can’t be the image.
Maybe Bios-Revision or Bios settings.
Or maybe Samsung 960 Evo instead of the previous used 950 Pro and SM951?!

Edit2: (Solution - but why?!)
After downgrading UEFI of ASRock Board, install worked flawless!

After install of Win10 on RAID0 upgrade of UEFI let system still work. It was only an installation issue…