Win2k on T61

Hello guys,

I’m trying to install Win2k on my T61, but my attempts failed and led me to this forum (used win-lite a few years ago and found out Fernando is running his own forum now :smiley: ). I tried from here and from here and every time I get the message (during install with the BS while loading the drivers) that the iastor.sys file is corrupted/damaged. First attempt was trying to install without any AHCI drivers and I very fast was informed that I don’t have any hard discs attached to my device.

My t61 is type 7661 with webcam, 1440x900 Resolution, 4GB RAM and a 2,60GHz T9500 C2D (should be 965PM ICH8M, if I’m not mistaken). If I’m missing something just tell me.

Thanks in advance

@ SuDoDmz:
Welcome at Win_RAID Forum!

Usually this message indicates, that you have integrated or loaded a textmode driver with a wrong architecture (here: 64bit driver for a 32bit OS). This does not work!
If you should have chosen the correct 32bit Intel RST driver and got the message nevertheless, I recommend to try the modded 32bit Intel MSM driver v8.9.8.1005, which you can find >here<. As far as I remember there was a user, who reported, that he only succeeded with the W2k installation in AHCI mode after having integrated a driver, which belongs to the Intel Matrix Storage Management (MSM) platform.

If you want to get any Windows OS installed in IDE mode, the Intel SATA Controller has to been set to "IDE" mode. Unfortunately the BIOS of mobile system usually does not offer this option. Then you have to stick with the "AHCI" mode and use an OS with Intel AHCI support or to load/integrate the missing AHCI driver.

It would be better, if you would be sure about the Southbridge of your system resp. the DeviceID of the on-board Intel SATA AHCI Controller. You can check it by a test installation of any post-XP Windows OS (example: Win10 TP).

Dieter (alias Fernando)

Well, I deleted the files already, but I’m hell’a sure they were 32bit drivers!
And I’m also hell’a sure it’s the ICH8M, just had a look in IDE ATA/ATAPI Controller, I have the ICH8M Ultra ATA Controller and the ICH8M-E/M SATA AHCI Controller :slight_smile:
Aaand my t61 supports Legacy IDE mode, I didn’t try though, because I have an UltraBay Adapter and want to install 2k on drive 2 (currently 1, because I need the bay for the DVD drive) and 7 on drive 1 :smiley:
Thanks for your help Fernando, but it idn’t work (yet, hopefully).
How shall I proceed?

What means "it didnt work"?
What exactly have you done and what happened?

It still keeps telling me that the iastor.sys is corrupted/broken. I downloaded driver from your link and integrated it with nlite (fresh 2k copy in a folder → point with nlite to folder → enabled drivers and bootable iso → chose single driver → pointed to one of the two inf files in the directory of the driver and chose ICH8M and ICH8M-E/M → created and burnt it down, after that boot from cd)

Which size has the iaStor.sys file, which you have integrated into the W2k image?

That may be a dumb question, but where can I find the file? Or which one do you mean? The infs I pointed to in nlite? when I type iastor in the searchbox it only shows me some files called iastor.sy_ (in different directories) with a size of 166kb (if that’s what we need)

Within the driver folder, to which you navigated nLite while trying to integrate the Intel AHCI driver into the W2k image.

These are the files, which have been compressed by nLite. What I want to know is the size of the uncompressed source file named iaStor.sys (this is the real driver).

Aah, now I see. You mean the folder I downloaded from here. The size of IaStor.sys is 324kb (exact size: 323 KB (331.288 Bytes), size on disc: 324 KB (331.776 Bytes))

Ok, this verifies, that you really have integrated the correct 32bit driver.
Then I do not understand, why got the message, that the file iaStor.sys is corrupted.
Maybe you should re-download the driver or try to get it from another source.

Finally found a solution (my bad, sorry): lenovo was already offering win2k ahci drivers on their support site (v7.x) tried them with nlite and it worked like a charm. Thanks for your help and efforts Fernando :slight_smile:

Thanks for your feedback. I didn’t know, that the Intel MSM drivers of the v7 series do support W2k.
Lenovo offers the Intel MSM driver v7.0.0.1020 dated 02/12/2007. If you want to use a newer driver, you probably can update without any problem to the attached Intel MSM driver v7.8.0.1012 dated 09/29/2007, which supports your Intel ICH8M SATA AHCI Controller as well.

Enjoy your Lenovo P61 notebook running Windows 2000 in AHCI mode!

Intel_MSM_Driver_v7801012.rar (175 KB)