Windows 10 and Intel RST Drivers and Console

My previous motherboard died so I did a clean install of Windows 10 on an ASRock Z77 Exteme4 with a 2 drive RAID Mirror (using Intel RST). I realize W10 includes Intel RST Drivers v13.2.0.1022 but I’m interested in having the RST Console on a permanent basis. To make a long story short, after several attempts to install RST drivers from Intel’s website, the Console refuses to run. I’ve tried searching the forums but after reading about driver versions, compatibility issues, driver mods, etc., I’m at a loss and could use some help. Although a speed increase would be nice, my priorities are stability and to have the RST Console but I’m not sure where to go from here. Any help would really be appreciated. Thanks for reading.

Still trying to figure this out but have some additional info.

I didn’t realize this before but Windows Pro and Enterprise are the only two versions that include RAID drivers… I have Windows Pro. Each time I install Windows, I leave my 2-Disk RAID Mirror disconnected so nothing accidentally happens to the data, then shut down, connect the RAID and boot back into Windows. The first time I installed Win 10 (on the previous motherboard) I subsequently went into Disk Management, imported the RAID drives and they worked. I did the same thing this time, but this time they were imported automatically. The drives work fine and as far as I can tell I have no issues.

One thing I can’t figure out is what drivers Windows Pro is actually using for my RAID Mirror. I don’t see any iastor*.* processes running and the only iastor*.* files are in the Windows\WinSxS folder<br />
Next I went into Device Manager > IDE ATA/ATAPI Controller > Standard SATA AHCI Controller and selected Update Driver Software. I had every RST driver from v13.1.0.1058 thru v15.2.0.1020 in a separate folder with each RST_x64.msi extracted to a subfolder. When I went through the motions of installing v13.1.0.1058, it said that driver was older than the currently installed version. But every other version, from v13.2.4.1000 thru v15.2.0.1020 only listed Intel(R) 8 Series Chipsets or higher. I expected that to happen with the more recent versions, but not with v13.6.0.1002.

Then I tried to install a couple drivers by running the SetupRST.exe file but the same thing happens as before. When done, I reboot, the RAID drives are still working, the RST Console Icon says the drivers are not running, and everything else looks the same. Looks to me like Windows 10 Pro prevents any other driver from taking over and the RST Console won’t work with the drivers that came with Windows Pro. But I don’t understand why it worked with the same version of Windows on my last motherboard… both Z77 chipsets.

Will one of the modded drivers work? Curious if they’ve been tested with Win10 Pro.

@65Cobra427SC :
Welcome at Win-RAID Forum!

Here are my comments:
1. All Windows 10 Editions contain the Intel RAID driver v13.2.0.1022, which will be installed and running automaticly, if you do a clean installk of Win10.
2. If you want to updatre the Intel RAID driver from within the Device Manager, you have to open the “Storagte Controllers” section, right click onto the listed Intel SATA RAID Controller and choose the “Update driver software” option.
3. If you want to update the Intel RAID driver and to get access to the Intel RST Console, I recommend to download the “Intel RST(e) Drivers & Software v13.2.8.1002 WHQL” and to run the installer.

Dieter (alias Fernando)

Thanks Fernando for helping. Here is where I’m at…

Microsoft Storage Spaces Controller does not contain an ‘Intel SATA RAID Controller’ entry. The only entry within that location is “Microsoft Storage Spaces Controller”. The only entry similar to the one you referred to is “Standard SATA AHCI Controller” which is under “IDE ATA/ATAPI controllers”.

Not sure why the difference but just to clarify, I’ve never run, or even accessed MS Storage. And the motherboard BIOS is set to AHCI, not RAID. Haven’t used the RAID setting since XP :frowning:

Since I wanted the RST Console, I downloaded the “Intel RST(e) AHCI/RAID Drivers & Software Set v13.2.8.1002 WHQL” driver from the “Latest/best RST(e) v13.2 Series drivers” section of your website.

I checked the Windows Features and verified the box next to .NET 3.5 is checked but not the boxes next to “Windows Communication Foundation…” which is apparently okay from what I read online. I rebooted anyway but I’m not sure if it’s supposed to be “running” or how to check. I don’t see it listed in Task Manager.

Next I Ran SetupRST.exe and a Window opened…
Intel(R) Rapid Storage Technology Failure
The setup ended prematurely because of the following error:
This platform is not supported.

Attaching log file.

2017-01-07(b) IntelRST Log.txt (15.8 KB)

@65Cobra427SC :
It seems to me, that you haven’t turned the Intel SATA Controller within the BIOS to “RAID”. This is absolutely required, if you want to get access to your already existing Intel RAID array.
Maybe you will not be able to boot into the OS after having changed the SATA mode to “RAID”. In this case you may havbe to repair the boot sector or even to do a fresh install of the OS.

Sorry to disagree but setting the BIOS to RAID is NOT a requirement to creating a RAID in Windows. Nor is it a requirement for using the Intel RST Drivers. My current 2-Disk RAID Mirror is functioning perfectly at this moment and I’ve been doing it this way since Windows 7. Setting the BIOS to RAID is just another “method” of creating a RAID setup. It’s been since referred to as “Fake RAID” because motherboard manufacturers had users believing it was a replacement for those high end (read expensive) RAID Controllers. But it’s not, because it doesn’t offer the protection of a RAID Controller, which is the only “true” hardware based RAID setup.

So, in reference to my situation (since Windows 7 that is), even though I’ve never set the BIOS to RAID I’ve always been able to setup a 2-Drive RAID Mirror in Windows. But this is the first time I’ve not been able to install the Intel RST Drivers/Console. I checked some old notes and it appears I only installed Windows 10 once before… it was 4 days before the free update offer was going to expire, which I think was in July 2016… which would have ben performed as an upgrade from Windows 8.1. Since this install was the first installation from scratch, and it’s the only one that won’t let me install the RST Drivers and/or Console, the issue lies with Windows 10 sensing the RAID Mirror being connected, activating the built in drivers, and blocking any further changes unless you know the secrete :slight_smile:

I haven’t given up, especially considering I can run more tests via images of my hard drives, so I’d be more than happy to give any ideas a shot.

The Intel RST Software incl. the RST is only installable with Intel Chlpset systems, whose Intel SATA Controller is running in AHCI or RAID mode and managed by a matching Intel RST AHCI or RAID driver.


My motherboard has the Intel Chipset, the system is running in AHCI mode and the drivers included with Windows 10 are from Intel… I checked the properties of them all. Yet, neither the Intel RST Drivers or Console will install… not even using the modified drivers.

Something is preventing those Intel RST Drivers from installing. It can’t be the drivers from Intel since I’ve attempted to install drivers created before Windows 10 was even released. So the problem has to do with Windows 10. But it can’t be Windows 10 in general or it would be a problem with everyone. So it either has to do with a difference between performing an upgrade vs clean install, or with specific versions of Windows 10 since I’m running Pro.

I still have images of Drive C: from my prior upgrade and will take a look at it.

No, Win10 doesn’t have any in-box Intel AHCI driver, just an MS one.
If I understood your previous post correctly, you have combined your SATA drives to a Windows Software RAID and such RAID is not supported by any Intel RST driver or Software.
If you want to use an Intel RST AHCI driver and the Intel RST Console Software, you should break the existing Software RAID and let its former members been managed as single SATA SSDs running in AHCI mode. I am pretty sure, that you will be able to get the matching Intel RST driver and software properly installed without any problem.

My bad… thanks for pointing that out Fernando.

So would the ACHI driver be the MS AHCI Storport Miniport Driver (storahci.sys)?


I started to say I made progress but still have an issue… but by the time I finished typing what I wanted to say, the issue corrected itself. So now I think everything is okay but have a couple questions.


Extracted the files from SetupRST.exe (RST_x64.MSI, RST_x86.MSI,

Then extracted the files from RST_x64.MSI (iaStorF.sys,, iaAHCIC.inf, iaStorA.sys,, iaStorAC.inf) in case I needed them separately.

Ran RST_x64.MSI but didn’t reboot when it finished.

Went to Device Manager > IDE ATA/ATAPI > “Standard SATA AHCI Controller” (my only entry at the time) and updated the driver

Selected the “iaAHCIC.inf” file I had previously extracted, then rebooted.

The “Standard SATA AHCI Controller” is now “Intel(R) 7 Series/C216 Chipset Family SATA AHCI Controller” :slight_smile:
And the slight lag I noticed before, while accessing my raid mirror seems to be gone :slight_smile:

I knew my installation wouldn’t install the RST Console so the next thing I did was run SetupRST.exe to take care of that issue. The problem I still “had” was the RST Console saying the drivers were not running, but that has since changed and everything is looking good.


When it comes to the properties for my hard drives in Device Manager, everything still looks the same… fairly generic like it did before… even with the two drives being used in my mirror (Western Digital 3TB RED NAS Hard Drives). For example, driver version is 10.0.10586.0 dated 6/21/2006 (yes, 2006) and there are no new entries under the Events tab after the install and reboot. Is this correct, or is there something else I still need to do?


Everything is correct, nothing needs to be changed.
My comments:

  1. The only interesting sections within the Device Manager regarding the in-use IDE/AHCI/RAID/NVMe drivers are the “IDE ATA/ATAPI Controllers” and “Storage Controllers” ones, but not the “Disk Drives” section.
  2. The HDDs/SSDs, which are listed within the “Disk Drives” section of the Device Manager, are managed by the MS drivers named msisadrv.sys and isapnp.sys. The related INF file is named machine.inf, whose date hasn’t been changed by Microsoft since 2006. Nevertheless this file is brandnew, which can be verified by the shown version 10.0.10586.0, which is nothing else than the current official Windows 10 version 1511 Build 10586, which has been released in November 2015.