Windows 10 x64 + Raid 0 + GPT

Hi all,
I tried to install Windows 10 x64 on my SSD raid 0 in GPTmode but it failed. Works fine in MBR mode.

My mobo : P8Z77-V Deluxe (latest bios)

What I did :
- secure erased my samsung 840 pro x2 ssd OK
- set raid 0 OK
- installed Windows 10 in MBR mode OK
- installed latest IRST driver x64 OK
- installed and used Paragon partition manager to convert MBR to GPT OK
- reboot et set Bios in UEFI mode, CSM enabled, secure boot disabled, fast boot enabled OK
- raid 0 is first boot device OK

My raid 0 refuse to boot. I had to convert GPT to MBR for my pc to work.
I’m confused… Could you help me please ? Thanks for reading !
Sorry for my English…

@ waxounet:
Werlcome at Win-RAID Forum!

The problem is the boot sector of your system drive, which had been created in MBR mode and obviously could not been converted to GPT by the Paragon Partition Manager.
You may try to correct the boot sector by booting off the Win10 image and using the Repair function, but this is what I would do:
1. Backup your important files.
2. Break your RAID0 array.
3. Secure erase both SSDs.
4. Recreate the RAID0 array.
5. Install Win10 x64 in GPT mode.

Dieter (alias Fernando)

Hi Dieter,
thanks for your answer !
When booting on Win 10 installation usb flash, I tried Shit+F10 to open CLI and used Diskpart : which refused to convert MBR to GPT before starting installation.
I wonder if raid 0 and GPT are compatible…

They are! I have very often successfully installed Win8/8.1 and Win10 in UEFI mode (using the GUID Partition Table) onto different Intel RAID0 arrays.
Important: Your USB flash drive with the bootable OS image has to be formatted with the FAT32 file system (NTFS doesn’t work, if you want to install an OS in UEFI mode).

OK Dieter I’ll try this way, thanks !

Hey Dieter thaks a lot ! It works ! See U !