Windows 11 22h2 intel ethernet driver issue

i being using windows 11 for 4 months now recently i notice slow downloading speed on desktop while my smartphone connected to the same router has no issue of slow downloads . i have 500mpbs unlimited plan with no caps from my isp.

the speedtest on windows 11 desktop connected lan cable shows the result in range of 18-20 mbps max as a downloading speed

while the speedtest on smartphone connected to wifi 6 5ghz shows the result in range of 390-450 mbps

need help in improving the downloading speeds

According to my own expriences with slow PC internet connections it seems very unlikely for me, that your problem is caused by the in-use Intel Ethernet driver.

  1. To which device (directly to the router or via repeater) is the patch cable connected?
  2. Which Router and which Intel Ethernet driver version do you use?
  1. its a fiber connection with a optic cable coming from isp end to the g-pon box which has cat5(i think) cable whose both ends are of rj45 that goes to wan port in router and the lan port cat5 connects to my desktop directly .

  2. router name :asus rog rapture gt-ax 11000 and ethernet port on mobo. is Intel(R) I211 Gigabit Network Connection
    sorry english is not my first language so there will be alot of grammatical mistakes

My advices:

  • Do some Speedtests on different locations to find out the reason for your problem.
  • Take CAT7 patch cables for the LAN connection.
  • Make sure, that you use the currently latest Intel Ethernet driver for Intel(R) I211 Gigabit Network Connections, which is v13.0.14.0.

i tried out most of the server location on speedtest the result were similar, i also did speedtest on ubuntu live by making pen bootable this was the result

the lan cable came with the router itself is there a way to check if its cat7 or not ?
i recently updated ethernet driver but the issue still remains
Screenshot 2023-02-16 194247

So its OS related, trash apps, specific app settings, hacked settings, something you tweaked and dont remember now, etc etc…
Its not the LAN port its, not the driver, not the router, get a spare disk and do a clean Win install and check it… you may get a surprise and see that was a user action or a corrupted/tweaked old Windows.

EDIT: Sure why not, its only a slow disk, as long as you can install a clean OS on it and boot from it, its fine, its only for testing…

EDIT: Google is your “friend”… your task, your time not mine.

i have 1tb external hdd will it help if i fresh install win11 on it ?
at the moment my only internal ssd has current win 11 and other internal hdd are out of space

the windows 11 installation wizard wasn’t letting to install win11 on flash drive
i also tried making windows to go with rufus but it kept running on errors
is there any other way i can install win 11 on flash drive ?

Just came across this thread as it was new for me, replying to a question you made about the category of your Ethernet cable, it’s not a Cat 7; I mean, it could be, but it’s very unlikely that a cable bundled with a router is that kind of cable (it’d be 5e, 6 perhaps). In any case, cable categories are usually printed on the cable outer layer itself along it.

Cat 7 cables were mainly done for 10 GbE, they are stiffer, braded and shielded usually already at that category.

As for the testing you did in a live Linux environment, you have discarded the problem being your machine’s Ethernet card, the cable itself and your router and upstream connection; it looks fine to me. Like @MeatWar said, it is setup related, something is interfering in your Windows setup, whether it is the driver, some traffic shaping app, limiter, balancer or whatever I don’t know; but it’s the only variable left.

As for Windows to Go, officially it was sunset several releases ago in Windows 10, don’t recall exactly when, but unofficially it can still be done (last I tried was with a W10 21H1 or thereabouts), never on 11, but I remember booting off of some Thunderbolt port wasn’t taking it, I needed to boot off of a USB 3 (different path / controller / driver thing for sure).

Get a copy of 10 and give it another shot in a W2G through it, or try 11 again perhaps booting from a different USB (just not 2.0, or you’ll die waiting haha, it’s perfectly possible though).

@JRMoore @MeatWar
thank you for explaining it well , the printing on the cable says “data cable ftp 26awg 4pair awm pvc 75oc eia/tia-568b” if that means anything i don’t know. my router supports 2.5gbe so it would be cat 4-5 i guess. that cable is quite stiff and thick compare to g-on box lan cable

after some tries i was successful in make my 1tb external hdd in win11 windows to go
i also had made my 64 gb flash drive in windows to go but it was started giving me page file space error and its showing only 32gb as a storage so can’t change page file also it was way damn slow even though is usb 3.0 i had to wait like 50 mins for it to load windows fully . ooh similar issue like thunderblot happened with me that i tried my otg converter and connected it to usb c port but it won’t show up in bios i thought the separate controller would give boost but my system just saying no lol

windows 11 on my 1tb external hdd was way fast it was like booting from internal hdd some relief and it went smoothy installed all the drivers . ran the speedtest well speed was fluctuating but result were all above 250 mbps (avg. 400 mpbs +)so i don’t know what should i do next . should i wait for 23h1 update to hope it fixes or is there a way to change settings

i will also be testing out vivetool gui app on 1tb external hdd in order to recreate same problem there

Generally two possiblities- someone/something messed with your settings or someone/something is using your bandwidth extensively so that those 10 to 20 MBit/s is just the rest of bandwith left to you.

Someone/something-was it you or an uninvited guest?

For Windows settings I’d recommend as a first step resetting winsock and/or tcp/ip stack (if you don’t have very special network- settings or very special applications with corresponding firewall rules for example).

thank you for replying i tried both cmds and speedtest shows no changes .

update : so recently i was cleaning /dusting my mid tower outside after a long 5-6 month period . then i tried to boot my pc but it was giving 0d error code on motherboard display qcode i know this is very common with my pc as it gives some error after cleaning her
i tried to check all the connections for loose grips nothing worked it was giving same error .

so i remove 1 ram stick 1x8gb from it and pc booted up no errors codes but windows was acting up strangely i had to check other ram stick is defective or not so i showdown the machine and change the stick luckly both the sticks was working .

i found out the last slot for ram is not reading it in start ,eventually i figured out inorder to make both ram stick work i had to lock all the 4 latches (side latch) well successfully booted os with no errors but i had to hard reboot and jump to system restore point inbetween to load up windows as it was giving alot of troubles running on just 1x 8gb ram stick
the start doesn’t work
the search doesn’t work
the windows app store doesnt open up
the snippingtool doesn’t work
mspaint don’t open basically most of microsoft app won’t work

but hey that speed issue got fixed :sweat_smile: atleast something good came out of it