Windows 7 - classpnp.sys hangup on Modern Ryzen (B450)

I’ve had Windows 7 Enterprise installed on my system as much as I care to count, but suddenly I’ve been unable to install, or boot into it more than once.
Every other time I tried to clean install it, it would do as such with minimal hassle, the most annoying thing that I would have to do in order to do a successful install was me having to bundle USB 3.0 drivers into the installation media to be able to use the mouse + keyboard during the install. I like to keep my computer clean even software-wise, so I do system wipe-ups very often, but, when I tried to re-install Windows 7 it wouldn’t let me, keeping me from proceeding with the installation with an error message that said: “A Required CD-DVD Driver is Missing” even though I don’t own any CD-DVD drivers and the USB drivers were present.

Being persistent as I am, I installed Windows 10 and tried to make a bootable .VHD with Windows 7. I created the VHD file and installed Windows 7 within a VM (VirtualBox) and added the VHD file into the msconfig boot options (using the bcdboot command in cmd). As I boot into the VHD everything runs completely fine until the first reboot. As I rebooted my computer, the Windows 7 VHD installation started to freeze in black screen state right after the Windows logo animation. It wouldn’t boot no matter how long I waited so I decided to reboot into Windows 10 to check if the VHD file as fine and to my surprise the Windows 10 installation wouldn’t boot either. In order to boot into any Windows again I had to run a disk repair. I noticed that this bug usually happens when Windows 7 is loading the CLASSPNP.SYS file (checked that trying to boot into safemode with no success).

That said, I’ve already installed Windows 7 on the same system numerous times before with no problems whatsoever. I didn’t do any updates regarding the BIOS or change my hardware. Does anyone know what’s happening?

CPU:AMD Ryzen 1600
MB: Gigabyte B450 Gaming
GPU: GTX 960
Storage: 1x SSD 240GB, 2x 500GB HDD


A missing CD/DVD driver? sounds like an AHCI or RAID driver issue.

is your system configured in a RAID?

Nope, AHCI as always.


Since you have the USB 3.0 driver integrated try making a bootable USB install media and try installing it that way.

That’s how I’m doing it. I can’t fathom why this is happening, I don’t even have a CD/DVD drive, and never even connected one to my machine.


Maybe try something like Easy2boot and see if that works?

put your modded windows 7 ISO in the windows 7 folder that Easy2boot creates and see if that gets around your problem?

Easy2boot will make a RAMDrive out of your ISO so this might get around your problem.


Will do, but the thing is even if I successfully install it, I wouldn’t be able to boot into it because of the aforementioned hang ups on the boot screen. The most weird thing is, if I boot into Windows 7 it doesn’t work and also breaks my Windows 10 installation. I’ve never seen this before, never ever… I don’t know what’s causing it, I have some ideas like the CLASSPNP.SYS driver BUT I’m not able to pinpoint the issue.

Update: I managed to get my Hard Drives recognized by the Windows 7 installation media, but every time I boot into it, or even start up the installation media, Windows 10 won’t boot until I run a disk check. Any ideas?


I think Microsoft’s old MSAHCI driver on windows 7 must handle drives in such a way that Windows 10 doesn’t like.

You could try the backported windows 8.0 STORAHCI driver, that is targeted at XP though.

Windows XP 32-Bit and Server 2003 32-Bit on Modern Hardware (527)

Thanks. Going to take a look on that.

Update: It seems like it isn’t classpnp.sys fault. The Windows boot up just hangs as soon as the last driver loads, that being the classpnp driver.

To fix the CD DVD driver issue, try using a different USB port. Does diskpart see the HDD/SSD AND USB Drive?

You need to integrate the drivers into both Boot.Wim and install.wim