Windows 7 on UEFI Class 3 not working, comet lake i5 10210U

So here’s something. I have a laptop here, the specs are here if needed:


Intel Comet Lake series laptop i5-10210U
Intel UHD Graphics 620
Shipped with Windows 10, did get update for Windows 11
512GB Kingston Nvme SSD, also 1TB HDD from unknown make.
UEFI Class 3 only, no CSM support, at all.

My goal was to get Windows Vista or 7 up and running on this machine and I’ve basically scowered the entire internet at this point to try and figure out some sort of way to do this. Firstly, I decided to try my luck with 7 right from Windows 11, but of course it failed pretty much immediately.

Then, I decided to test Windows 8.1. I used Rufus to flash an 8.1 image to a 8gb USB I had, and then I botted into it. Windows 8 installed with no issues whatsoever and when it booted, stuff like the Wi-Fi and iGPU were not working properly, but the OS was running decently regardless.

Then, after days of searching I found working Comet Lake drivers that supposedly give graphics support to any 10th gen intel cpu, even on Windows 7. I tried them on Windows 8.1, and surprise surprise, they actually worked. Windows 8.1 now had graphics support. I also found an internet driver pretty much immediately after installing the OS, so that was working from the start as well.

After all this, Windows 8.1 on this laptop that should be running Windows 11 is actually very nice to use. It lags much less than 11 does and all programs open instantly. I’ve really enjoyed using Windows 8.1 on this.

But Windows 8.1 was never the goal, it was 7 or Vista. So, I began efforts to get 7 working. After finding a Windows 7 ISO with a Windows 10 PE, I attempted to run this but it didn’t work after it passed the first phase of setup. It threw an error for winload.efi.

So, I found UEFISeven, which I have installed on this device, and managed to get it running on the second portion of the driver (the HDD). After the installation would fail, I would go into Windows 8.1 and open the HDD and put in UEFISeven. Then I go back to the BIOS and choose “select EFI to boot” and then I’d click on the UEFISeven file.

It would work. The Windows 7 boot screen would open and the dots would connect and the logo was formed. But then it just did nothing, it just entered this screen of death where the animation is playing and everything, but Windows isn’t booting.

I entered safe mode, and discovered it has failed after loading ahcix64s.sys. I deleted this file from System32 in the HDD and it now failed at amdlog.sys. After deleting that too, it failed at disk.sys. These files were right next to each other in the boot menu, so it seems that if I delete one, it just fails at the one before it.

I added them back and then tried these things:

  1. Running a different ISO
    Didn’t work, I installed from many sources but none worked…

  2. Trying different UEFISeven versions.
    Apparently this worked for some people with the similar issues, but not for me :frowning: I couldn’t get it to work.

  3. Using a different acpi.sys.
    This apparently also has some effect but I didn’t see it. If you have your own acpi.sys, please give it to me and I will report if it worked.

Overall I’m really lost here. Windows 8.1 installed so perfectly it seemed evident that Windows 7 would, too. But because of UEFI, it is extremely difficult and I have no idea how to get Windows 7 on this machine. Maybe someone has some mod or anything I can carry out? I would love to get it work.

Anyone has a solution??