Windows 7 won't recognize ADATA XPG SX6000 NVMe SSD

After installing MS hotfix for NVMe support on Windows 7 my ADATA won’t appear neither in “My computer” nor CrystalDiskInfo/Mark even though in the device manager everything seems to be fine (ADATA NVME SSD is recognized and listed next to my HDD, there is also a “Standard NVM express controller” listed in the “Storage Controllers” section). I can also see this drive in the BIOS boot section. I can’t find any drivers provided by ADATA. My computer is Acer A515-51G with 100-series Intel Chipset. What can be wrong? Thanks in advance for any help.

The problem seems to be solved but in a way that doesn’t satisfy me.
I tried to install WIN7 in UEFI mode on this drive using WIN10 boot.wim and setup.exe (with MS NVMe support hotfix integrated with WIN7 image). I was able to complete the installation of WIN7 on this ADATA NVMe SSD, but the system won’t boot from this drive after the required restart at the end of the installation (EFI\Microsoft\Boot\BCD error). What is surprising - after this attempt I have now access to this SSD drive via my HDD legacy WIN7 system (I can see It now in “My computer”, it contains WIN7 folders from the installation that won’t boot). My case is also described here:
Problem with Windows 7 installation on Acer A515-51G-54TZ (Kaby Lake)

@Salamandra :
If you want to get full NVMe support while running Win7, you should integrate the related MS NVMe Hotfix into the boot.wim and install.wim of the Win7 Image.

@Fernando :
Thanks a lot for your reply!
I have tried to integrate this hotfix into both .wim files, but I’m somewhat confused: when I replace boot.wim from WIN10 should I still integrate this hotfix into it (after this replacement)?

@Salamandra :
The Win10 boot.wim contains already the NVMe driver. So there is no need to integrate the NVMe Hotfix into it.

That is why I wasn’t sure. Thank you!
Integrating MS hotfix into both install.wim and boot.wim (without replacing boot.wim from Win10) works very well for my NVMe SSD and Windows 7 legacy.

MS NVMe Hotfix for Win7 doesn’t available anymore.

@afil - KB3087873-v2-x64 + Windows6.1-KB2990941-v3-x64 attached below, install both, then reboot and NVME will be recognized by Win7 (676 KB) (5.92 MB)

@afil :
Microsoft doesn’t offer anymore the NVMe Hotfixes for Windows 7 and Server 2008 R2, but they are still available within this Forum.
You can either use the ones, which were attached by Lost_N_BIOS, or use the download links from >this< Forum post.
Note: The Hotfix KB3087873-v2 is only additionally required for old Win7 Images up to SP1 (fixes a possible 0x0000007b BSOD issue), newer Win7 Images from SP2 up only need the Hotfix KB2990941-v3.


I had Win7 on HDD and install KB3087873-v2-x64 and KB2990941-v3-x64. Then I clone system to Adata GAMMIX S11 Pro 1TB.
ADATA SSDToolBox does not support Win7 and show wrong smart.
I tried to install generic or samsung NVME drivers, but system said you already have the best driver.
I uninstall both MS NVMe hotfixes.
Of course, system cannot boot up now.
I’ve tried to install generic and samsung NVME drivers through Dism and pnputil.
Drivers were successfully installed, but system still can’t boot.
I have 2 questions:
-how to install NVME driver into my fail system?
-how to correct update NVME driver in Win7 when it will works?

p.s. sorry for my english please.

@afil :
It was a big mistake to uninstall the MS NVMe Hotfixes. Now your OS obviously doesn’t have access to any usable NVMe driver.

Nevertheless you would have been able to replace the generic MS NVMe driver by by forcing the installation, that means by hitting the “Have Disk” button, navigating to the desired driver and double-ckicking onto the *.INF file.
The message you got indicates, that you haven’t imported the Win-RAID CA Certificate before you tried to install any of my mod+signed drivers (this is absolutely necessary, if you want to get a modded storage driver installed).

If you had imported the Win-RAID CA Certificate before you made your OS unbootable, you can try to boot off the Win7 Image, to use the "Repair" option and to load the desired mod+signed NVMe driver.

By manually updating the driver of the related "Storage Controller" from within the Device Manager. If you want to replace the NVMe driver by a mod+signed one, you have to import the Certificate about the trustworthiness of the Digital Signature before you try to update the driver and not uninstall the in-use NVMe driver.

@afil - This SSDToolbox / SMART info is a ADATA issue, same with newer models of that disk and Win10 too
All you need is the hotfixes I linked (or at least v3 one as Fernando mentioned), other drivers will not help with the toolbox issue, except maybe Samsung one but it’s slower than MS Default one (I confirmed both of these items myself with SX8200 PRO).
If you need to see SMART info, use other SSD tools like SSD Life or general info tools like HWINFO64/AIDA64 etc

How can I do it? Could you please explain step by step?

@afil :
If you should mean the procedure how to import the Win-RAID CA Certificate, please read the start post of >this< thread.
Regarding the “Repair” option of the OS you have to boot in UEFI mode off the previously used bootable Win7 DVD/USB medium and to choose the “Repair” option, when you are asked, whether you want to install or to repair the OS.
Then you will get the option to load a suitable storage driver to detect the system drive.

Nothing helped me. I just reinstall system.