Windows Vista on i9-9900k Z390

Hi there. I’m trying to install Windows Vista on a modern PC:
MSI Z390 Gaming Edge Ac
RTX 4070

But you have some troubles.

  1. First of all, when I trying to boot MSDN version of Windows Vista and it immediately shows 0x000000A5 error (parameter1 0x00000D) ACPI is not compliant
  2. Then I found a tutorial to modify acpi.sys. I tried to replace modified ACPI.sys (and update checksum), but again A5 error message appears.
  3. Then I found Windows Vista Extended Kernel image, and somehow it was loaded into the installation. It even shown all hards disks. I start installation and after first reboot, on second stage of installation it again shows A5 error. And this error was the same as error when I tried to boot OG MSDN Vista image. It’s very strange, because it successfully loaded into the installation.
  4. Then I noticed, that ACPI.sys file in boot.wim and install.wim has different Versions. Boot.wim has and install.wim has. Is it possible, when installation is loaded it uses boot.wim acpi.sys version, but when the send stage of installation begins it uses another driver with the old version?
  5. I tried to replace acpi.sys file from boot.wim to the hard drive with Vista installation files (second stage of installation), but the error message appears, it says acpi.says is corrupted. Is there a way to integrate ACPI.sys into Windows Vista image? I mean in the the second stage of installation? If you know the answer please help me.

Or maybe the main reason is not aspi.sys file? Maybe it’s RAM or other hardware? Which hardware can also cause A5 error? Thank you

Hi, Roman, welcome to the Win-Raid forum (ala Fernando)!

I don’t think anything except acpi incompatibility can cause 0x000000A5. If you’re sure that acpi.sys from boot.wim is compatible (the compatible file version must be 6.0.6002.24312), a possible solution could be load boot.wim and install.wim in NTLite, open unpacked folders in explorer and copy the file from boot to install, then build iso again and try to install it. However, it should have the same effect with replacing acpi.sys of an already deployed image. Another necessary step could be replacing C:\Windows\System32\DriverStore\FileRepository\acpi.inf_###\acpi.sys, but I’m not really sure. I’m attaching acpi.sys with the compatible version both in original and modified (hex edit and rebuilt checksum) states. Hopefully, my answer was helpful, let us know how is it going! By the way, your channel definitely has too few subscribers :slightly_smiling_face:

Edit #1: I forgot to mention one thing, but remembered thanks to u/Moline. You might have to disable Driver Signature Enforcement by spamming F8 wile Windows Boot Manager is being loaded and select the respective option.

Where did you find the ACPI modding tutorial at? I have a Lenovo laptop with 11th Generation Tiger Lake that cannot run Windows 7, even with a modded ACPI whereas 8.0 works with those same modifications and 8.1 just works without any mods needed. Also, after you mod ACPI.sys, you need to press F8 to load up the Startup Options. Scroll down to “Disable Driver Signature Enforcement” and select it. Sometimes, a black screen with white text will pop up saying the digital signature of the file cannot be verified, but other times, it will just repeat the BSOD if driver signature enforcement isn’t disabled, so you must make sure you disable that via F8 options first.

Also, try Windows 7. Unless your motherboard is unique, you will need a modded ACPI.sys for 7 as well. Luckily, you can grab that from this kit: Precision7530

This ACPI.sys does not require an F8 keypress to disable driver signature enforcement as it is already signed. It also contains Fastbootpro’s bootmgfw.efi (rename the original one to bootmgfw.original.efi before moving this one in). Use only those two files when trying out 7. If 7 works, then you either need to press F8 and DSE after installing Vista and moving in the modded ACPI.sys, or the standard ACPI mod isn’t enough for Vista.

This sounds very similar to my problem with Windows 7 on my Lenovo IdeaPad (which has Tiger Lake): Vista/W2k8 x64 on Modern Hardware - Microsoft Windows Vista - Forums

My post is in that same thread. Basically, if Windows 7’s ACPI.sys can work with that patch, then we would somehow have to port Windows 7’s ACPI to Vista. This wouldn’t work, even with the Extended Kernel, as there are loads of dependencies ACPI.sys relies on, and if we’re thinking about backporting ACPI.sys, we might as well use 8.1’s ACPI.sys as that one is much improved compared to 7’s, and even Vista’s, and 8.1 does not get the ACPI BSOD, unlike 8.0 and earlier.

Earlier you said that your laptop couldn’t run Windows 7 even with modded acpi.sys. Are you sure that you didn’t bypass 0x000000A5 and it’s not another error?

It is not another error. I use the modded ACPI.sys and attempt to boot, but the A5 error is still there. Of course, the BSOD flashes too quickly for me to read, so I have to video tape it and stop it at the time the BSOD appears, where I can then see the A5 error. If I mod the ACPI.sys within 8.0, I can load its installer fine. Of course, Windows 8.0 doesn’t appear to have built-in NVMe drivers, which I find weird, as my NVMe drive wasn’t picked up by it (but is picked up by my Windows 7 ISO, which uses a Win8.1 PE for setup part 1, and my Win8.1 ISO)

That’s weird, modded acpi.sys worked fine in my case

I edited my original answer, take a look

Hello. Thanks for your feedback. I appreciate it. I’ve tried to add acpi.sys using nLite, but nLite doesnt work properly with Windows Vista Extended Kernel image, it just crashing.

But I have good news!
I have succeeded with installing Windows Vista on Intel i5-124000F CPU and Asrock B660 HDV motherboard and 64 Gb of RAM! The reason was the “clock circuts” or “driftting issues” which Intel has in 4-11 generations. Looks like this was the main reson why A5 error appears. Vista is also can run on i3-12100 and i7-12700k. The proof you can check here Windows Vista on the Intel Alder Lake Platform - EclecBoard
. I was film the video about it, it will be uploaded in English soon on my Ramtech ENG channel. Thank you guys. Also thanks to Bernardo Souza, who sent to me Vista Extended Kernel.

Have a nice day!

That’s insane! To be honest, I didn’t know these could cause 0x000000A5. By the way, do you remember attempting Windows Blackcomb? What if you try to install those builds on that 12th generation CPU?

Most likely outcome seems to be 0x0000007B. You could try using Uni Ata, but the results are unpredictable, either they are with modified Ahci drivers by Fernando

Hi. I’m not 100% sure that “Clock circuts” can cause A5 error. Yes, I’ve tried Windows 7 Blackbomb two years ago in this video (, but it also went to A5 error.

Recently, one of my subscribers, told me, that he succesfully run Windows Vista on i9-9900KF and Gigabyte Z390 Aorus. To do it you need to integrate modified acpi.sys file into Windows Extended Kernel SP2 image using nLite (or vLite), disable CSM mode in BIOS. I did it and tried to boot in UEFI mode on my MSI Z390 and 9900KF, but it’s stuck on “Windows Loading Files”. If I try to boot in CSM mode, the error message A5 appears. Maybe I need to change something in BIOS, idk. Also I’ll try to skip the first stage of installation using WinNTSetup, let’s see what will happen.

By the way the second video about Windows Vista installation is ready. You can check it here

Thank you