Working RX 480 no signal when used with new motherboard - Hybrid ROM issue?

Hi all,

I recently upgraded from an FX-4300/ASRock 760GM-HDV/8GB/RX480 setup to a 10400F/ASUS Prime H410M-E/16GB setup. I intended to use the RX480 again but to my disappointment, no matter how much troubleshooting I’ve done, I cannot get a display output signal when I use the RX 480 on the new setup. I’ve previously tried another motherboard as well.
For more info - the previous Mobo I tried was the Gigabyte H410M S2H; the one I have now is the ASUS Prime H410M-E. The GPU is a Radeon RX 480 8GB (reference model, but from Sapphire - SKU 21260-00).

I’ve confirmed that the RX 480 still works (in another PC which now holds the FX4300), that all the new components work (which I did by testing with a 560 Ti and a Radeon 4550). It’s specifically just the combination of new setup+RX 480 that doesn’t work.

A week’s worth of Googling and troubleshooting (including, yes, fiddling many times with any and all mobo settings that mention CSM/UEFI/Legacy/Secure Boot/etc haha) has brought me here, as it’s been suggested to me that this may have something to do with the Hybrid ROM of the 480, and this search has brought me to threads such as:
ok no link because I’m too new, but I’m referring to a thread entitled “How to disable UEFI for legacy only boot on recent AMD Radeon GPUs” by user drbob.

My two questions are fairly straightforward:
1. What’s the chances this is actually the cause of my issues, and that modifying the vBIOS would fix it?
2. If the answer to the above is yes, how hard would it be to go about doing this as someone with no experience whatsoever?


The RX480 its a modern hw gpu card…it should work straight on in ur new setup CSM ON or UEFI.
Enough PSU power on new setup?
Unless the card is offended or modified…for example, mining settings/bios.
Presumably ur H410 has lastest bios updated…if not do it.
U can try flash a vbios from Techpowerup (Same OEM/DEVICE HW IDs, same OEM memory part) or u can try to update the GOP driver first, but the GOP is only used in UEFI boot so…

EDIT: The u should report Sapphire/Asus, dont expect that Asus gonna do anything about it or give u anything related to bios motherboard but… For Sapphire u should insist, maybe they can offer u a new vbios.
As i told u before…GOP has only influence in UEFI system, but here’s the link to main thread and link to latest version post
AMD and Nvidia GOP update (No requests, DIY)
AMD and Nvidia GOP update (No requests, DIY) (84)

Thanks for your response MeatWar!
I’m aware that it should work - hence why these last two weeks have been as…confusing and annoying as they have been haha.

As far as the PSU, I have to assume it’s enough; I have two PSUs that I’ve tested on, one being a 600w and the other a 500w. The RX480 was running on the FX4300 system flawlessly using the 600w PSU for multiple years, so I’m unsure that this could be causing issues.

The 480 has not been modified in any way - it was purchased new many years ago and has since only really been used in the AM3+ platform setup.

I have updated the motherboard to the latest BIOS, after trying with the one it arrives out of the box from. No change.

As far as updating the GOP - would you (or someone else) be able to point me to where I could do that? Apologies for the request; I’ve stumbled onto GOP updater utilities/tools on this forum, but don’t know enough about this all to know if this is correct for me - should I just use the latest GOP Updater posted by user Sylar76?

I have tried both modifying the rom from the GPU using drbob’s guide. Didn’t brick the card, but didn’t fix the issue either. Afterwards I reflashed back to my backup of the original rom, then tried the GOPUpdater, which again didn’t brick the card…but also didn’t fix the issue :smiley: