x58 eclipse

Hi guys and girls,

This is my first time trying any bios mods (for mobo) and my first post so im not sure all is done right so correct me please if i did something wrong.
I was gifted a pc a few days ago with a x58 eclipse motherboard. Online i could read that nobody seems to be able to get this motherboard to post with a x56xx class xeon in there yet: on hwbot user named basthijs has some scores with this combo (cant link). seems to work. Now some more googling later tells me that there was supposedly a 1.16/1.g beta bios for this board yet its impossible to find. So people recommended to inject the cpu microcode to the bios manually. I have not found anywhere online anyone who did this succesfully so i wanted to try myself. i downloaded mm tool and used a guide: How to Update CPU Microcode in an AMI BIOS on delidded.com (cant link). Yet after comparing the bios of the x58 eclipse (x56xx support) and the x58 pro-e (known to have x56xx support) it seems that the x58 eclipse has the same cpu support and 2 more microcodes in there. Since at this point I’m in way over my head i came here to ask for help is there any way i could try to mod this bios or should it already support these cpu’s? The bioses i used were the latest from msi’s website:

pro-e: cant link (1.f/1.15)
eclipse sli: cant link (8.f/8.15)

The cpu id of all 6 core x58 cpu’s xeon x56xx, w36xx and i7-970/980x/990x are 206c2 (cpu-world). The microcode id’s and platform id’s in both bioses are equal (in MMtool) so yea that is all i got. Is there anyway to tell which microcode id supports which cpu?

[[File:Schermopname (2554).png|none|auto]]

Left is the x58 pro-e and right is the latest x58 eclipse sli bios.

Hope anyone could help me out or give me some more insight into this thanks in advance.

Schermopname (2554).png

@koelopawa - Update to 2015 or 2018 version (1D -2015 or 1F-2018), anything after 0F/13, otherwise you have bugged uncore (locked x20 uncore, can’t raise or lower), and that should also add compatibility for your Xeon then too
All you did in above was add in older microcode along with existing, that will not help and is not needed. Remove all 206C2, insert 2015 version or 2018 version.
I suggest you insert 2015 version, if you need me to help you do that, please add the links in reply, you will be able to link now on your 2nd reply

You want (only one) - attached below


206C2-2015-2018.zip (20.6 KB)

Thanks a lot for the information. But I think i was not clear i what i meant i did not change anything in neither bios yet the pro-e seems to boot with x56xx xeons and the eclipse doesnt. now i haven’t got my xeon in yet (because im not sure if i should buy one), i understand that makes thing harder. I can for sure buy one just to test, i understand its older microcode because the 206c1 are es samples (at least wikipedia tells me). So just to be clear i did not change either bios (yet,hopefully).

@koelopawa - See edit above, I added the microcodes for you. If you had issue inserting 2015 with MMTool let me know and I will resize it for you
If you do not have CPU then you can’t know if it will boot or not, and you can’t know what BIOS/microcodes anyone else was using in some random thing where they said it works or not for them.
PRO-E would not boot with that BIOS either, if the other one wont, is that latest PRO-E BIOS? If yes, then if the other board wont boot but PRO-E as shown will, it’s due to the older 206C2 microcode being in there, as mentioned, remove both of those and insert 2015 or above, then it will boot Xeon for sure.

What does 206C1 ES have to do with any of this?? Nothing, unless you have a 206C1 ES CPU, if you do, then you need 206C1 microcode in there, and that may need certain older version than what’s in there too, only testing can tell.
1366 CPU’s, especially Xeon, are very cheap these days, no reason to buy ES 206C1, get retail Xeon

Which Eclipse are you talking about here, there is Plus and SLI?

I’m sorry but i think you misunderstood I’m just trying to clearify myself. First of thanks for your help really appriciated i ll try now if i can fix this myself. Second i think i got it the older code in the bios might be the reason it won’t boot.

Now what im trying to clearify I did not change anything anywhere i just found out that 206c1 is for es, im not trying to buy a es but should i delete this/could this prevent it from working nicely with x56xx xeons. Now my information comes from the overclock.net forum where these 2 boards are discussed while being specific which bios both users use. I personally have experience with the pro-e and know it works with the x56xx xeons yet the uncore bug is present (like you said, at that time i did not know there was a microcode fix for that so i never bothered). Yet the other users (more than one) tell that when using the most recent bios 1.f they cant use x56xx xeons in their eclipse. Like i stated i have yet not tried myself (I will and report back to you) also the code shown in the images are unmodified by me just the standerd download from msi.

I ll now order a xeon and see if it boots with the stock bios 1.f if it doesnt which is what i suspect reading online (i know not always what you read is true). I ll modify the bios and report back.

Lost_n_Bios thanks a lot for your help and explaination it helped a lot!

@koelopawa - You’re welcome! And yes, I understood you now after second post above. Yes, remove all 206C2, insert 2015 version at least
You do not need to delete 206C1, it can remain.

Register here, looks like latest beta is 1.1G2 and they discuss works with Xeon/Gulftown etc in that thread

If you can’t get, let me know and I will register and get it for you Or, we can just mod 1F ourselves too later

Downloaded it and will look when i get the cpu, hopefully I dont get the uncore bug . Thanks for your time I also posted your findings on tpu xeon thread because I saw multiple people couldnt find it so more people hopefully find it, although considering the age that wont be many. I did not credit you so if you want I can change that. to be honest nor did i credit myself just stated someone helped me out finding it.

Thanks and if you are interested I’ll report back in time.

@koelopawa - What is the 206C2 microcode in that BIOS? If it’s not 14, or above then uncore bug
You should just upload that BIOS for them over at TPU, that way they don’t have to register to get it. Also, please send me a copy so I can have in case someone needs later, thanks!
No, I don’t care about credit, I didn’t do anything anyway, just found the thread for you in google I knew from past experiance that MSI beta BIOS are newer on that forum usually, vs the ones you can find on the US forum.

Yes, please report back and let me know how it goes

Sorry for the late response i was waiting on a cpu to fit. Got it today so I ll report to you later today or tomorrow if it works. Also forgot to upload the bios earlier, here it is.
I’ll test and report to you in the next 2 days thanks for the time and effort. The c206 seems to be revision 13 so im afraid it has the uncore bug but I’ll try anyways to make sure.

A7520IMS.1G2.rar (1.05 MB)

Have tested the bios today. The xeon works with this bios its just a shame the bios has the well know uncore bug. I’ll see if i can fix it just a little hesitant because i dont have a bios programmer.

@koelopawa - Check what version ME FW is there, if any. You will have to install ME driver first.
If there is ME FW you can dump with FPT and update microcode. Otherwise, you can maybe dump BIOS with AFU, edit, and then flash back with AFU /GAN version (but it’s risky)
Does BIOS have a built in BIOS update routine/tool/method? Ohh! Yes, it’s MSI! You can flash mod BIOS via M-Flash. Edit stock BIOS, make sure mod BIOS is OK, then flash via M-Flash (often needs to be named exact same as stock name.extension)
If you want me to update the microcode for you, link me to BIOS you want edited, or is the above the one you would want modified?

@Lost_N_BIOS So if i understand correctly this is my problem: https://github.com/platomav/MCExtractor/issues/3
So i read up on some stuff since i got 0 knowladge of computers. And i read correctly does it just mean the file size isn’t correct and i need to either delete some hex values at the beginning or the end?

Thanks for your time and/or response sorry if i completely misunderstood te problem.

@Lost_N_BIOS I tried to edit the microcode but the older microcode i extracted is smaller than the new micro code 0x2000 for the old microcode with 400 blanks at the end. But the new microcode is 0x2400 without any blanks at the end so resizing that code by deleting the last 400 hexadecimals does not seem smart/right to me. Any tips? I downloaded some more msi bioses from there website though all have the 206c2 rev13…