X79 platform, Windows 10 Intel RST issues forcing a driver update. But which driver to try?

My system is an Asus X-79 deluxe (X79 chipset with LGA2011 and Intel RST device_ID 2822 in RAID mode, EFI/BIOS). At the time I got it, RST v13 had recently come out, RST/RSTe was an issue, and v12 installers were recommended but needed hacking to install. Fernando, the hacked versions have worked very well, they’ve been solid, thanks! I’m still using and it’s rock solid.

I use the Intel RST driver to allow on-board SSD caching of a mirrored data HDD for heavy data use. (I know, soft raid… but it’s been insanely reliable under Windows 8.1, more than my battery backed LSI 9260, and the file server handles the important backups.

I’m now considering clean installing Windows 10. When I trialled Windows 10 1703 (March 2017 update) using my existing v12 driver, I hit a widely-reported “DPC_WATCHDOG” BSOD issue a couple of hours after starting. Google says this might be linked to the Intel IAStor and IAStorA drivers (I’m using IAStoreA), but perhaps it isn’t. The WinDBG stack was zeroed, no idea which driver caused it. So I might have to upgrade my RST driver.

I have two questions:

1. Is the DPC_WATCHDOG Win 10 BSOD issue fixed by working on the RST driver side, or by a Windows update?

2. I’m confused that the “modded driver” pages say that v15 drivers may not work correctly with X79 and to use v13 or v14 instead (see note under v15). But the “best drivers” page says that the latest 15.7 drivers natively support the 2822 device which this board has. Meanwhile the “performance tests” say to downgrade to v11 for RAID use, although that’s RAID0 and I’m using RAID1 + Trim. I’m happy with the performance of v12.9.4.1000, but should I stay with it on Windows 10, or change anything? What about the GUI controller and any BIOS/EFI module?

If you use SATA mode then on Win10 I would recommend to use stock generic MS drivers. They even started to support and utilize MSI mode. I saw no difference in performance between Intel ones and MS ones.

As a last resort yes, but I’m heavily using the SSD cache+mirroring capability on the RST. So I’d like to find out what options I have (if any), to keep RST on Windows 10, before giving up and using Microsoft’s.

Although I have tested a lot of different Intel RAID driver versions, I have never had a DPC_WATCHDOG BSOD.
If you do a Google search for “WATCHDOG Windows 10 iaStorA”, you will find a lot of tips (e.g. to disable the “Fast Boot” option within the BOOT section of the BIOS).

Due to the unversal external DeviceID DEV_2822 all Intel RST/RST(e) RAID drivers up to the v15 platform are installable onto all Intel Chipset systems from ICH8R up, but nevertheless the v15 platform Intel RST(e) drivers will not fully support your X79 Chipset RAID system.
Reason: The DEV_2822 Intel SATA RAID Controllers of modern Intel 100-/200-Series Chipset mainboards are totally different from the Intel SATA RAID Controller of older Intel Chipset systems like yours. As a consequence all these different Intel RAID Controllers with the universal DeviceID DEV_2822 have different specific internal DeviceIDs, which are layed down within the code of the driver (iaStor.sys resp. iaStorA.sys). It is the driver itself, which is responsable, when it comes to the question, whether a specific system is fully supported or not.

If you are happy with that RAID driver, I don’t see a reason for to change it.

You can use the Intel RST Console Software v12.9.4.1000 and I recommend to put the matching Intel RAID ROM/EFI RaidDriver v12.9.0.2006 into the BIOS.

As a last resort yes, but I’m heavily using the SSD cache+mirroring capability on the RST. So I’d like to find out what options I have (if any), to keep RST on Windows 10, before giving up and using Microsoft’s.

You obviously misunderstood mbk1969. When he wrote “SATA”, he probably meant “AHCI”.
Just to make it clear: There is no MS driver available for Intel SATA Controllers, which are running in RAID mode. The Win10 in-box RAID driver v13.2.0.1022 is an Intel RST driver and not an MS driver like the Win10 in-box AHCI driver.

Yeah, I was meaning AHCI… sorry…

You can’t use a driver that supports device ID 8086:2822 on a device that has ID 8086:2822.
There are internal IDs you have to use. You better ask @Fernando how to retrieve them.

I had very bad issues using driver v14 on my ASRock X79 Extreme4. Version 13 work fine, but the performance is lower.
v15 will not install (unless modded), but I do not recommend it. I stay on v12.9.4.1000 and I have better performance than v13.

PS: DPC_WATCHDOG indicates issues during overclocking. Tell us more, please…

PPS: Damn, I am slow… Should not post during work…

If you are on Win10 then have you tried MS own AHCI drivers? They can have more performance.

Thanks Fernando. As always, amazingly exact and fast. Medal for you I think!

I didn’t know the external model number might hide an internal model difference. ARGH! Maybe it’s worth emphasising that, on those pages.

To be sure I understand, if I install Win10 with Intel 12.9.x BIOS/EFI and RAID mode, Win 10 will select an Intel driver that handles RST anyway, so I don’t have a problem (except maybe to install the GUI front end if I want to)? But it’ll install 13.2.x not 12.9.x drivers so I might have to roll back and manually downgrade them after it’s set up? If that’s correct what is the best procedure to do it? Or should I mod the Win10 install media’s drivers beforehand?

The info I found when I looked up DPCWATCHDOG BSOD on Win 10 was because I saw a lot of these kinds of post.

I’ve also had DPC_WATCHDOG once long ago with Asus AI drivers, but they aren’t installed at the moment.

The same way as usual, but you have to force the installation by using the “Have Disk” button, because the Intel RST(e) drivers v12.9.4.1000 are older and have a lower version number.
There is nothing to worry about, because both drivers (v12.9 and v13.2) have the same structure and the additional SCSI filter driver named iaStorF.sys.

Please tell us if your CPU or RAM is overclocked.

Your mainboard also has ASmedia SATA controllers.
What driver and version do you use? Are there any drives connected to those controllers?
The ports connected to the ASmedia controllers are SATA6G_E5 (lowest of the brown ports, next to the system panel connector)
and the eSATAp ports on the back of your computer.

I had bluescreens because of the ASmedia drivers. I updated them to version 3.2 and everything works fine.
AFAIR I had version which caused the bluescreens, but I could be wrong regarding the buggy version…

I can’t use the MS AHCI drivers, because I use 2x Samsung SSD 840 Pro in RAID 0.

Yes, it’s overclocked. Rock solid stable at about 43x for years. Nothing else is overclocked, it’s otherwise all configured for stability and longevity. Running cool (< 60 degrees) and slightly undervolted in a couple of places, with stability/PLL settings mostly high to extreme and other stability settings (Spread Spectrum etc) set for stability rather than speed. RAM is also undervolted to match Ivy Bridge MMU specification of 1.50v ideal / 1.60v max (1.50v 2400GHz sets of matched DIMMs weren’t available at that time, so it’s using G-Skill top-end @ 2400GHz 1.65v DIMMS running perfectly at 1.53v). Hopefully none of that is an issue.

The board has 6 x Intel, 4 x ASMedia 1061 (2 internal, 2 eSATA) and 4 x Marvell 9230 SATA ports. There’s a total of 10 SATA devices (1 set of mirror+cacheSSD, 1 plain mirror, 4 single SSD/HDD, one DVD) with the 2 mirrors and boot SSD on Intel and only one SSD on eSATA, so without tracing cables I can be sure that I’ve got the Marvell and ASMedia internal controllers both in use.

Any drivers (and I’m sure I would have installed them) will be old. From memory I also updated some ASMedia controller firmware at the time, although I can’t remember if that was the SATA or USB3 controllers or both.

I would have expected to see ASMedia+Marvell somewhere in Device Manager, but I can’t see a specific ASMedia or Marvell storage controller, or AsMedia/Marvell drivers for any disks - in fact I can’t see any controllers other than the one Intel chipset controller, and no SATA devices with drivers other than Intel + Microsoft. To save time, do you know where the ASMedia/Marvell controllers and drivers would normally appear, so I can check versions and update them? Or are there Microsoft versions of them which are ok?

Updated to add detail

If there are only Intel and Microsoft SATA AHCI/RAID drivers, you do not use the ASmedia drivers and should be safe.

All SATA Controllers are listed either within the “IDE ATA/ATAPI Controllers” or within the “Storage Controllers” section of the Device Manager and have the word “Controller” within their name.
The manufacturer (vendor) of the related Controller is not shown unless you have installed a Controller driver from the same company as the Controller (e.g. Intel, ASMedia, Marvell etc.).
If you want to know the manufacturer of a specific IDE or Storage Controller, you can right-click onto it and choose the options “Properties” > “Details” > “Property” > “HardwareIDs”. Then you can see the VendorID of the Controller: VEN_8086 = Intel, VEN_1B21 = ASMedia, VEN_1B4B = Marvell.
The in-use Controller driver can be seen, when you right-click onto the specific Controller and choose the options “Property” > “Driver” > “Driver Details”.

They can be turned off in BIOS.

@Fernando - thanks. That solved the mystery. All the ASMedia/Marvell SATA controllers were indeed under adapters as “standard adapters”, with MS drivers.

@mbk1969 - thanks but I’m actively using them so turning off in the BIOS wouldn’t help. But I expect Win 10 will install MS drivers for them which will fix it, if not there’s probably updated Win10 drivers from the makers.

I also learned more about zeroed crash dumps, it looks like the cause of the DPC_WATCHDOG was probably an out of date network driver not the old RST driver, which is reassuring. The “dps” output for the host crash dump was solid with tcpip references all the way. Sure enough the host had Intel ProWin from 2013, now updated to latest. That might fix the original BSOD issue (we shall see!).

I also now know the position with the Intel SATA drivers, which I’d have needed to ask anyway.

Two last questions -

* If Win 10 installs the 13.2 branch of RST drivers, will my disk setup be intact and can I revert to without any issue? Or should I back it up elsewhere until Win 10 is confirmed stable? (I can’t remember how to check which module version is in my BIOS, or whether to change it if I’m keeping anyway).
* Also where’s good for downloading firmware updates for the ASMEDIA/MARVELL SATA+USB3 controllers, as that probably won’t be a bad idea?

Thank you everyone for helping!

I meant you don`t see them because they are turned off in BIOS. I see you found them by hardware Id.