x99 Huananzhi board cannot reach raid configuration

Hi all,

I am newbie in win-raid forum and this is my first post, so please don’t be angry if i posted this to wrong place.

Starting with my question, I have Chinese Huananzhi x99 board and 4 ssd drives[each one as exactly same models]. I want to make hardware raid setup but i can not reach to configuration screen.

Fast Boot: Disable, Quite Boot: Disable - on CSM everyhting is Legacy
PCH sSata : here is ACHI and just dvd-rom on that 4 black ports
PCH Sata : here i tried Sata as RAID and after reboot pressed ctrl+i and also tried ctrl+(e,r,g,c) nothing happens.

As i understand from what i read from different places on internet x99 boards has 2 Raid controllers. My board has 4 Black ports (firstly i tried these) and 6 red ports also tried these.

I am adding photos to clarify the situation



Last screen is from current status of my pc which is on Sata as AHCI mode. I have installed windows 10 and saw that C600+/C220+ Sata AHCI Controller.

Thanks in advance and Kind regards to all.

@ineedraid :
Welcome to the WinRAID Forum!

Although I don’t have any own experience with an Intel X99 chipset mainboard, here are my advices:

  1. Connect the 4 SSDs to the (obviously red colored) first SATA ports 0, 1, 2, and 3 and set the related SATA Controller within the BIOS to “RAID”.
  2. Provided, that your on-board graphics card has a working EFI VGA BIOS module (GopDriver), I recommend to set the “CSM Support” within the “CSM Configuration” to “Disabled”.
    If there is no GopDriver available, I recommend to allow booting in UEFI mode by customizing the “Boot option filter” and “Storage” settings within the “CSM Configuration” section of the BIOS.
  3. After having stored these BIOS settings, turn off completely your computer for a minute.
  4. Restart the computer, enter the BIOS and search for a previously not available option named “Intel(R) Rapid Storage Technology”.
    If you shouldn’t find it, reboot your computer, enter the BIOS and search for the option again.
  5. Click onto it and create the desired Intel RAID array.

Good luck!
Dieter (alias Fernando)

P.S.: I have moved this thread into the “RAID Performance” Sub-Forum to enhance the chances, that other RAID users with an Intel X99 chipset system will find your request and can help you.

Thank you very much for your well explanation. I have tried almost every combination but with no success.

1. Ok
2. I don’t have onboard grapichs card, sorry about that i missed to provide specifications about my pc.
specs : x99 Huananzhi motherboard without onboard graphics, 4x256GB Silicon Power SSD(there was a text on box raid ready) intel Xeon E5 2678 v3, 4x16gb ddr3 ecc, 1050ti vga.
3. OK
4. Searched everywhere can’t find “Intel(R) Rapid Storage Technology” :frowning:
5. :frowning:

Without a graphics adapter you cannot see anything on your monitor.
Which discrete graphics card are you using? Does it support booting in UEFI mode?

@100PIER :
Can you help regarding the RAID configuration?

I am not sure about it but already wrote on above post, trademark is gainward 4gb gtx 1050ti, there was an option on CSM menu for PCI cards and i tried to set UEFI and for Video as well, after bios screen it does not show anything with these settings. so am i blind there?

i almost forgot about some detail, there is a strange thing on Sata port 2 which you can see from here :



just this port have some option that the others don’t have, DevSlp : Disabled. I also tried with Sata device type HDD and SSD. I changed sorting of them from 0 to 3.

just a little update, i learn that my VGA supports UEFI but that didn’t changed the status.

@ineedraid ,

Here are some screenshots about my two RAID0 SATA SSDs structures configured on a X99 system:

HWinfo_RAIDx99.PNG

W10_Controller_RAIDx99.PNG



They are handled by Intel SATA Controller 1 set in RAID mode. (Controller 2 does handle only SATA in AHCI/IDE mode).

I have build the two RAID0 structures under the BIOS menu (specific sub-menus).
The two independant RAID0 structures are used for pure data storage.

The System SSD storage is a Intel NVMe PCIe V3.0 x4 add in card.

Why your BIOS screen interface is so different than mine ?
If you have any question don’t hesitate.

Hi, my mainboard is rare Chinese brand huananzhi so i assume that it seems different than your bios. Here are some info about bios, Bios Vendor : American Megatrends - Project version x9900 0.27 x64 - Compliancy UEFI 2.4 ; PI 1.3. My guess i need to find some hdmi or DP cable because i am using DVI port of my VGA and recognised that maybe this is the reason why after setting up to UEFI mode there was no display after boot screen. I can enter to bios with del and esc and fast boot options with F7 which is interesting point that i didn’t see that anywhere.

These Chinese boards are somewhat tricky, some of them have overclocking options that don’t do a shit :frowning:

Hi @ineedraid !
Your problem was solved or not?

because i have a Huananzhi X99-F8D and RAID works well.
Maybe i can help you

Paul

can you help me? I can’t activate the raid options