XFX GPU HD 5770 BIOS soldered flashing procedure

Hello all!
First time poster here, I have the CH341A kit and soft ware(not sure of the version I have). Anyway, my XFX GPU HD5770 has the soldered on bios. I been trying to flash it, with the GPU out of a system. The system I’m trying to flash it from has W10 pro, does the GPU require being in a system to work? I got these letters n numbers off the bios chip on the GPU(I think its the bios) “APL5920 then under that BMARV”. I do notice when i go to close my software it hangs, but I can get as far as the 2 lights on the USB pad lighting up but for what ever reason it always says not Equal when I try to verify the flash. Now its getting to the point where the clip is hard to even get on the chip.
I have gone as far as to flash chips on main board with this unit, and it worked. I can even remove the chip but see no way of flashing it after I have removed it. Any and ALL HELP is great, THANK YOU IN ADVANCE! Philly

Not really answering your question, but Video Cards are much easier to flash than Motherboards since even if the Video Card itself is bricked, it is usually possible to flash the EEPROM without requiring a physical reprogrammer or anything like that. Is there any reason why you want to do it via an external reprogrammer? If you have a computer with an IGP or another Video Card, you could try to tell the Firmware to boot with it and ignore the Radeon 5770, then use a Windows or DOS tool to flash it.

Computer wont boot with it in, already tried in wondows that didnt work, sorry didn’t say this before.

@PhIlLyChEeSeStEaK - It may be shorted then, if it wont boot with the card installed while using onboard or another PCI/PCIE card as main graphics.

APL5920 is not BIOS, this is a dropout voltage linear regulator. Show me some images of your card and I will circle the BIOS. So, this would be the main issue you’re having, for now

No, GPU should not require being in a system to flash with programmer, however you do need to find a compatible software version (or software) that will work with the BIOS chip on the card.

Here is all versions of CH341A normal software - http://s000.tinyupload.com/index.php?fil…257455007472602
Once you know which chip is the BIOS, try dumping with all those, if all files are FF or 00 then either you have a connection problem (incorrectly setup, or poor/loose connection, either one could be cause).
Or, software is not compatible with your chip if you know it’s connected properly and the connection is snuggly attached.
Here is another program you can use often if CH341A software is not working for you (which can be the case in Win10 sometimes), ASProgrammer 1.40 - https://github.com/nofeletru/UsbAsp-flash/releases/

Here is guide on how to setup and use so you can be sure you’re connecting it all correctly -
https://www.bios-mods.com/forum/Thread-G…341A-programmer << Same as one directly below, but with all images expanded/visible at once
[GUIDE] Flash BIOS with CH341A programmer

Thank you so much, i had a feeling it may not be the bios. But I couldn’t find a link any where showin one being done. I had before, and i did flash it from inside of windows. But that resulted in 2 big perpendicular lines across my screen, so the BIOS chip is on the cooler side. I will disassemble and post back photo’s tomorrow.


Hope you can get it fixed and it’s just a BIOS issue! Yes, almost always BIOS is underneath the cooler side, on same side as the GFX Chip, so you have to take off heatsink/fan

You’re welcome!

OK, yeah the 8 pin chip that i was trying to flash was on the other side or outside of it. but my computer will not post now as I cleared that 8 pin chip(what ever it is), any suggestions? I do have a junk XFX 6950 I just got was gonna save it but the PCI pin on the PCB got broken in shipping so I can swap that 8 pin chip, is it worth a try? Sorry im not sure how to post pictures here but the chip i flashed was next the the outside X clamp on the back of the PCB .