Y520-15ikbn + Samsung 960 evo = 890 MB/s ?

Ok guys, you’re my last hope: I bought a 256gb 960 evo, and it works perfectly, I tested it in another pc and benchmark gave me 3000 MB/s on read. In the other PC it was detected as a pcie gen.3 x4, but… in my notebook is stuck at gen.3 x1, and peak read speed is 890 MB/s. I literally, LITERALLY tried everything: format, secure erase, bios update, firmware update, clean install, driver selection during windows 10 install, set AHCI in bios, set RST premium in bios, reset bios, tried every freaking setting in bios, tried every freaking possible nvme driver and even pcie controller driver… I tried everything that came to my mind but nothing, ssd still stuck at gen. 3 x1 instead of supported gen. 3 x4 (as crystaldiskinfo, samsung magician and benchmarks keep saying). I don’t know what else I can do… Please guys, if someone have any advice (any, even the most simple one that maybe I didn’t think of) please tell me. I’m in your hand. Thanks in advance and sorry for the poor english

What CPU and chipset does your notebook have?

Also, please link to your BIOS download, I will check and see if some setting (Hidden or not) needs adjusted. How many other HDD/SSD do you have connected to SATA Ports?

Thanks a lot, guys! So, my model has an i5-7300hq, HM175 Chipset, another hdd sata seagate 1,75tb connected to the sata port (tried without and nothing change) and I recently installed versione 4kcn41ww of the bios.
Version 4kcn40ww is the only bios officially linked on lenovo site (probably every other version had problems) and should be the most stable one https://download.lenovo.com/consumer/mobiles/4kcn40ww.exe .
Version 4kcn41ww strangely is still linked, but “hidden” https://download.lenovo.com/consumer/mobiles/4kcn40ww.exe (it seems to have given problems to a lot of people).
My pc came with 4kcn43ww installed, but I downgraded trying to solve and I can’t find 43ww or 44ww (they were relased and removed) anywhere.
Really guys, thanks a lot for your support!

Oh, if someone can please share 4KCN43WW or 4KCN44WW bios it would be awesome

Here is the link for 4KCN43WW.

The HM175 has a less flexible HSIO lane configuration than other 100 Series chipsets due to only having 22 HSIO lanes for the 16 PCIe lanes on the PCH (as opposed to 26 HSIO lanes and 20 PCIe lanes on the Z170 for example).

There are also the 16 dedicated PCIe lanes that come from the CPU that should allow your 1050 Ti to operate at full bandwidth (you can check this with GPU-Z), bringing the total number of PCIe lanes to 32 for the HM175.

Depending on how the 16 PCIe lanes on the PCH are divided up you may have run out of lanes for the M2 SSD, forcing it to operate at 1x.

If you run HWInfo64 you should be able to tell which devices share HSIO/PCIe lanes through multiplexing.

If the M2 slot is sharing with another device you may be able to disable that device on the BIOS to regain those lanes.

Good luck!

Sorry, I’m unable to get proper IFR from your setup module, something in the latency menu form section breaks IFR output, and the menu’s don’t show up in EZH20 like they should either, so I can even take a look at your visible or hidden BIOS settings
I checked 40 and 41, same result. Here is the extracted actual BIOS roms and setup files from both, in case someone else can help get proper IFR output from setup for us - same issue for 43 BIOS too, thanks for the link @chinobino (*Note, 43 is not included in download below, this comment added later, if anyone needs file for that let me know)

I could change PCIE Port configuration lane assignments in ME, and then adjust lane operations, but that may mess other things up doing it that way since we don’t know what port this drive is using (from 1-20), if you can figure that out it may be a safer edit.
It’s much better to edit BIOS settings instead, but that’s proving to be a problem. * Edit, much like @chinobino is talking about above, he replied while I was typing, seems we were looking at the same things regarding lane assignments

Do you only have one port you can connect this SSD to? If not, have you tried them all yet? Does your system have a dedicated graphics card, in addition to the onboard graphics in the CPU?
If yes, can you see settings to set primary display to SG and then disable either internal GFX or PCIE GFX and see if that changes anything. Disable onboard LAN, or wireless LAN may also free up lanes, only for testing for now.

Do you have flash programmer (CH341A or similar), and SOIC8 test clip cable?

Yep, I hoped it was not, but lack of pcie lanes was my main fear. M2 slot doesn’t seem to share pcie lanes with anything else, but there is a lot of hardware running on pcie. I can try to phisically remove some component (wifi card or sd reader), but I don’t really want to lose function. Oh, but with HWInfo I saw something interesting: 1050ti doesn’t run x16 but x8…
Thanks a lot for sharing bios link (maybe I’ll found on lenovo china something else too), for the explanation and for the help!

Thanks for looking into it!
Answering your question: yep, only one m.2 port and one sata port; the notebook has a 1050ti (that seem to have problems too, running x8 instead of x16); I’ll try disabling graphic card and anything else and see what happen, of course; sadly I don’t have neither a flash programmer or a SOIC8, but I can think about buying it.
Many thanks for your explanation and help, very appreciated!

So, I’ll make some other test with new bios and configuration and report. Thanks again!

Pickup a CH341A and SOIC8 test clip cable on ebay, then in 3-5 weeks when it arrives if you are willing to possibly have to take the system apart we can test many BIOS or ME changes.

Thanks, I’ll make the order!


Those are right?

Oh, and can you please send me the extracted 43ww bios or (better) write how can I extract it? Huge thanks!

Yes @Vega206 - those are correct items. Here is 43ww extracted - http://s000.tinyupload.com/index.php?fil…922100333351443
How it’s extracted. First extract the original exe with Innoextract-1.7, this is the tool to extract this type of exe it’s built with Inno Setup. http://constexpr.org/innoextract/


Then you get new Intel Insyde based exe 4KCN43WW.exe, this I extract with “Uniextract - Universal Extractor 1.6.1” https://www.legroom.net/software/uniextract (version 2, from other site, is not as good for dealing with BIOS, in case you look for or find a “New” version)
That gives you stock flashing package and bios.fd.



To get BIOS bin/rom file from BIOS.fd you have to open BIOS.fd in hex editor, search for string $_IFLASH_BIOSIMG, go to the first line after that and the following header, to next line with all FF’s, select from there down to 800000h (So select from 00096010 to 0089600f = 800000h / 8MB / 8192KB)
Copy that and paste to new file, then save as BIOS.rom or BIOS.bin same/same


After only 3 months everything has arrived! So, there are some guides I can follow?

@Vega206 - here is guide with many images so you can get setup correctly

And here is package with the main driver and all the software versions

Make a backup first, before you do any writes! And make sure it’s verified (buffer and chip match), and that it’s valid meaning you open it in a hex editor and make sure it’s not all FF or 00 and that is looks similar to stock BIOS too (Also compare this way with other BIOS tools you’re familiar with)
Or you can upload and I will check it. It’s best to do this for a few reasons, one so you have a known good backup, and two so you can find the correct software version that works for your setup (and sometimes need to find correct chip ID, exact not always best)