Yoga 2 Pro shutdowns every 30 minutes

That seems to have worked. fpt -i below:|addpics|3tg-4-cf5d.jpg|/addpics|

Good. So, you ME region is protected from read and write, and you need to boot in ME recovery mode to be able to rewrite it.
Here is a guide for it, boot in this special mode into DOS and perform fpt -me -d me.bin command, it should work, attach the resulting file.

Here it is.

ME.rar (68.6 KB)

Compress it in .rar or .zip and upload/attach it here. It should be less than 6MB that way and thus easily uploadable. The full image is needed, not a part. And avoid .txt because this forum has some issues with .txt attachments.

Why so? I think, no image is needed, because we have a full $0AH0000.FL1 with a normal clean ME region for this board, and it can be used like this to reflash only the ME, once it’s writable: fpt -me -f $0AH0000.FL1

That seems to have worked. I ran that command with the jumper installed between SDATA-OUT and 3.3V, powered off the laptop, and removed all the batteries for ~5 minutes. When I restarted the computer, windows detected the MEI and I was able to install the intel driver package. Since then, the computer no longer shuts down after 30 minutes.

Thanks a lot for your help, CodeRush and plutomaniac.

@ CodeRush: We said the same thing. Dman8777 couldn’t upload the file initially and attached a small part of the me (for example $fpt + something extra) which makes no sense. But yes, of course, since Lenovo includes a non-stock ME at their SPI image we can relfash that when the descriptor is unlocked.

It’s actually surprising that you managed to disable the ME via the pinmod. Those pins are extremely small on some audio chips nowadays. Enjoy your fixed system.

Hi! Can you help me with similar problem? I have Thinkpad Edge e540. At the start of the system it says “FW status recovery error”. Laptop is working, but with problems like waking up from sleep itself. I can’t get info just like the topik starter. I can’t extract ME from Lenovo’s bios file because it contains only update, not the full image. I tried with HxD editor, with fitc. FITC gives an error.
i can extract ME from file that i dumped from chip, but it’s corrupted as i think?
i also tried to flash dump from the same laptop, but there also problem’s - laptop start to show picture after 15 sec from pushing the button, and then only boot’s up. It;s because of the wrong ME in that dump, i think.

So how to fix this problem? Maybe there is some tool to clean ME region or smthing?

i attached old.bin - file that i dumped from laptop
j9uj23ww.exe - bios from lenovo site

https://drive.google.com/open?id=0B8r-se…T1FEcTJFa1AwVmc|addpics|80e-1-59b2.png|/addpics|

You haven’t attached any files.

As far as I can see, that 08 BIOS is very old at this point. The latest is 23 if I found the model correctly.

What method are you using to dump your firmware? Hardware programmer or software tools (you should have unlocked flash descriptor in such case).

Sorry i corrected file name, and uploaded files via GDrive

System now has newest bios. I used hardware programmer. Also i teried to flash from dos using fpt, but it gave me an error saying that flash descriptor is locked.
I have 2 chips on this system 8mb main and 4mb ec. ME situated in first 8MB chip.

So from what i read on this forum, the only chance for me to short some pins on audio chip to override the lock?

No, no. If you have a programmer, nothing “flash descriptor”-related is of any concern. Since you have a programmer and the required knowledge, we can repair the system’s ME region and, if you want, unlock the flash descriptor so that you can use software tools (FPT) in the future to replace the ME region if need be.

An EC of 4MB is very large. You have two chips (8+4=12MB) and the BIOS is at the 2nd one. At least that’s what I see from the old.bin file. Can you attach programmer dumps from both chips? Also, can you attach another dump of that system from someone else, the one that you said you found?

My mistake, really, you’re right.

Uploaded files to the same folder
https://drive.google.com/open?id=0B8r-se…T1FEcTJFa1AwVmc

- old.bin, ec old.bin - my dumps
- 4MB-W25P32.bin, 8MB-W25Q64BV.bin - another dumps, that i tried to flash (20 secs POST with black screen and then start)
- two zip archives - yet another dumps from the internet, don’t tried to flash them.

I assume the old dumps are before you flashed the other dump, right? I have attached a new old.bin (8MB chip) which includes a) a cleaned+configured ME region and b) unlocked flash descriptor. After you flash it, start the system and run Flash Programming Tool with command fptw -greset and check MEInfo and MEManuf after the reset to verify that everything is ok.

old_fix_me_fd.rar (2.6 MB)



Thanks a lot! I flashed the dump, system starts without errors. i followed your instructions and maked reset with fptw - greset. reinstalled Intel ME driver. It’s strange, but MeInfo and MeManuf gives an error “Unsuported ME Firmware Version 9.0.10.1372 H”. It’s strange because i downloaded the right version (9.0). Will try to use this tools from DOS and upload photos later. System seemed to be working normally. Will see…

Can you explain how you cleaned the ME? I want to know this magic! Any money for that skillz)) Can you answer to the PM?

UPD: uploaded photos…seems something is not ok :confused:|addpics|80e-2-8c8f.jpg,80e-3-3848.jpg|/addpics|

The ME was cleaned with this guide.

Install the latest v11 driver as seen at the first post.

What error is that? Where is it shown? From within Windows, run MEInfo -verbose and MEManuf -verbose and show the results.

There is no error, it’s a fully normal output of MEInfo (last part of it). No signs of any problems there.

Thanks a lot for all your help!

It was memanuf -verbose under DOS at the second photo.
As the CodeRush mentioned there is no problems - the system running normally.

I have the very same problem of sudden shutdown on a Yoga 2 Pro running Lubuntu/Cinnamon and also Windows 10.
This fix seems rather elaborate for the ordinary user. Has Lenovo or Intel gotten involved? Shouldn’t they help solve this very serious issue, without us having to do all the research on this screwup?

@venik212 :
Welcome at Win-RAID Foru!

I totally agree. This problem has to be solved by Lenovo and/or Intel.
Regards
Dieter (alias Fernando)

I have the very same problem of sudden shutdown on a Yoga 2 Pro running Lubuntu/Cinnamon and also Windows 10.
This fix seems rather elaborate for the ordinary user. Has Lenovo or Intel gotten involved? Shouldn’t they help solve this very serious issue, without us having to do all the research on this screwup?

The question is: How does one (or even many users) get the attention of these large companies? I have an Intel NUC (“New Unit of Computing”) that had some serious issues, and Intel went the full course of first denying that there was a problem, then said it was only in Linux, and finally (it seems) after more than 2 years managed to fix it. Maybe here Microsoft has some culpability, too, since several posters mentioned that the problem arose after they “upgraded” to Windows 10. That might be the case for me too, but I cannot be sure of a connection between the upgrade and the appearance of this problem.