Z370 aorus gaming 3 and IDE mode

I have the Z370 aorus gaming 3 and option "IDE/Compatible mode" for SATA is absent in BIOS setup
Currently I know nothing about BIOS modding
Can BIOS modding help to add "IDE/Compatible mode" or this is impossible and no sense in examing this theme?

Sorry my bad English

Why would you want to use IDE mode? It’s probably there, I will check now and edit this post

IDE mode should be gone long ago, maybe 10 years ago it should have disappeared

In most places in your BIOS, I see only RAID or AHCI. But, I do find 1 place with three different entries where IDE is an option as seen in images below (2 sections below what is shown in left image has IDE too)



You may need to enable CSM option, reboot to BIOS and then look again for IDE mode.
Did you look in every page and section, if yes, find CSM enable that and reboot then look again.

I also see it as an option (Many times) in the "Setup" portion of the BIOS, that lays out all the BIOS menus to the user interface


I also see several "IDE" related BIOS modules in the BIOS itself, IDEBusBoard, IDEBusSrc (PCI IDA Mass Storage Device - IDE Bus Driver), ATAPassthru etc.
So it should be an option somewhere, probably only when legacy or CSM is enabled as I mentioned.

IDE mode is required for "modding" of the HDDs firmware…

See edit above. You may need to use another motherboard to modify HDD Firmware’s on, similar to many people setup certain systems to run Xp or Linux on for various firmware editing or testing.

It’s there, but since I don’t have that board I can’t direct you any further on how to enable other than what I edited in above.

If you are talking about modifying this boards BIOS/firmware to run certain HDD/SSD like NVMe, that is not required the BIOS is already setup to be NVMe ready.

I tried to enable CMS, but without reboot, no IDE
Later I will try with reboot, thanks for tips
Only one thing that I need is SATA controller in IDE mode
If no way for this, easier to sell MB,CPU and RAM for me, no sense in second computer

You have to reboot after enable CMS, otherwise it’s not enabled yet. I think you will find IDE though, after reboot once CMS is enabled, look in all places one you reboot.

What are you actually doing that IDE is needed for? Please explain in more depth than “Modding” HHD Firmware.
Or do you mean exactly that, flashing or modifying hard drive firmware such as on a spinning hard disk drive flashing/modifying the actual firmware on the hard drive’s PCB/controller itself?
If so, I can understand that and know what you mean because I know some tools only work in IDE and some only work on certain older chipsets too even if IDE is an option still no good unless certain older chipset for some tools.

Now I’m not near MB, can’t check CMS right now
If I will change the “optimal” value to IDE with AMIBCP, and then will save and write saved image, is there any chance that after clearing CMOS I will got IDE mode enabled?
I’m develop one tool for WD drives repairing, and IDE exactly for modifying the firmware on the hard drive’s PCB/controller

Don’t use AMIBCP without flash recovery tools, it may brick your motherboard. Unless you have BIOS switch to switch to BIOS 2 so you can reflash BIOS 1
And that section is not going to change the default for the AHIC/RAID only place, that is for UEFI loading, the other is for CSM enabled options, which should show up for you once you enable CSM and reboot. You may also need to find and change “OS Type” to Legacy or non-win8 etc.

Thanks for further info on the hard drive modifying, I guess you did mean exactly what you said and I initially didn’t think that due to the way you mentioned it

No result with CMS, IDE mode still absent
OS Type have only 2 option:
Win8-10 WHQL

Looks like I need to buy more older MB/CPU instead of this(
At any case, thanks for your time and help

OS Type still says that after reboot with CSM enabled? You’re welcome, and I’m sorry I cannot better answer directly since I don’t have this board.
Please note, IDE mode choice was not in same location as original AHCI/RAID Location, so if you did not look everywhere, enable CSM again, reboot and then look in each page, and inside every enterable section.

You can ask Gigabyte directly, they may be able to give you correct method. I would do that before buying another motherboard

I searched everywhere, no IDE mode
Gigabyte support not work at all
I have registered on http://esupport.gigabyte.com, activated account by link from email, but I can’t login with specified email and password (with very detail error message “Failed login”)…

But now no matter
I installed Win7 on this PC and compare it (I5 8600+16Gb+intel 760p) with the old one (I5 3470+16Gb+old SATA SSD)
Both works with the same speed, I can’t find difference in my tasks/OS
I got only problems with the SATA and the Win7 instalation from this upgrade, no profit, so I decided to sell this hardware

Case closed, thanks again

Did you try reset password, or another browser, or create new account and try again?
You could also try here - https://passport.gigabyte.com/Apply.aspx

OK, I see case closed :frowning: Sorry I couldn’t get this sorted out!

Hm… I have another idea to try before sell :slight_smile:

I want to try write simple driver for AHCI controller initialization (allocate phys. memory for Command lists, FIS and enable receiving FIS)
If this will be enough to put controller in work state, then I can remove Intel/MicroSoft driver, init controller from the my driver and exclusively work with controller in AHCI mode
This will fully solve my problem, and also will give possibility to use new platforms for program users :slight_smile:
I think I should try

Yes, I think you should try that, it’s very “tech” and seems like something right up your alley that you should have done all along
Since your creating and modifying stuff normal people don’t usually play with, that fix (if you can get working) is fitting for the work being done anyway

For reference, my 5 years old Supermicro X10SAT (Intel Haswell generation) does support IDE. I recall having to use it for Seagate HD utilities, SeaTools for DOS.

I was curious and checked the Data Sheet of the Kaby Lake generation Chipsets, and have bad news. Check Page 221 - 29.3 Overview. It doesn’t support IDE mode any longer. It says the same on the previous Skylake generation Chipsets, on Page 237 - 29.3 Overview. Thus, the latest Intel Chipset to support IDE mode for the SATA Controller should be either Haswell generation (8 Series) and maybe Broadwell (9 Series, H97/Z97).

Thanks, that explains it! I assume some boards will have other added controllers that can also carry IDE signals, but probably only on certain models and less of those more often as time goes by too.

Done, my idea works perfectly
After disabling standart driver, and starting controller from my driver, program work fine and windows can’t prevent this by its own commands


Problem solved, no need in IDE mode and old hardware anymore

Very cool your method worked! And it’s good you though of this idea before going through the hassle of selling and buying new hardware again!
I couldn’t view your link, malwarebytes blocked it

Just video how it works, nothing serious…