Z370 BIOS with RST drivers v14 for SSD acceleration

Older MB & CPU, Asus Z370-F Gaming & i7 8700K.
Data drive RAID5, 3 Seagate 4TB drives via RST, ‘fake RAID’ VERY slow.
Added 256GB Kingston SATA SSD to same controller.
RST application, v15 through v17, recognises array & SATA SSD.
SSD cache acceleration not available within RST application since c. v14.

Tried v14 RST option ROM packages from this site.
When using ‘Replace’ tab, receive ‘invalid FFS file’ MMTool error when replacing ‘RaidDriver 91B4’ orom.bin package.
When using ‘Option ROM’ tab, can replace option 8086-2822 package, and save ROM as unsigned.
No RST option available in EUFI after flash & reboot.

Tried v14 RST option ROM packages extracted from earlier Asus MB BIOS (Z270 etc) BIOS images.
MMTool will overwrite ‘RaidDriver 91B4’ in early Z370 (RST v15) & late Z370 (RST v17) Asus BIOS images, with RST v14 package extracted from other Asus BIOS images.
No RST option available in EUFI after flash & reboot.

Tried UBU v1817, Asus Z370 BIOS images have no ‘CSMCORE’ filename for GUID A062CF1F-8473.
UBU fails at startup.
CSMCORE not present! Plarforn Aptio 5 or non-UEFI BIOS not support.
Press any key to continue . . .

As far as I can get …
Downloaded (earliest) Z370 BIOS v0408, extracted bios.rom from ‘.CAP’ wrapper with UEFITool 0.28.0.
Loaded v0408 into MMTool 5.00.0007 (mmtool_a4), extracted (RaidDriver GUID 91B4) RST package uncompressed.
Loaded (latest) Z370 BIOS v3004, replaced ‘RaidDriver 91B4’ RST package with RST package.
PC boots to v3004, EUFI BIOS ‘Advanced\Intel RST’ option is present, reports RST

Will the Z370 chipset support/recognise a v14 RST package?
I CAN inject the RST package extracted from an asus.com Z270 (RST v14) or Z370 (RST v15 through v17) BIOS image, v15 through v17 package DOES appear in UEFI settings after flash & reboot.
Any inserted/replaced package earlier than RST v15 does NOT appear in UEFI settings after flash & reboot.
I CANNOT inject any of the earlier RST v14 orom.bin packages from this site.
Am I missing something?

Never saw users injected RAID OROMs from Intel 8 Series (RSTv14) or older (7 RSTv13/6 RSTv12) in Intel 300 Series… there were not designed for working with such modern chipsets, can say no surprise here.
Currently and last UBU version will open the bioses from your motherboard.
The AMI tools “leaked” around the web are not up to date with modern releases of AMI V Core bioses, use UEFItools, IFRextract and other tools to deal with it.

EDIT: Yeah…must be it, good luck.

Hi MeatWar.
Not an expert on BIOS, assumed that the RST driver package would be pretty much platform agnostic.
And would have worked on a later chipset, big assumption on my part.
But I’ll try IFRextract, to see if I can get any further.
The MMTool FFS error implied perhaps a checksum issue.
This is why I tried UBU, but the script is looking for the CSMCORE module name, and the Asus Z370 BIOS images only have three sections that are named.
DummyMSOA, RaidDriver, ACPIPlatformFeatures.
Had to find CSMCORE from its GUID, although it’s the RaidDriver section I’m apparently interested in.
Thanks again.

The UBU v1.79 images in your post opened some doors.
It loaded the BIOS, but advised required files were missing from the RST folder.
The readme.txt pointed toward the SATA .efi driver, inside an FFS wrapper.
I put these and the orom.bin into the files folder, and the original 3004 bios into the root.

UBU successfully replaced both the SATA & RST drivers with
Flashed successfully, but no RST option within the UEFI GUI.
Repeated same steps for versions,,
Same result.

Took the already modified 3004 BIOS with SATA/RST (final mod attempt).
Added the SATA/RST drivers from the original 0406 BIOS ( to UBU.
Ran UBU again, to mod the already modded 3004 BIOS. down to then back up to
This worked.

The tools are working fine, the BIOS images and the SATA/RST drivers are good.
Perhaps one of the following?

  1. There is a common setting across all of the Asus Z370-F Gaming BIOS images that disallows SATA/RST versions earlier than
  2. UBU is not recalculating or re-writing a required checksum, preventing pre- SATA/RST modules from loading.
  3. I’m still missing something.

Finally figured it out, thanks to a throwaway comment on another forum.
Seems the Kingston 240GB SATA3 SSD was formatted out of the box, so all space was already allocated.
RST couldn’t find an unallocated SSD volume, so it didn’t bother to display the acceleration tab.
Would have been nice if the tab had still been there.
At least I’d have known it was supported.
And it would have pointed me in the direction of the SSD status.
Extracted RST/SATA drivers v15.8 from the older BIOS, and replaced the v17.5 modules in the latest BIOS, seeing as RST stopped supporting SSD cache after v15.9.8.
Rebooted, then installed the RST GUI v15.9, and lo-and-behold, the acceleration tab appeared.
It’s not a perfect solution, but chucking in an unused SSD improves access times a bit, at least until the cache fills up.
And this was an affront to my techie abilities, so I was determined to make it work, regardless of whether it was worth it or not.
Thanks for the assistance guys.

1 Like