z490 ethernet drivers(I219-V) on Win7

I injected usb3 drivers via nt lite. eveything works perfect except ethernet driver. It’s strange because there is an intel win7 driver for l219-V but not working. I realised that my ethernet adapter seen as "(11)l219-v in windows 10. But in intel’s driver package there is (1)to(7) versions there. Also device id’s are different too. So i replaced to device id’s in .inf file but it’s not working. Any ideas please? I want to use my win7 forever!

Asus tuf z490 gaming plus

Flash old version GBE can make it work,recommend flash 219-V(7) GBE from the same brand of the board.

Sorry i don’t understand your suggestion. What do you mean by flash old version gbe? I’m new in forum don’t know much about terminology

mening,you may need to use older rom file (bios mod) of your device,or you can try force installing (have disk method) the lastest windows7 driver

The main problem is; The driver package contains the driver coded (1) to (7) for l219-V. My ethernet card appears to be (11) and this only works on windows 8 and above operating systems. In theory both are the same ethernet but intel only included drivers between code 1 and 7 and this only works on windows 7. Even if I edit over the inf file, it doesn’t work.

Only the option to install from the old rom remains and I do not know how to do this. Do you know of a guide I can follow?

try force installing first. browse for drivers -> let me pick -> pick the lastest win7 driver,ignore the warning (25.0)
or open up a request in bios modding. enter details,like motherboard,OS,decive id (check the chip),and explain your problem


Sorry, forgot to mention. I tried already many times different vers.

The problem is on my z490 board’s ehernet adapter’ driver number is starting with(11) bu the intel i219-v driver package contains only drives (1) through (7).

If I am not mistaken, the drivers between (8) and (17) are included in the driver packages following windows 8, so my ethernet adapter does not work in windows 7. I forced the driver to install by editing the hardware ID from the inf file, but it didn’t work. Do you think there is a way to solve this? I want to continue using Windows 7.

@Obican
l219-V doesn’t work on new 400 series motherboards GbE region.
You need to replace TUF Gaming Z490-Plus GbE region with Z390-F GAMING GbE region in BIOS rom.

Ty for bringing clarity to this issue. I didn’t do that before. Is there any guide to do that?

Make sure what the version of the ME of the board.
Use correct version FPTW64 to flash the old version gbe.
Before you flash the GBE, you need to edit and input the MAC address into the old gbe.

hello,

Please, can you indicate the name of the hardware ID device (DEV) corresponding to the on your i219-v on z490 board, and can you also indicate the source of drivers ?
Also what generation of processor are you on? Have you found any other compatible drivers since ?

Thank you.

@Obican :
Here is my comment to your request:
1. Ethernet drivers for Intel Z490 chipsets are available, but do not work with outdated Operating Systems like Win7.
2. Affected users cannot expect, that chipset manufacturers like Intel will ever develop specific Win7 drivers for modern chipsets.
3. Due to the fact, that Win7 and Win8-10 need completely different Ethernet drivers, you may not get any Win10 driver properly installed and working.
4. If you really want to continue using an outdated OS, why did you buy a brandnew computer or a mainboard with a brandnew chipset?

P.S.: Since it doesn’t make sense to start 2 threads about the same topic, I have merged both threads, which were started by you in February 2021.

@Fernando no hope with Intel NUC i5 10210U BXNUC10I5FNH2 under windows 7 x64 : it is also a i219-v (DEV=0D4F) exclusive to Win10 ?

if @shaider1.1 can give some more info.

Unfortunately still not solved. I tryed all intel drivers version from official website. Win 8.1 and Win 10 drivers not works under win7. Wi-Fi 6 AX201(PCI\VEN_8086&DEV_02F0&SUBSYS_00748086&REV_00) and Thnunderbolt 3 (PCI\VEN_8086&DEV_15E8&SUBSYS_20818086&REV_06) same result.

Thanks for the information shaider1.1,

In the meantime it is still possible to use an USB to Ethernet adapter…

However, it seems that not all of these adapters are equal (unreliability problem for example it is detected but does not work anymore, disconnections, etc.).

Does anyone have this kind of tools ?
Does your system remain reliable and durable ?
To be avoided ?

Thank !