Z590 TACHYON A5 BSOD problem

Hello all,

I’m trying to have Seven on Aorus Z590 Tachyon but there’s always the same BSOD coming at the begin of the boot :


When I try an old Server 12 it also result in another BSOD :


I’m not sure if it’s the bios or the operating system so I hope to find help based on your knowledge to finaly have them working with this motherboard.



It is the Acpi cant load database error. I did a fix for Win7 32 bit and may be also for win 64 bit.
Send me your acpi.sys, which should be modded


That’s some good news if a solution already exist :wink:
Yesterday I tried some ACPI found here for X570,one call acpi88 and a pack of 4 but none change anything

I’ll don’t have time today so I’ll send my acpi tomorrow :slight_smile:



acpi.zip (171 KB)

Hello @diderius6

Here are a bunch(3) of acpi.sys files wich comes from ghost of OS with ACPI BSOD,they aren’t extracted from ISO before installation,hope this could also work to modify them and re-inject them.
I did this method with an old XP FLP 06 deployed many years ago on Z97 platform and it works great with this Z590 motherboard ^^

Thanks for your help :slight_smile:

acpi.zip (547 KB)

Only MSI Z590 mainboards can work well Xp and win7,gigabyte seems also can work on win7. ASUS and ASRock cannot work and will A5 BSOD.



On my Gigabyte I’ve tried old ISO and also one fully update with 7updater tool,always the same BSOD described in the first post.I have no problem with my XP and the good acpi file injected,board has 2 SATA controler and the Asmedia can work in IDE instead of AHCI.
For Asus board,from what I know now there’s a specific bios for APEX XIII wich work well with Seven and XP https://community.hwbot.org/topic/205829-rog-maximus-xiii-apex/?tab=comments#comment-587370

I am wondering why Server 2012 is not booting normally.
One more thing, I don’t know why, but I think B560 and H510 motherboards are more compatible with windows 7 than Z590 motherboards.

Which does the windows 7 running on the MSI Z590 PRO WIFI have vanilla acpi.sys or modded acpi.sys?

MSI Z590 not need any mod acpi.sys,they can support native win7.

This windows 7 was running on GIGABYTE Z590 VISION G(BIOS Version:F4d) and i5-10400f system.

I’m waiting on Luumi for his Windows 7 on Z590 DARK (yet to be released, he has the board though and did all kinds of OC videos), he got Win7/XP working on Z490 DARK without any issue and another forum member here also got it working. I hope EVGA boards can do that ? @canonkong could you please kindly let us know if the EVGA FTW Z590 (It’s only the released board right now from EVGA) can boot ? Thanks.

Not sure about EVGA Z590, their mainboards not sell here.

Windows 7 works fine (Normal Intel SATA ports on AHCI) on Z590 ASRock OC Formula and Apex XIII, even got USB to work on ASR not sure about Apex yet. XP is working fine on OCF too but with Asmedia sata ports set to IDE/XP support enabled. (Talking about these specific images only, XP does work on APEX XIII but it’s not same as this one)



Ok that’s nice for all your motherboards but what about the subject of this thread guys ?

I tried to install Windows 7 on the ASUS PRIME H510M-D motherboard (Bios Version 1017) and I’m having a problem only at the end of the installation, as soon as the system restarts it gets stuck/frozen in that Windows 7 flag animation

Can someone help me ? Does anyone have any idea why this is happening?

The ISO I used is only with injected USB drivers to be able to use the mouse/keyboard at the beginning of formatting.

@canonkong Can you help me ?


what A5 BSOD do you get?

The bios must Enable CSM funtion first.

It’s me here again (@vinisilv4 ), I had to create a new account because my old one has a bug where I can’t answer the post anymore

CSM was activated even before I started formatting

secure boot is turned off

Boot Mode I tested both UEFI and LEGACY and the same problem happened

Windows won’t start, it’s frozen here in this screenshot:

http s:// prnt.sc/1qjasnv


Z590 also needs to disable XHCI handoff in BIOS, or it will freeze with the starting windows logo.