Z68 Hard-locking with SSD on Sata 3 port, but not Sata 2 port?

First, Fernando, thank you for this great forum. I was a member of the NforcersHQ forum and was helped by your many posts and work there getting an older Nforce4 system running on a raid1 with windows 7. It is still running great for my kids!

Now, my issue is pretty specific, but maybe someone has a suggestion.

I have a Z68 (MSI Z68A-G45) system with a I7 2600K that hard-locks (randomly and not immediately) when running an SSD on the intel Sata3 port, but not when running the SSD on the Intel Sata2 port.

My system has 4 magnetic hard drives, set up in both a raid 1 and a matrix raid (0 and 1). The boot drive is an intel 320 SSD (Sata 2 only) and I have tried two different stata 3 drives that both give me
problems when connected to the Sata 3 port, but not the Sata 2 Port.

Also, the system really does Lock, screen freezes wherever I was, no mouse movement, no log file entries, no dumps of any kind. Only a hard reset fixes it.
It will do this randomly, but regularly when I have a Sata 3 SSD on the Sata 3 port.
It does NOT lock at all when the Sata 3 SSD is on a Sata 2 port.

I have had this problem using RST 13.1, 12.9.4, and 12.9.1 (and an earlier version, probably 12.5, but I updated it first and can’t remember what it was).
The raid bios is the latest available from the board MFG, at 11.5.

I would REALLY like to get the Samsung 840 EVO 500GB drive I just got working at full speed on Sata 3 instead of Sata 2.

1) Do you think updating the raid rom could help? If so which version would you recommend going to for a Z68?

2) Do you have another recommendation for an RST version that I might try?

3) Anything else I might try?

Thanks for any suggestions you might have and keep up the good work.

@ Raid_SuperFan:
Welcome at Win-RAID Forum!

It is fine to read such feedback about the support I have given many years ago.

I am not sure, if it will solve your problem, but I recommend to insert the Intel RAID ROM v12.9.0.2006.

The best matching Intel RST(e) drivers for the v12.9.0.2006 OROM are the v12.9.4.1000 ones.

This is what I would try to test the functionality of the SATA3 ports:
1. Update the Intel RAID ROM of your mainboard BIOS by using the UBU tool (it’s very simple and safe).
2. Flash the updated BIOS and don’t forget to redo your current BIOS settings (RAID has to be enabled).
3. Connect the Samsung 840 EVO to the first SATA3 port.
4. Unplug all other SSDs/HDDs.
5. Do a fresh install of your OS onto the Samsung SSD.
6. Do some tests and check, if your problem has been solved.
7. If everything should be fine, reconnect your other SSDs/HDDs.

Good luck!