z68 SSD Raid 0 Trim not 00 or FF after update

Hi, i am searching for a problem since some weeks. I have a asus p8-z68 v-pro mainborad with 2 m4 ssd and running win 8 64bit. I had everything running (i know never touch running system…) and recently updatet
to the latest RST 12.8 driver and the latest 12.7 op-rom. In this Combination (and also with the 12.7 and 12.6 drivers) i noticed that the trim seams to do something, but now it does not do 00 anymore but somehow other "random?" data?

When using trim check, it says Data is neither unchanged nor empty. But all the time, and always after round 20 sekonds, so i guess it is not just any other programm or data writen, it must be something from the trim. Does anyone has any idea
what to do? I dont want to go back to one of the first oproms/bios or buy another mainboard (wouldnd be the cost, its just the time to install everything again :frowning:

Drive path : \.\C:
Offset : 325307973632
Random data : 7A 22 C6 30 0D 2C 13 35 C3 C5 E4 95 01 91 0E C9…

Reading raw volume data…
Opening \.\C:…
Seeking to position 325307973632…
Reading 16384 bytes…
First 16 bytes: AF C3 1E 0D 99 06 EC E7 42 DD BE 16 B1 0F 3A 2E…

I checked this in the modded oprom ofcouse. Search for the following hex code:

06 1C 00 00 01 → 06 1C 00 00 07

thats fine too

@ n0fear:
Welcome at Win-RAID Forum!

Intel has changed somehow the TRIM support since starting the Intel RST(e) v12 development branch. Nevertheless TRIM should be active within your RAID0 array, since your Intel Z68 SATA RAID Controller is using the TRIM modded Intel RAID Controller v12.7.x.xxxx and the actual Intel RST(e) driver v12.8.x.xxxx.
This is the best way for Win8 users to verify, if TRIM is active within your RAID0 array:

  1. Run the Win8 “Optimizer” after having chosen Drive C (after having checked, that the SSDs have been detected by the OS as “Solid State Drives”).
  2. Wait a minute.
  3. Run the TrimCheck Tool.
If the tool gives you the message, that “TRIM appears to be working”, everything is fine. In this case you can be sure, that the TRIM command passes through the Intel RAID Controller into the SSD members of the RAID0 array. No further TRIM tests are required.


Well thanks alot for reply, tried that what you told with optimizer but same result, changed but not to zeros :frowning:


Is this maybe a problem? Dont know what this \?\Volume{… is as C is a SSD Raid and there is no other SSD inside!?


Maybe anyone that has a working BIOS for p8z68-v pro (not v3) that he could upload for me?

As the message shows, there is obviously another program, which is running in the background and writing new data into the related sector.
Nevertheless I am pretty sure, that there is TRIM activity within your RAID0 array. Otherwise the data, which were written by the TRIMCheck Tool, would still be completely present.

I suspect, that this is the hidden 100 MB partition with the MBR.

Thanks bout the hint of the 100 mb partition. Thats what i thought, too but you really think there is a programm that writes there that fast all the time? Strange thing, as i had 00 00 00 before, but i can not remember with what firmware, oprom and driver combination that was. well ok then, maybe it has something to do with the latest firmware of the m4 then, too. Stupid question but if i use HxD for example and got like 40 Gig of Free space on the drives, should it find alot of free space with 00 00 00 00 then?

Try the manual Hex Editor test. Then you will see it.

Thanks alot for your help but it is still the same, trim does not Zero the drive with latest drivers and latest orom :frowning: well maybe i will go back to an older version or just upgradde to a new mainboard in some weeks

As I already have written: TRIM is obviously active within your RAID array. Otherwise it would not be possible, that the previously present data have been overwritten by other data.
There is something else, which prevents, that you don’t see zeros or FF’s at the place, where the deleted data were.
How much free space do you have within drive C?
Advice: Please check your system regarding programs, which are working in the background and try to disable their activity while doing the Trim test.

Found the error, and it was soooo stupid… it was bitlocker that was running, it does kinda "random data" with trim. Deaktivated it and 00 are back again… god am i stupid i should have thought that it makes sence not to have 00 in a full disk encryption

Thanks for your feedback! It is fine, that you found at least the culprit, which prohibited the "normal" TRIM detection.