Zotac EN1080K Error Code 43 / Zotac Vr Go 2.0 GTX 1070 vBIOS Request

I’m looking for the vBIOS for the Zotac Vr Go 2.0 GTX 1070.

I have a Zotac EN1080K that I’ve been attempting to upgrade with an i7-8700 for a couple of months. The initial modding works and I am able to use the i7-8700 with hyperthreading enabled. The one caveat is the GTX 1080 throwing an error code 43 whenever the 8700 is installed. I believe this to be an issue with the GPU’s vBIOS. I’ve updated the GOP, but it had no benefit.

The only lead I have is from a user on the NotebookReview forums who got an error 43 after updating their Clevo N950KP6 with a Coffee Lake CPU. They eventually fixed it by taking the vBIOS from a native Coffee Lake Clevo’s GTX 1060 and flashing it to their own.

Unfortunately, Zotac has stopped using MXM cards in their larger mini PCs, opting for full sized desktop cards instead. This puts the card with the closest vBIOS in the Vr Go 2.0, which has a i7-8700 and an MXM GTX 1070.

I won’t be able to flash the vBIOS directly to my 1080, but may be able to figure out the difference between the MXM cards used in Coffee Lake and Sky/Kaby Lake systems. I’m guessing it’s a pretty rare system, but if anybody had a Zotac Vr Go 2.0 and could post the vBIOS, I would appreciate it greatly.

EN1080K vBIOS: https://mega.nz/#!zWADWQxB!osqTpVrskuIXs…bdD5JKAcPeR78fI

@mini-stx - there is vBIOS inside the BIOS itself, in addition to a GOP, this may be all you need to upgrade, did you try that already? If not, link me to your system’s BIOS and I can help you look there too

Link above is the vBIOS only, please link motherboards BIOS, thanks

1080 or 1070, you mention both?

Original BIOS: https://www.zotac.com/download/mediadriv…b336EN1080K.zip
Modified BIOS: https://mega.nz/#!rygwHIaT!fhWtS5PFhP6cU…9ChvO-_oqdrC2T8

There is no internal GOP, this PC (Zotac EN1080K) doesn’t have any integrated outputs. I’ve tried updating the internal vBIOS using the one from the Zotac Vr Go 2.0, but to no avail.

I have a GTX 1080 Mobile, but the only system Zotac has made with a Coffee Lake CPU and an MXM GPU is the Vr Go 2.0, which uses a 1070 so it is my best chance I figuring out what is missing in the vBIOS for the 1080 in the EN1080K.

I see vBIOS in the stock BIOS, did you try updating that already, but with latest from here (W/ settings transfer) instead of from the Vr GO? Specifically >> Skylake/Kabylake/Coffeelake v1059
VBIOS in GUID A0327FE0-1FDA-4E5B-905D-B510C45A61D0 >> SubGUID >> C5A4306E-E247-4ECD-A9D8-5B1985D3DCDA >> OROM VBIOS SKL-KBL - 1049

I’ve updated it using the automated tool provided by @revlaay. I figured I should stop mucking up that thread with my problem and create a new one, as I don’t think the issues are due to the automated tool and instead are due to Nvidia locking their mobile cards to specific CPUs (Error code 43s not caused by hardware failures are almost always due to Nvidia pulling shenanigans within their drivers to prevent any modifications).

I think you are correct in this assumption also, we already tried onboard iGPU VBIOS/GOP swapping and by process of elimination you have narrowed it down to the Nvidia card.

Maybe @lordkag can advise on this, since he is the NVIDIA and vBIOS guru here. I’m sure he knows how to recognize the NVIDIA lock/CPU named regions and can probably edit that for you or tell us how to proceed
Or also, maybe @Sylar76 could advise too if lordkag is busy right now.

Still looking for a way to bypass the CPU limitation if anyone has an idea of where it may be in the driver or vBIOS.

the same problem here.
i have modified it to run cfl cpu.
with 1070 , i5 8400/9400f work without issues.
with 1060, i5 8600t error code 43.
i tried clevo and msi mxm vbios but it doesn’t work too.
i also tried edit subsystem id for graphic card(to clevo and asrock) but it doesn’t work too.

maybe one of these guys can help or point you in right direction? @svarmod @_haru @dsanke @revlaay @Mov_AX_0xDEAD @CodeRush

No idea, sorry :confused:

Another promising vBIOS might be found in the ASRock DeskMini GTX (Z370/Z390). It comes with an mxm 1080, has the same outputs as the Zotac mini PCs and supports coffee lake chips.

Tried flashing an MSI vBIOS 1080 Mobile to the GPU after hearing success in another thread, but ended up bricking the card. Connected via RDP and restored the original vBIOS. PC is back to the way it was, but no closer to working with the 8700.

Got the PC to boot when using an MSI vBIOS by setting BIOS to be UEFI compatible, rather than Pure UEFI. PC boots with MSI vBIOS, but GPU is listed as Microsoft Basic Display Adapter and attempting to install NVidia drivers results in a “compatible graphics adapter not found” error.

Here is the MSI vBIOS I attempted to use: https://mega.nz/#!6X5h0ArB!s_3BCq0ZhzgbW…7IULQqGkPpCfGOU

Here is my original vBIOS: https://mega.nz/#!bG4hVYQR!1rCRf9LoVCVDE…jaWlQFOUuHNgG3U

Did you try to copy the settings from ASRock DeskMini GTX (Z370/Z390) vBIOS to your vBIOS instead, or reverse of that and use that vBIOS but copy into it the settings from your original vBIOS (from within the BIOS) << Later would be what I’d try first,

I don’t know how to copy settings over since NiBiTor doesn’t support the 1000 series cards. I just flashed the MSI vBIOS directly after seeing success in this thread with the GTX 1070 version of my PC.

Your links dont work anymore , can you reupload?