(A7) ME FW Downgrade - Request MeSpiLock Failure on MSI GE62VR 7RF Apache Pro

Hi! How are you?

Today I wanted to comment and see if someone can give me a hand.
My notebook named in the title of the post, from one day to the next, when restarting it, I found the error (A7) ME FW Downgrade - Request MeSpiLock Failure. (After the MSI flash screen, HECI disabled and proceeding with boot)

This error doesn’t go away and I don’t know how to fix it. I read the guides (Intel Engine Drivers and Guide Unlock Flash Decriptor) and I really do not dare to open the computer.
The question is that I entered the bios and the firmware of the ME appears correctly so I do not understand why the error came out.

My query is:
If I open the notebook and short-circuit the realtek chip and restart the PC, when I turn it on again can the error clear itself? I ask because, as I mentioned before, the version of the Intel Management Firmware appears well in the bios and I don’t want to risk breaking anything or anything.

PS: I already tried updating the bios and when I select the update bios option the pc freezes and I just have to force shutdown to make it work back.

PS 2: I have already checked the FWupdateTool and all the options listed and I have the flash decryptor blocked.

PS 3: In the MEInfo when I open the bios file it says ME 11.8 but inside my installed bios figure ME 11.6.
I don’t know why this is, if the bios was already installed at the time (two months ago) and theoretically without problems, because there is an older ME.

PS 4: If I tried to install or update the ME firmware inside windows, the program says invalid platform. (This is the error: Error 8743: Unknown or Unsupported Platform
Cannot locate hardware platform identification
This program cannot be run on the current platform.)

I attached the Stock bios, idk if it’s useful.

PS 5: Sorry for my bad english, is not my natal language.

WhatsApp Image 2020-07-29 at 14.23.18.jpeg

E16JBIMS.31A (BIOS del sistema).rar (5.51 MB)


The CSME firmware must have become corrupted after a BIOS update so it needs to be repaired. That requires an unlocked Flash Descriptor as explained at [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing. If the laptop has warranty, I suggest you use it because this process will probably not be easy since you’ve discovered that you have no write access to the CSME firmware region of the SPI/BIOS chip. The steps afterwards are easy. You download the latest BIOS from MSI and flash the 8MB image via Flash Programming Tool with parameter “fptw64 -f E16JBIMS.31A” followed by “fptw64 -greset”.

Thank you Plutomaniac, i will give it a shot because I don’t have warranty.

Just one more question, the process can fail and the system will never come back again?

Because the laptop is still working, only i can’t suspend so…

Thank you brother!

Since you do not have warranty, you can try the E.1 pinmod to flash in unlocked FD, if you cannot do that then wait and purchase CH341A + SOIC8 test clip with cable, then you can fix for sure once it’s arrives.
With flash programmer mentioned above (CH341A + clip/cable), you can always revive system if you mess it up, but you have to get it first and make a backup then you can always recover with all system details in place.


@Falkentyne in his msi and I had the same problem. I have ge72 7rf but I disabled me firmware in bios and than reenabled it and me fw was than And I had The same msg at boot.

Did you disabled me fw in bios?? :slight_smile: when you will enter bios hidden menus and you disable mr and sending did messages you should get rid of this but boot time will be longer, or you can lost some Control of your cpu.

If you want recover it completly you need a bios dump with merged fully functional me fw and than flash it with programer @Lost_N_BIOS told you.
I have no dubts that he can do that for you.
You can also ask Svet at Msi forums for bios with me and he will give you me-port unlock tool and flashing tool so you could recover without programer but you need to pay Svet.

Thank you for your answers @krzyslaw and @Lost_N_BIOS.

Krzyslaw: I don’t disable me fw in bios. What’s more, I had a hard time finding the hidden bios options and I didn’t want to touch anything because as the laptop still works, I didn’t want it to become unusable. Can you give me more information about Svet and on what forum? (send me a DM pls)

I would have no problem paying you, as long as I find a way to do it from my country (ARGENTINA)

But that ME port unlocker is from inside windows? and putting the stock bios would be solved or would I have to talk to “Lost N Bios” to add another ME to the bios ??

Thank you very much for all the information you can give me in advance. If I can resolve these issues, I have to reward you in some way. :stuck_out_tongue:

@Krzyslaw - Please post here to tell @nikovillarino how to enter hidden menu, so they can disable ME - Then it “may be” possible to dump and fix ME FW with FPT, but I’m not 100% sure due to possible FD locks
ME Port unlocker tool is run from DOS, and that is how I would have you dump/update ME FW once ME Disabled from BIOS too (with FPT)

Once you disable ME FW from BIOS hidden menu, do the following using DOS FPT. Take stock BIOS, E16JBIMS.31A for example, rename to E16JBIMS.bin
Then do the following >>

Go to the thread linked below, and in the section “C.2” find and download the V11 ME System Tools Package.
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a DOS Folder.
Make a DOS Bootable USB, then copy ALL contents of the FPT/DOS folder to the root of the USB (So copy FPT.exe + fparts.txt to root of USB, not in any folders)
Then put your copy of BIOSfilename.bin in root of folder as well
Then boot to DOS and run the following command >> FPT.exe -me -f biosfilename.bin

If you get error above, especially if SIZE error, do not proceed. If you get error, can’t flash due to error 26-28, or 167 OK, this means lock in place in FD and disable ME FW does not help, you will need to use Svet method or get flash programmer

Is this an error? @Lost_N_BIOS
The ME version now is

EDIT: Also now in the BIOS says Change the Product Name ._.

Like this:



@nikovillarino - it’s only an error if you had not disabled ME FW, but you did, so it’s expected. Type Y/Yes, and reboot once it’s done, then enter BIOS and enable ME FW via the hidden menu entry
Then, boot back to DOS, or windows, and run one of these FPT CMDs >>
FPT.exe -greset ( if you do DOS)
FPTw.exe -greset (if in WINDOWS)

@Lost_N_BIOS I understand, i tried but the Screen drops error 451 and the operation don’t start

correct fw ME_11.8_Consumer_D0_H_Production.bin


\Intel CSME System Tools v11 r32\Intel CSME System Tools v11 r32\FWUpdate\DOS
FWUpdLcl -F ME_11.8_Consumer_D0_H_Production.bin

your problem , previous flash wrong or similar , may not work
or wait on answer here ,best help for you

some ME setting in bios – f2 + L alt + R ctrl + R shif --in bios all option
FW setup or similar tab is ME

boot to bios ,combo key up , pch-FW tab

After the error, the laptop don’t turn on anymore, so idk what to do now. (Don’t showing msi logo)

hw programmer …,bios re-flash ./
not possible boot to bios or similar ? ,but disable ME kill nb similar .,.think
and in ME fw tab exit two files id ,recovery ??

I can’t do anything of that right now, i will search if some technical service has a HW programmer :man_shrugging::sob:

EDIT: Laptop magically turn on again, with no ME firmware (Still but it’s working now inside windows

small chance SW/repair
@Falkentyne here or on "notebook forum review"
I think he had a similar problem with Gt73

but i think he used the same "hwprogramer" fix

@NeXt3R - I gave him correct ME FW (Actual BIOS from MSI), AND that ME FW is configured for his board.
So, same as what you provided, but what you linked can ONLY be used in the manner you described (with ME FW update tool) and ONLY when ME FW is in healthy functional state.
I believe it would not work here, due to ME FW is not healthy state

@nikovillarino - Did you get image of this error? Sounds like still blocked error, IE either ME FW was not disabled, or ME FW disable does not overide the FD ME FW lockout so programmer or pinmod would be required to program the ME FW as initially mentioned.
After error 451 if nothing was flashed, then nothing changed and laptop should reboot as normal. What did you do before this reboot that then did not boot up again?

Ohh great, you got in!! Yes, if you disable ME FW, then it will always be N/A or until you fix it.
You need to do pinmod (linked at post #2, see section “E.1”) to unlock FD, or get flash programmer (CH341A) + SOIC8 test clip, then we can fix. If you need linked examples let me know.
Also, before you order, best to open bottom of laptop and look at teh BIOS chip to get it’s ID, just in case you also need to order 1.8V adapter.

is just a tip, I thought it could not hurt anymore ,on LOCk flash or not possible flash --no brick

in MSI bios exist more ID ? recovery ME ?? possible any switch this ?
@nikovillarino --now talking with msi admin @svet …will see

me repair ,but what repair PRODUCT NAME ?? license in bios ??

disable ME on MSI ?? not get BRICK ?? setting is in hidden pch-fw TAB" combo key post before
i send more images


my oem setting gt75 7re + last FW "win-raid"
link expired 16.8 2020

possible use any setting for repair ?? and ME status 1 is recovery ??

@Lost_N_BIOS @NeXt3R

Well, Hi!

After talk with Svet and After trying a few things and working with Svet’s tools we couldn’t get the ME to change from
(Nothing even appears in HWInfo)

According to Svet, there is most likely something damaged on the motherboard.

Then as soon as I can I will take it to a technical service to see what they tell me, I have the name of the product and everything correctly now, and in theory the fix should have changed the ME but it does not, there was only a change from the A7 error to no show any error and that it is in

The only thing that remains for me to prove is point E.1 of the guide but I will surely do it later when I gather some money and someone who has the courage to do it. (I don’t have the tools and I don’t know how to do it)

Also, thank you very much for your help, you are very good people.

Lost_N_Bios, I sent you a PM.