Acer mb with AMI Aptio V BIOS backup and flash issue

I recently bought a Acer off-market engineer motherboard which powered with a J5005es CPU and AMI Aptio V UEFI BIOS. It is similar to Acer Aspire XC-830, the only difference is mine has two HDMI ports, HDMI IN and HDMI OUT. I downloaded latest XC-830 BIOS file and tried to flash with afuwinx64 but failed. It says wrong ROM ID, I tried to flash with /X option which reports secure flash verify fail error. I also lost MAC address of Realtek GBE controller even though I can.manually add MAC address to make it work, the BIOS Realtek GBE controller shows 00-00-00-00-00-00. Any suggestion on how to make a moded bios XC-830 BIOS and flash to my motherboard? My motherboard also cannot boot Freedos tried legacy boot but the monitor goes blank after.choosing the mass storage boot. The mb has WP1 OBR1 TXE1 jumpers that I have no idea what they represent. I also tried backup with afuwin64 /O command but still fails to flash the backup BIOS file, still secure flash verify fail error shows.

Before you do anything, make sure you keep a backup of the original SPI image. Set the TXE1 jumper, download “Intel CSTXE System Tools v4” from Intel Trusted Execution Engine: Drivers, Firmware & System Tools and run Flash Programming Tool with command “fptw -d spi.bin”. Compress and attach/link the resulting spi.bin file here.

My mb txe1 has 3 jumper pins, I`m not sure whether I shorted the pins right. Here is the output.

SPI bin generated.
BIOS backed up using CH341A.

Acer Aspire XC-830 BIOS can be downloaded below.…roduct/7530?b=1
Latest is version R01-B0.…BC=ACER&SC=PA_6

Thank you for the SPI dump. That system is indeed using a Pre-Production (PRE) SoC with PRE firmware. You may not be able to use the Production (PRD) firmware from Acer’s website. We can try to swap the BIOS/IAFW sub-component with the one from the PRD SPI image provided by Acer (“R01-B0.bin”) to see if it works. I wouldn’t get my hopes up but you do have a programmer so you should be able to recover at least.

As far as SPI/IFWI components are concerned, you must keep the PRE CSE TXE and PMC firmware. One thing we certainly need to move is the microcode because the PRD BIOS have only 706A1 and not 706A0 that your ES CPU requires. Both PRE and PRD SPI images seem to have Intel BootGuard setup but they use the same OEM signing keys so that shouldn’t cause a problem. I have created two test SPI images for you. Flash them via the programmer and let me know if they work.

DUMP_MOD.bin → Your “spi.bin” dump with the BIOS/IAFW sub-component from Acer “R01-B0.bin” (safest bet, try this first)
R01B0_MOD.bin → The PRD “R01-B0.bin” SPI image with CSE TXE & PMC replaced with PRE versions and Microcode changed from 706A1 to 706A0

XC830.rar (5.47 MB)

Thank you for your effort. I will try to flash with SPI programmer and report back. The bios chip w25q128fwsq is covered by plastic cap.vB.t.w., can I use CH341A SPI programmer and flashrom to flash w25q128fwsq chip?

The back side of the mb also has a Winbond chip shows below.

That’s a SPI socket which means you can remove the SPI chip and flash it directly with the programmer. Normally OEMs solder the SPI chip at such systems during Production but yours is Pre-Production so they were probably using a socketed chip for ease of repairing, very cool. I don’t know if your exact “w25q128fwsq” chip is supported by CH341A and flashrom, you’ll have to find that out yourself.

For W25Q128FW you need to use ASProgrammer 1.40 and you’ll need 1.8v adapter like this -

I tried dump mod and R01B0 mod bioses, with HDMI monitor they all work, but with VGA none of them worked. Both cannot boot with secure boot option enabled at first boot. The Realtek GBE ethernet controller also shows 00-00-00-00-00-00 hardware address in OS. A strange things is the buzzer of the mb will not beep with original bios, but with the mod BIOSes they both beep during power on.
The dump mod bios shows below.

Both mod bioses can not boot with VGA monitor and shows secure boot signatrue error. Realtek GBE ethernet controller seems has no MAC address. Options in mod BIOSes seems a lot trimmed comparing to the original BIOS.

I can boot with Secure boot enabled after first boot with secure boot disabled. The major issue is the VGA boot blank screen and the 00-00-00-00-00-00 MAC address of Realtek 8111GA.

You can fix MAC ID. Do you need secure boot mode? If yes, then you may need to change some BIOS settings, and I’m not certain but I think there may not be such a thing as a secure boot enabled VGA BIOS (legacy option rom is used for this… Legacy = non UEFI = Not able to do secure boot)

To fix the MAC ID’s, you need to find the MAC ID’s on the board/inner casing, often on a sticker or on/near the LAN ports, if not check both sides of the board for all stickers and the inside of the casing. Also, check on/around/beneath the memory, sometimes sticker is hidden there too.
If you already know the MAC ID’s then post them here and Plutomaniac or I can put back into BIOS for you possibly (may not be stored in BIOS). See this thread, try changing with that tool and be sure to read last post about realtek ID’s -…00/td-p/1817289

Thank you for ur reply. My mb LAN ID is 98eecb5737e5. It would be nice if you can inject this MAC ID into the bios file.
B.t.w., my mb has a 13-pin socket, I have not figured out the rest rest of them except the HDD LED and PWRBTN locates.

I fixed the audio problem by replace the ALC662-VD0 chip. I dumped the SPI. I will upload the CH341A backup of my BIOS chip if needed.
I cannot fix the RTL8111GA MAC Address 00-00-00-00-00-00 issue with traditional tools, even contacted ASROCK service support, they send me a APP called wMAC which runs on Windows but it cannot write MAC address of RTL8111GA chip.
I need my BIOS with updated CPU Microcode and REALTEK LAN UEFI driver. The peer of this motherboard goes with ASPIRE XC-830, I think we can adapt from XC-830 and make some change especially the CPU microcode and add back to the original BIOS dump, or mod the XC-830 BIOS according to the BIOS dump. The mod @plutomaniac did work out of box except it cannot boot with VGA monitor. The mb has two HDMI and a VGA output comparing to the XC-830 which has a HDMI and VGA output.

After replacing the broken Realtek rtl8111ga chip, I lost LAN MAC address. The motherboard powered with a J5005es CPU and AMI Aptio V UEFI BIOS. BIOS and Windows 10 shows Realtek GBE controller has no MAC address assigned, simply 00-00-00-00-00-00. It is similar to Acer Aspire XC-830 which has a HDMI and VGA output, but this mb has two HDMIs (HDMI-IN, HDMI-OUT) and a VGA output. The BIOS is a 2017 version, is it possible to extract CPU microcode, SATA, Realtek UEFI Lan Driver, etc of the XC-830 BIOS and inject to mb BIOS? Or is it possible to change the XC-830 BIOS to the adapt the mb?
SPI bin generated using fptw -d command.
BIOS backup by CH341A programmer, it is slightly bigger than SPI bin.
Acer Aspire XC-830 BIOS can be downloaded below.…lash-issue.html
Latest is version R01-B0.…lash-issue.html

Merged your new topic back into this one - no need for two threads, and I already replied to you about this exact issue here

@wizbee - Please use some other non-virus upload site. That site sets off malwarebytes 4-5 times with different warnings of things being blocked, and I cannot download the file without having that “With addons” box checked
This is a good site for file sharing -

Never mind, got it finally!

* Edit - I cannot find MAC in this BIOS, since you currently only have zeros as your MAC ID. The only way to find it in BIOS, is to have a dump from another same system, and know it’s exact MAC ID

So software for now will be the only way, unless you can resolve above mentioned situation

Download the stock XC-830 package, extract, in the Win folder, try this command for AFUWin to fix MAC (may not work, but we start there) >> afuwinx64.exe /M 98EECB5737E5
If that fails, try one of these tools and the following commands, from DOS

dmi236.exe /o 98EECB5737E5
dmi172.exe /o 98EECB5737E5

If those fail, try EEUpdate from Intel (included above link) - here’s a how to PDF, in case you have two MAC’s -…C%20ADDRESS.PDF
EEUpdate.exe /MAC=98EECB5737E5

If those all fail, also included is Asrock MAC Write package, which includes two specific tools for RTL8111…284458623569323

Thanks for your reply. I just backed up the BIOS with CH341A programmer. Please check it out.

P.S., I cannot boot into DOS environment with this mb. Tried legacy boot still fails. So DOS tool is no go. Can you help me mod the BIOS that include the CPU microcode, Realtek LAN EFI drivers(EFI BIOS modules upgradeable with XC-830 BIOS and UEFITOOLS) updates of the XC-830 BIOS, btw onboard CPU is J5005ES comparing to the J5005 of XC-830.


Thank you for you BIOS mods, I tested both of them and all runs with lower CPU percentage resources at startup and seems cooler than the original BIOS. But VGA output is not working. My mb has HDMI-IN, HDMI-OUT, VGA but the XC-830 lacks the HDMI-IN. Is it possible to mod the original BIOS to include the latest EFI BIOS modules and CPU microcode using XC-830 latest BIOS and the UEFITOOLS? Btw some mods need to adapt the J5005ES CPU.


I have a ACER XC-730 which has the same rtl8111ga and similar BIOS except it is powered by J4205. Should I upload this BIOS for you to pin down the problem?

@wizbee - thanks for your BIOS dump, but didn’t you already give that before? You can boot to DOS, you just need to make DOS bootable USB or CD, then choose that via bootmenu hotkey at startup, or set those to be first in boot device list in BIOS temporarily
Yes, I can update CPU microcode for you, and LAN I suppose but that is only useable if you boot to LAN via PXE (This is all the BIOS LAN Module is used for)

I did not upload any BIOS, so I’m not sure what you mean about you “Tested both BIOS mods”??

As for the ACER XC-730 BIOS, yes, that may be helpful to find MAC location in your BIOS for the XC-830, if it’s stored in same or close location.
Please give me programmer dump from XC-730 and tell me if’s MAC ID. If the MAC ID is not in it’s BIOS, then it’s stored in chip, and you’ll have to use one of the tools I linked you to in package previously.

@Lost_N_BIOS The test bioses I mentioned was made by @plutomaniac and he is the first one modded this bios. The BIOS dump I uploaded yesterday is done by CH341A, not sure the original MAC ID embedded or not. As I said before, I cannot boot into DOS with this motherboard. I tried to make FreeDOS bootable flashdrive with Rufus but cannot boot, just blank screen. I am not sure how to boot into DOS or 32-bit UEFI with this mb, the adfuwin.exe requires 32-bit system.


XC-730 BIOS linked below. @Lost_N_BIOS
MAC ID attached in description.…623534125277412

Thanks for info, I didn’t look back and notice he made you some BIOS to test, sorry I missed that earlier!

I know that was dump you sent yesterday, but since MAC ID is current all zero’s, then the original one is not in there. That’s why I need other same, or hopefully similar dump and correct MAC, then I can fix in your current BIOS.
You can boot DOS, you just have not done it correctly yet, for this system. Blank screen sounds odd, maybe you have UEFI Mode / Secure Boot enabled or OS Type Set to Win8-10 etc? If yes, disable, then you can boot to DOS
Or, try not using Rufus and freeDOS, try win98 SE instead (With or without Rufus?) Here is how I boot to DOS, never any issues on anything - Follow steps 1-4 to create bootable USB
<Request> Flagship X470 Gaming 7 Wifi Motherboard BIOS Fix

Also, be sure to use small cheap drive, like 128MB-2GB

Thanks for BIOS and MAC, I will get into this tonight for you. * Edit - checked, no, this MAC is not in this BIOS that I could find, forwards or backwards, not even partial.
So, MAC must be stored on chip in these systems

Can you help me mod my original BIOS to update the CPU microcode, LAN UEFI driver, etc using UEFITOOLS and xc-830 bios I mentioned before? The MAC ID issue seems not a BIOS issue. So we can skip that part.

Tried you app. Cannot using on Win10. Tried on Windows XP. Still cannot boot.

@wizbee - you need to be specific, I don’t know what “App” you are talking about. If you mean the Bootable DOS creation tools, they work fine on Win10 and WinXP too, I’ve used them on both systems to make USB Bootable drives.

If you cannot boot the board, you need to program back in your original dump. Then once you are running again we can discuss modification of the BIOS.
If you can’t boot from your original dump, then there is either some issue with it (bad dump), or some issue with you writing back BIOS to chip. If it’s the later we need to find reason and change the cause, so you can get it running again.
Programming in edited BIOS isn’t going to make it magically boot if programming in your original BIOS isn’t working either.

I am using original BIOS and it runs OK. A little high CPU usage at startup. I think the mod @plutomaniac made works OK except the VGA output issue and trimmed BIOS menu issue. I want to mod the original BIOS to include some fix that the latest BIOS of XC-830 included. I think it would be great if you can help me mod my original BIOS to include the fix. You can check the bioses plutomaniac uploaded earlier in this thread. What I mean yesterday is the original BIOS runs fine, I think Acer has blocked DOS boot, at least in this board. Tried to change the CSM option, it only brings up legacy boot mass storage but no siganl shows after choose the mass storage boot as first boot. I think the MAC ID issue is not BIOS related. So we should skip this part and focus on the BIOS mod agenda to include the CPU microcode fix at least. Can you help me mod my bios dump and make a new bios based on the original bios that include CPU microcode update from XC-830 BIOS or the BIOS plutomaniac uploaded earlier? Since the original BIOS is outdated.

Could anyone shed some light on the BIOS mod of this BIOS? How to update the CPU microcode, Realtek UND driver, NVME driver etc?