Alienware cold boot black screen issue, IME corrupted?

Hello Guys,
I have an AW 18 r3 laptop, every time I cold boot it, there is a 30 seconds completely black screen right after I push the power button, and after that everything just fine. This problem only happen when cold boot.
I found that the in windows device management tool there is a yellow icon on the "Intel Management Engine", I tried to use MEAnalyzer to get the IME info, but it said "Error 63: Unknown or unsupported hardware platform."
I read some posts in this forum and I think the problem may be due to IME corruption. I have attached my bios file, could someone have a look and probably fix it for me? (3.5 MB)

@caiqinlin - The cold boot issue, could be due to BIOS or ME, or corrupted ME FW etc.
Your in windows device management comments, means you may need to install Intel ME driver package, from the driver download page for this system.
If you know you already previously installed ME drivers, then it’s possible ME FW was corrupted during some BIOS update or via some glitch etc.

What is the attached file? A BIOS dump from programmer (if yes, what is chip ID and what software/version did you use), or software (if yes, what), or a stock BIOS etc?
I did not download it to check yet, waiting on answer about that first.

Please also link me to the stock BIOS download PAGE for this model, thanks

Hi, thank you for your quick reply.
I have tried to install ME driver for many times, and it doesn’t work.
Yes, this is a full bios file dump from the CH341A programmer, this bin file is 8m. The bios chip is 25Q64FVSIG, and software is called CH341A programmer.

Sorry this link for AW bios v12…nware-18&lwp=rt

@caiqinlin - You’re welcome! Did you have ME Drivers installed before, or do you not know? I guess maybe you do already have them installed, since you can see the item as Management Interface in device manager, I think you can see ME driver in Installed programs too if you wanted to double check
Thanks for the info, I will check your dump now and fix it if there is ME FW issue I see, we’ll I will redo/update/clean ME FW for you no matter what too.
Please wait, I don’t have time to do now, but will try to get done this afternoon, if not I will get it done first thing tonight

@caiqinlin - * Edit - Here, program this back in, then remove power cables or shut off PSU. Then press and hold the case power on button for 10-15 seconds or short power on pins for that time. Then let system sit without power for one+ full minute
Then enter BIOS, load optimized, save and reboot back to BIOS, make all changes you need, then boot to window and shut down for cold boot test. If this does not fix it, then BIOS may be the issue, try newer or older, flashing via standard update method…997647741674395

I have downloaded your file. Thank you very much!!!
I only know how to write the bin file into the bios chip with the CH341A programmer, and I don’t know how to do it without the programmer.
So may I ask if I program this back with the programmer, I don’t have to follow your instruction like

, is this correct?

@caiqinlin - Sorry, not sure where the confusion is on what I mentioned? Yes, I meant for you to program that back in with flash programmer (like CH341A)
Yes, please follow my exact instructions as I wrote them, this procedure drains all power from the board for over 1 full minute and it resets the ME FW internal state
If you don’t do that, ME FW may still be messed up. If it is, or you don’t understand what I meant, then once you boot into in windows you can do this, and this = same as above procedure >> FPTw.exe -greset

Thank you, what confusing me is you asked me to disconnect power cables, but when I program with CH341A, I have already disconnect power cables and battery as well.
Let me tell you all my steps,
1. Disconnect power cables, disassemble my laptop, remove the battery, remove the keyboard
2. Find the bios chip, program it with CH341A (pinout), program your new bios file in.
3. Assemble my laptop

After that I need to follow your steps — 'Then press and hold the case power on button for 10-15 seconds or short power on pins for that time. Then let system sit without power for one+ full minute’

Could you tell me is this correct way?

@caiqinlin - You’re welcome! OK, then leave power cables disconnected Main thing here is to have ZERO power on the board after you program in BIOS, for 1+ minute
Yes, I would do as you outlined 1-3, then when you put back together leave main battery and power cable disconnected, press and hold power on button for 10-15 seconds, then let sit for at least one full minute without power like that.
Then put in main battery, connect power brick, boot to BIOS, load optimal defaults, save and reboot back to BIOS to make any changes you need, then boot to windows.
Then you can shut down and test if issue remains or not on next power on attempt, if truely cold boot issue, it may not happen until at least 4-6+ hours after being shut off.

@Lost_N_BIOS Thank you very much, I think I have fixed this problem, I program the bios chip with your bin file and now the 30s black screen is gone.
I have been studying this issue for several months, at last fix it!!!
Something strange is after I programed the bios file, and reboot, I got a 5 short beep sound from the bios when first I was using the battery. Then luckily I tried to connect the charger, the problem is gone. Don’t know why but just FYI.

@caiqinlin - You’re welcome!! Great to hear this has fixed the delay issue!!
Those beeps may have been warning to connect power, or due to ME FW State reset during that first power on, or CMOS resetting possibly, not sure? That or maybe battery is setting off beeps due to charge amount, or non-genuine?
Be sure to load optimized defaults in BIOS, then save and reboot back to BIOS, then set everything in BIOS how you want

Hi, seems like everything is fine except I cannot get ME info, if ME problem is fixed, why it said ‘Error 63: Unknown or unsupported hardware platform.’ ? could you please help?


@caiqinlin - You’re using wrong ME Tools package, you need v9.1 package from Section “C2” at end of first post here - Intel Management Engine: Drivers, Firmware & System Tools