Allow B0 stepping on Asus W621E Sage

Hey everyone,

I currently own a couple of intel xeon platinum engineering samples that have a b0 stepping (lower clock speeds than the release variants). Because of this, they won’t boot up on the Asus W621E Sage but they will boot on some other motherboards such as the Supermicro X11DPH-T (I own both but would like the W621E to work since it has some extra features). It was brought up in a different forum that this is probably due to the bios on the Asus board not supporting b0 stepping chips. Is it possible to mod the bios on an Asus W621E to allow b0 stepping chips using the Supermicro’s bios as a reference (or directly, I’m not familiar with bios modding at all). Any help or guidance is appreciated.

I only find WS C621E Asus, can you link me to download page for W621E, or did you mean WS C621E? Also, please list exact Xeon CPU models and stepping (From the IHS) for each. I mean full S-Spec like SLB9J
Maybe CPU doesn’t matter so much, I can just update the Asus Microcodes with the version in the Supermicro. Asus has more already, but the two in Asus BIOS that are in Supermicro are older versions

You may have to loose one CPUID microcode, if I cannot grow file size. These are current CPUID’s in Asus BIOS 50654, 50652, 50651, 50650 and first two are the ones in Supermicro BIOS, so we keep and update those to match Supermicro.
If you have to, which of those can you give up 50651 or 50650?

Hey Lost_N_BIOS,
You are in fact correct, I happened to incorrectly shorten the name of the Asus board as I typed it without looking at the name (yet I somehow remembered the supermicro model).
The CPU’s are QL1K chips. Let me know if you need any more information.

And as for what you mentioned regarding the CPUID’s, does it matter which we drop? I won’t be swapping out these chips with anything else.


Thanks, and good it’s that BIOS, already editing and almost done. No microcodes need removed, updated and inserted without issue, so no worries on that.
You will need to either use USB Flashback if that’s an option, or possibly a flash programmer if you have. I am unsure if Asus updater, or in BIOS flash program will allow modified BIOS to flash.
And I do not know if you can use FPT on such a large BIOS image, I assume so but I’ve never used it with these, you would likely know more on that than I do

I will edit in BIOS here in little bit, refresh to find mod BIOS shortly, correcting FIT table now and will upload in few minutes

Here is updated BIOS


Wow dam that was quick. Much appreciated. And it does have USB flashback, lets hope it’ll work! I’ll give it a shot tomorrow after work and report back.

You’re welcome, see above for edit! Since you have flashback it should be good to go then! You may need to rename the file to WSC621ES.CAP for flashback. Smaller cheaper USB Sticks usually work best, like under 1-2GB. Flashing LED on USB means it’s working, solid LED means it’s not.
When it’s done, after 1-3 minutes flashing then no LED activity then you can reboot. Or whatever normal BIOS update time is for you on BIOS that large

Well small update, so I can’t get the board to flashback. It doesn’t seem to recognize the flash drive(current one is a 4gb usb 2.0 flash drive I picked up today, smallest I could find), the light on the button blinks for a few seconds and then stays solid and the light on the flash drive never turns on. I’ve tried formatting it FAT, FAT32, and NTFS, have tried the stock BIOS, the modded bios, another flash drive (though that one was a 64gb usb 3.0 one) and I get the same behavior. I also confirmed that it was in the right port. Was gonna contact Asus support tomorrow.

Are you sure the USB has a LED in it? Not all do, test on another system, write some file to the stick and watch to see if LED. If there is LED, and it doesn’t light up on flashback process, then yes it’s not compatible. Only FAT32 for this process.

Look around in your junk drawers, or old computer stuff, hopefully you can find more suited USB stick. I find older and smaller best, sometimes 100 year old 256-512MB and 1GB work better than anything else.

Yea it does, I can see it when I plug it in to my other laptop. And unfortunately I moved into this place late last year and most of my older stuff is back in Maryland and I’m in California sadly. I’ll ask around at work and see if anyone has any old flash drives.

Too bad it’s not working for flashback then Hopefully you can find some old goodies at work, check in the back of desk drawers Maybe also, ask a neighbor or friend in town?

And I just noticed, I left .rom on the file name, please remove so it ends in .cap. That might let you flash with the built in BIOS flashing app (EZ Flash I think). I doubt it though since the file is modified, but worth trying.

For flashback to work you need to rename the modified bios to WSC621ES.CAP
Might also be worth enabling the showing of file extensions in Windows, just so that you really have the file name as WSC621ES.CAP and not e.g. WSC621ES.CAP.bin

Yes, I mentioned that in post #6, hopefully he already did that and my comment in #10 can be ignored anyway due to post #6 And yes, to your second point for sure!!

Thanks for looking out!

Yea I noticed the rom extension and swapped it. Waiting to get a smaller flash drive from some folks tomorrow. They said they’d go digging.

Hope they find you a golden nugget!

Another update, got some 256mb drives and its flashing right now!

Crossing my fingers.

Alright it flashed but the issue persists unfortunately. It gets to post code 04 and sits there. PCH initialization according to Asus’ AMI codes. If I hit reset at that point, it’ll cycle through some codes and end with 66 and one long beep followed by two short beeps which indicates a memory error. This was the same issue as before. Any other potential ideas? If not luckily I can still return the board.

The only other difference I can see that may matter is ME version. Supermicro has and the Asus has (I assumed it would have been the other way around, older ME supporting/allowing the XEON)

You can update to that version, by first cleaning and transferring settings from your current BIOS/ME to that version ME using this guide
[Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

I am unable to find that version to download, so you would need to extract it via UEFITool and then clean and settings transfer via the guide. I can do that if you need, but I would only feel comfortable doing that if you already had a flash programmer in hand to recover in case of a bad flash, due to I’ve never worked with this Intel ME type and the guide specifies it may not cover all settings/necessary info. I could transfer manually from your boards ME to the other ME though, one setting at a time, no guide needed for that it just takes much longer, but still I’d really prefer you have a programmer in hand in case something goes wrong.

If you want to do that, order a CH341A flash programmer, since this is limited time before you can return you may need to purchase one locally for $8-12 or something vs $3 if you order from China and wait.

Hey Lost,

Would it matter if I have the flash programmer in this case since there isn’t a removable BIOS chip on this motherboard (at least as far as I can see)? In the past when I’ve worked with similar devices its needed me to take the chip off of the board and put it on the programmer. Is my assumption that this would work the same way correct?

Can you show me a few good images of the board so I can see if I can locate the BIOS, Asus is usually removable, but I normally only see Desktop boards. If it’s soldered on you’d just need a test clip jumper type cable to use with the programmer.
Never mind, I see BIOS here and it’s QFP package, so test clips can’t even be used on that.

Can you tell me if you see a unlabeled/undocumented in PDF header with 8 pins? If yes, you may be able to use an adapter I can show you on ebay, it’s used to boot from BIOS on a chip (MSI have similar JSP1)
Possible suspect to me is header directly next to the debug LED (under jumpers), or the one right next to that one.

Took a look and the one directly to the right of the debug LED is a VPP_I2C1 header used for Intel VMD and associated sensor readings and the header to the right of that is a USB header. I compared the board to the documentation and I believe every header was accounted for unfortunately.