Allow B0 stepping on Asus W621E Sage

Board has a SPI Header left to the Chipset Cooler. On the other hand there is a GPIO Header at the bottom right side.

Pinout for SPI Header

Pin#1 - NC
Pin#2 - WP#
Pin#3 - VCC
Pin#4 - GND
Pin#5 - CS#
Pin#6 - CLK
Pin#7 - MISO
Pin#8 - MOSI
Pin#9 - HOLD#

Be carefull if you hook up a SPI Programmer to the Header, some new Asus Mainboards (AMD AM4 for example) have 1.8v Bios Chips. So always take a look at Bios Chip Datasheet before you hook external VCC to the Board.

I don’t know the pinout of the adapter I have, only that it’s made to work with Asus boards and MSI boards, and I have used on both without issue. SPI header would be the one you’d use this for! Or you could also hookup CH341A or other raspberry based programmer via cables.
Here is it’s info page, mainly showing MSI based details, Asus is on other side of adapter, but same functions so he only wrote one info guide

If you want one of his ebay listings let me know, you’ll have to message him directly and ask to purchase this item only, he doesn’t have any listings up for this only as extra items in his other listings, but he will send/sell separately I’ve ordered one that way.
He ships from Korea, usually 10-15 days to arrive, and I’ve ordered 10+ times from him always fast shipment compared to many others overseas shipping

Dam while that would be handy as hell to have, it would be outside of the return date. I have exactly 10 more days before I have to return it. I don’t mind taking the risk flashing it. It seems like there are some others that are in the same boat as me. I’ve linked em to this post so there may be some other activity soon.

So you want a BIOS with the other ME version?

If you think that may make a difference then I’m down. I was gonna try and go through the guide this weekend and see if I could make the changes myself. How challenging do you think it’ll be for a person who’s never messed with BIOS modding before?

It is generally easy, but I’m only saying that as a BIOS mod person, I don’t think it’s that hard to follow along though the guide is pretty straight-forward and covers all steps.
However, the guide specifically states it does not cover this type of ME or ME FIT tool, so you would have to do side-by-side and change each setting to match as you go through to be sure all is copied over. I will do it tonight, and see if it looks OK.

*Edit - I just tried, and due to the guide not being specifically for these tools and ME types, and no clean ME files for this specific type and version, I am unable to get a clean error free copy transferred over.
Maybe someone more familiar with ME and CSE SPS Tools could get this copied over for you? @plutomaniac if you have time, would you mind trying a simple transfer from the supermicro board to the Asus board here, thanks!
I keep getting @FPT entry point error on outimage builds (Shown at MCE), and the ME version does not change either (Few settings at top of XML get removed on build when compared to original Asus)

I am reading this thread very interessted, hopefully there will be a way to unlock ES Cpu‘s on this Mainboard.

This is the only useful discussion I’ve been able to find on the web addressing BIOS for C621E Sage. Mine absolutely refuses to boot with B0 stepping Xeon gold 6149 QLQ9s single or dual, with any combo of QVL RAM, GPUs, etc. So a good chance the ASUS BIOS vs my cpu is the culprit. I have changed out and checked every other component except CPU and mobo. Post slows at q code 14, then cycles and stalls at 66 (PXE initialization).

LOST_N_BIOS I found your file here and it backflashed fine (whereas the ASUS updates do not). But system still stalls at Q-code 66. Based on this info do you have any advice on a further mod that would be needed to recognize a QLQ9?

Also, the system has never booted, there is no OS interface- does the CPU have an Intel ME component I need to clean/modify or is the chipset ME the one needing cleanup?

I wanted performance features of the C621E, but Supermicro X11 looks better now. I have a couple dual X10 boards that run ES cpus perfectly. I am still going to take a shot at getting this to work. Would be willing to try microcode mods on the WS C621E BIOS myself after I get educated here a little more. Please advise concerning QLQ9s- Thanks!!

Well the OP said he was able to boot his same Xeon on similar system but another brand Supermicro X11DPH-T, and the only differences I noticed right away was the microcode differences which I edited and posted update BIOS of here, and then the Intel ME is newer in the other board.
But, due to this ME type, I’m not able to correctly transfer in a clean settings transferred ME to the Asus. This may not be the solution though, there could be many other things different within the BIOS itself, which I have no way to compare without knowing exactly what makes the Xeon work on the Supermicro X11DPH-T

In cases like this on a normal desktop board, and CPU works on one board but not another, it’s usually only those two things (CPU microcodes and then ME not as often)

The BIOS I posted here on post #4 has the matching updated microcodes from the Supermicro X11DPH-T, so if you already flashed that in then you are using the updated microcodes that are known to work on the other board

Hi MIT, I successfully backflashed my C621E with LOST’s mod, but still code 66. B0 xeon 6149s, QLQ9s, this forum looks like the only help around.

Have you asked Asus directly via email, or maybe Asus pro’s on the ROG forum? Some of the BIOS tech’s hang out on there, they may be able to look into getting a BIOS fixed for you.

Hey Max, thats interesting, upon a cold boot, my chips will stall at 04 which is PCH initialization, however if I hit the reset button on the board, I will get post code 66 like you and one long beep followed by two short beeps which means no memory detected. I’ve tried memory in all slots with that so I’m pretty sure it isn’t the memory (especially since it works on another board).

EDIT: And Lost, I haven’t asked Asus directly yet or on their forums (since its an ES) but I’ll give it a shot when I get a chance this weekend.

They wont care if ES, especially on the forums, and you don’t even have to say that anyway just give model and CPUID and say it works on competitors board why not theirs

I would ask on the ROG forum, not the VIP forum (if that’s still alive). Maybe ask in the overclocking section too, more interest will be in there and more of the staff that helps with BIOS too.

Thanks, just posted it in the overclocking and tweaking section. Lets hope that it generates some interest.

Thanks for confirming what I am seeing! I have the same code 66 plus the same long/2 short beeps that supposedly indicates that RAM is not recognized. Even though my
Samsung 2400 ECC is on their QVL. One more detail that might be relevant- EVERY time BIOS post stalls at 66 there is a message on lower right of monitor screen ‘system memory abnormal’ with a little code ‘BB’ in lower right corner of screen (image attached).

Before Losts BIOS update (installed OK) I was getting stall at 05, then cycling before stop at 66. Now it sits at 14 a few seconds, then cycles to 66 with the same system message.

These B0 CPUs work on Supermicro X11-DAC, X11 DPG-Q - what is it about ASUS? My C621E board came with BIOS 0401. ASUS 0501 and 0801 both stalled, would not flashback.
Thankfully, Lost’s 0801 mod successfully flashed, unlike any of the ASUS updates.
Still no boot and code 66, but at least I am up to 0801! (THANKS Lost!)

MIT, thankful you raised the B0 issue and Lost provided a better BIOS and some clues to narrow the problem. BIOS lack of support is probable cause so at least not a bad socket or cpu.
I have changed out, reconfigured, or re-seated every component, in case, out-of-case, but same code 66.

I did check with ASUS tech support before finding Win-RAID forum, and the only response was denial- they say my ES cpu is not on their list of supported cpus and that the code 66 PXE initialization means a CPU incompatibility not a memory problem. But AmiBIOS tech data says the code 66 and long/2short beeps are normally RAM not recognized.

Reason I got WS C621E was the OC capability, have 10 days left to return. I’ll head over to the ASUS forum,
but there was nothing last time I checked…
Thank you MIT, Thank you Lost!!


Screen msg w Code 66.JPG

Yo Max, you might as well post your results on the asus forum too. You’re at least getting somewhat farther then I did with video out. Are you using the built in VGA output or an external gpu?

And let me know if you need a link to the post, I can PM it to you, I dunno the rules about posting direct links to other places on this forum.

You’re welcome @maxdata Did you guys try without ECC? If not, and you have some, try non ECC, longshot but maybe it will work

Sorry I can’t figure out the Intel ME switch for you guys, but since it’s a minimal update it may not have helped anyway… But I suppose it could be the key too, who knows. Wish I could get it for you!
Do either of you have flash programmers? If yes, then I could maybe manually hex edit it in, probably be a fail, but we could still try.

@mitdal369 Do you have X11DPI-N? If yes, does the CPU’s work on that one, if yes then microcode and ME are not the resolution, those both have exact same microcodes and ME versions.
Wait, I see X11DAC has exact same as this Asus WS-C621E too, and you said the CPU’s work there correct? I think so, all three have all same ucodes and ME, confirming that ME and Microcodes are not the only thing that is allowing the Supermicro boards to work with these CPU’s


DPH8 and DPG-QT both have the newer ME, which I was trying to update the Asus too, but I guess this confirms that is not the solution

Hey Lost,

Na I don’t have the DPI-N but I believe it works on that model. And as for non-ecc memory I’ll hit up Fry’s tomorrow and see if I can pick up a stick or two and give that a shot.


Well you do have the X11DAC correct? And it works there right? If yes, then it’s same as this Asus board, as far as microcodes and ME, all same version for X11DPI-N, X11DAC and Asus WS-C621E
Ohh, sorry, that’s maxdata that has the X11DAC - anyway, he said they work there but not in this Asus with same ME/Microcodes, so the answer isn’t in the ME/Microcodes, something else in the BIOS making these compatible.

Thx for the post over at ROG OC. Signed up for the ASUS ROG OC forum, Will add couple pics/sob story
to your discussion as soon as system will let me post.

Pic is showing screen from a 15 pin VGA port on ribbon from the MB, to an old Acer monitor
But got the same post behavior regardless of monitor or graphics interface.
Used other monitors with Rx560 and DVI, GTX 1080Ti with HDMI, and different monitors too.
Also, I tried non-ECC RAM like Lost suggested, and still the same code 66.

I have to get the equipment Lost referred to, havent done any BIOS mods before, but
this problem has shown how valuable it could be to do that stuff. Thankfully Lost is
lurking on this and other forums, guiding victims thru the vendor-created hell
of incompatible BIOSes and microcode…:slight_smile: