AMD and Nvidia GOP update (No requests, DIY)

@Sylar76 is it safe to use GF104 UEFI on GF114? The card is MSi GTX 560 Ti Twin Frozr OC belongs to my friend and he needs it for full uefi uses. The original rom is 62kb while the efi updated is 121kb, made me wonder if this is safe at all.

everything went normal on GOPUpdater (no reds on the end, just warning of no efi rom) and do you know which nvflash to use and which commands to use?

Different size is due to the gop table added to a previous backup bios which hadn’t. Flash it with no problems at all.

1 Like

Hey Guys - I just wanted to thank you for the great tool. My new MSI Z690 w/ 12600k would NOT boot properly w/ my Vega 64 (constant VGA light on boot, among other problems), and with some research and good advice I was told it was likely due to not having an updated GOP in the card’s bios / firmware.

Long story short, having never flashed anything in my life, I downloaded a new VGA bios from Tech Powerup, ran it through the gpuupdate tool, then flashed the adjusted ROM my card using the latest ATIflash utility windows GUI. It works - boots right away, every time.

Great job, and thank you for keeping it updated folks!

1 Like

Hi guys. I don’t have for collection:
nv_group_GA1xx_0x60006.efirom
nv_group_GA1xx_0x60008.efirom
nv_group_GA1xx_0x6000A.efirom
If you have these files, please share.

Hello everyone, I am deep in a project to upgrade the EVGA GTX 580 Classified Ultra vBIOS to UEFI. Original flash chips were too small, 128k MX25L1005C’s. I desoldered and replaced with 256k MX25L2005C’s to make sure that larger UEFI updated vBIOS would fit. Verified that stock vBIOS on the 256k chips works flawlessly, very happy that it worked. But now I have a new problem. Neither GF10x or GF119 GOP updates work with the vBIOS.

The stock vBIOS I am trying to work with is here. As mentioned, it works great on new 256k flash chips. However when updated and flashed neither the GF10x or GF119 updates work and the card fails to boot. I have a CH341A flash programmer so flashing bad vBIOS is no big deal, no matter any problem I can always revert to stock vBIOS and get the card working again (as I have done many times in this project LOL) When I update the stock vBIOS with either GF10x or GF119 update this is the result I get. I know this screenshot is only with GF119, but output is exact same when doing GF10x update as well.


The “There are other ROM images in this binary! Please report it!” error is what I think messes me up. I believe the EVGA GTX 580 Classified Ultra stock vBIOS is a little odd, as the card it has support for interfacing with the EVGA EVBot external overclocking utility, which might make something weird about it. I know no requests are accepted, but guidance would be appreciated. I am inexperienced with modifying binaries/registers/hex etc. So I do not know if to or how modifying checksum bit works, I am hoping that someone with more knowledge than I have might direct me to some answers.

When stock vBIOS is updated with GF119, size becomes 145kb. when flashed with GF10x, is 140kb.

For the sake of simplicity, the link to a google drive folder with the original, the GF10x and the GF119 bioses for the card can be found here. Please let me know if anyone has any insight, the work being done here on the forum is incredible, thank you so much! (Also let me know if any other info is needed, I can get it to you ASAP)

Not really my expertise but ill ask anyway…is the new chip already soldered on the card, if yes is it correctly identified with nvflash? (Dont care of the programmer correct id) Did any stock rom (non-gop updated) worked after flashed in the card with new chip? If so was it flashed with programmer or nvflash?

EDIT: Ok…then my opinion is an issue with the type of image rom of the EVGA and we may presume also that GOPupdater cant deal with this image and its structure… wait for other users opinion, good luck on the project.

A side note for a more dramatic experience and you got nothing to loose, try some base NVidia GTX580 images on TPU (even unverified) as stock then with updated GOP, you may need to change some/or not HW IDs and force it.

Thank you for the fast reply! Yes, the MX25L2005C chips were listed in the nvflash’s executable help page as supported, they’re official. Also yes, I soldered the 256k chips to the card about a month ago and they work when the stock rom is flashed with both the programmer and nvflash. I have been trying to get this to work for a while now and so far I’ve seen that the 256k chips work just as well as the original 128k MX25L1005C chips.

Hi all. The GOP driver on my RX580 is the latest. However, with my Gygabite B450m s2h motherboard - there is a big problem. When turning off CSM my computer refuses to start all the same, then the bios resets to default settings. I tried turning off CSM and then turning Secure Boot on, after that the motherboard turned into a brick, I had to sew the bios with a programmer. Many days of searching on the internet had no result. The problem is typical for Gygabite motherboards, especially for lower-end models (the last bios is on the motherboard). May be somebody has faced the problem?

Sorry but u cant tell us that a Gigabyte B450 doesnt boot in UEFI mode with the proper EFI hardware required, ur issue is other than this for sure, its HW generation from 2017/2018, other from that u do hear more often in modern mboard the lack of CSM and only having PURE EUFI.

my card is an XFX RX 580 2048SP Black Wolf as seen here and the vBIOS for the model in the TechPowerUp collection(RX-580P4DFD6) does not match mine(RX-580S45DD). So am wondering if someone has the same one and can share the GOP for the same.

What you’re asking here is an original dump vbios (PN:RX-580S45DD) this is no where related with GOP (driver).

The only reported RX-580S45DD vbios dump on TPU (unverified) matchs only a 8Gb… yours is a 4Gb…as mentioned.

I formulated it wrongly. What am looking for is the GOP for RX-580S45DD because the only reported RX-580S45DD vbios dump used in the GOPUpd to obtain the GOP matches only a 8GB and mine is a 4gb.

No my friend, GOP (a dxe driver) version doesn’t care about vbios version/size, this is what the tool (GOP_Updater_v1.9.6.5.k_mod_v0.4.9.rar) does, it updates the GOP in any version of vbios/size.
Share your original vbios dump here if you want.

Hello. I can’t download the file because of the viruses that Google writes about. Please help me provide a link. I also attach my bios from the GPUz. Please help update it to Vbios

Fixing last-image-bit in PCI Structure of Legacy ROM!
Using last byte for checksum!
EFI is NOT last image!
Fixing ID, last-image-bit and checksum for EFI image.
File “GK104_updGOP.rom” with updated GOP 0x10038 was written!
I uploaded my bios through the GPUz of the video card and ran it through. Having received the message above.
But when checking the file, there are no visual differences.

You keep telling…uploaded, attached, but no files linked or attached on your posts.

EDIT: I wont do any vbios mods or updates, the GOP updater is for updating the EFI driver needed for UEFI boot, most vbios have a legacy vbios for CSM boot and an efi part for UEFI boot (no CSM), mods and flashing is user risk only and decision.

Every user should always search for an oficial OEM vbios update, a decision for a 3rd party vbios from sources like TPU is again user own choice/risk.
The correct pcb, revision, sku etc… is details NOT to depreciate upon this search on other vbios sources.

Unfortunately, new users cannot attach files. I give a link to the cloud.
file GK104 is the original. And the GK104_updGOP file, what I got after the firmware.
I need to get vbios for my video card. In order for it to run without CSM

Okay, I understand you. Thank you! Just specifically for my video card, I can not find any VBIOS version at all.
GV-N66TWF2-2GD/F1
GTX660ti

Why not… doesnt your search engine works, Do you know how to use a PC??? Damm sir…

GV-N66TWF2-2GD (rev. 1.0) Support | Graphics Card - GIGABYTE Global

This is a UEFI vbios F2 version (2013/03/22), what is the model of the motherboard?

EDIT: Nice and easy motherboard, fully UEFI compat. Just bios settings to a full UEFI OS and thats it, No AUTO or CSM.

Try another card or other output port, check UEFI/PCI rom priority. A user with a similar Gigabyte model can be more specific on these details that im not going to loose time with it and no Gigabyte board with me now, good luck.

PS: I checked the original dump of the bios (F1), take the oficial update (F2) as it nedeed.