AMD and Nvidia GOP update (No requests, DIY)

thanks for reply bro. yes when i do Nvflash --check, it does show EEPROM ID (C2,2011) MX MX25L1005 2.7-3.6V 1024x1S, Page. im guessing that means 1024 eeprom wont work. Does this mean having to change the vbios chip itself on the board?

No “bro” here and yes to increase size you must glue a new chip right next to the original…let it dry first :upside_down_face:. Wait…give some vitamins to the old one…it may grow a bit more. :innocent:

EDIT: See there you go… its all possible in these modern days… cheers!

lol xD thanks sis :stuck_out_tongue: Just bought some vitamin c and D! xD

@defch1k @Jackdanielz

yup it is not designed. the only thing i ever done it, is on a MSi GTX 560Ti Twin Frozr of my friend, which luckily the gpu does use 1Mbit (125KB) bios chip. the initial dump was 64KB (or 80, i kinda forgot), then i do the same thing you did, got the latest uefi Gop for fermi GF10x, resulted in 121KB of file, which sitll fits, decided to go flash it, and now the 560Ti got UEFI GOP and still runs normally, from UEFI less gop.

The thing is even i you could update/add the gop, you need at least plenty bios chip size to fit the bios.

Also used the version 5.69.2 of nvflash.

or send your gpu bios dump files here (not downloaded online).


@MeatWar @Koekieezz
I also got 1024k, so I will leave everything as it is, in the future I will update the video card and that’s it. Thank you for the information.

Some advice please. I’ve used this tool a couple times before and it works well

I have a R9 270, which I have extensively tested, overclocked and undervolted and has a single 6 pin connector. I’ve added UEFI GOP before too. All good. But to use with a Hackintosh it would be better if it was identified as a 270x (its actually clocked same or better and same config of ROPS/TMUs etc). But if I were to flash a 270x BIOS on it then the card would expect to have TWO 6 pin connectors attached which is not possible. So ideally I need to change the DEVICE_ID from 6811 to 6811. Presumably that will bork the checksums etc?

So, should I hexedit DEVICE_ID and then use this tool to add UEFI GOP and will it then fix checksums? Or does simply flashing a 270x rom still work despite lack of 2nd 6 pin connector on PCB?

The R9 270 can be flashed with an Apple EFI HD7xxx rom, available info on Macrummors and Netkas. Card will work in macOS and Win (Hackintosh), but if updated with GOPupdater no longer valid for Apple EFI boot. Hexedit is only valid in legacy vbios… doubt that can fool the EFI image…still not sure if any successful flash.

Hi, I have an RX 5500M on my laptop, which doesn’t support GOP(for some reason)
I tried to run GOPupd
it shows this

Fixing last-image-bit in PCI Structure of Legacy ROM!

Using AMD byte for checksum!

Fixing ID for EFI image. No checksum correction is needed.

Removing unnecessary end padding.

Data after ROM and not part of EFI! Please report it!

Recovering extra data at the same offset 0x20000.

File “Navi 14_updGOP.rom” with updated GOP was written!

is it safe to flash this or do I have to do extra steps?

It does not work like this. Even if you add gop, in the bios you need to disable combatibility mode(csm) and i doubt that you can.

What laptop is that that use a 2019 gpu and don’t have gop already?

CSM is most definitely disabled
it’s just that the dGPU doesn’t support GOP, the iGPU does, which is connected to the internal display

The laptop boot initialization is done with the iGPU so they didnt put in bios an EFI GOP driver for the Radeon.

Anyway if that is the case he don’t need gop.
Also i thought that uefi gop 1.67-1.68-1.69 is only for polaris and below. He seems to have rdna card, or i am wrong?

This is not a problem at least for polaris cards:
Fixing ID for EFI image. No checksum correction is needed.

Removing unnecessary end padding.

Data after ROM and not part of EFI! Please report it!

Recovering extra data at the same offset 0x20000.

Yes, my ‘card’ is RDNA 1, I wanted to disable the iGPU and use an external display only, but I can’t access the UEFI BIOS with that

GOPUpd v1.9.6.5.k mod v0.5.2

  • Fixed: AMD GOP thx MeatWar

GOPUpd v1.9.6.5.k mod v0.5.1

  • Fixed: AMD GOP

GOPUpd v1.9.6.5.k mod v0.5.0

  • Added: AMDVBFlashDriverInstaller v1.1.0.0
  • Added: recompiled (VS 2022) GOPupd.exe|GOPupd.dat
    python37.dll|VCRUNTIME140.dll (Python v3.7.14)
  • Removed:
  • Updated: AtiFlash to v3.31
  • Updated: nvflash64 to v5.735.0


Thank you to everyone who continues to support the project!


When I drag and drop vbios_1638 to GOPUpd v1.9.6.5.k mod v0.5.1, I still can’t patch the GOP, the screenshot is as follows.

However, the device ID 1002:1638 is indeed included in the amd_gop_IDs_2. file

Just on version detection… as its seems to get updated anyway. (152.7 KB)


1 Like

The problem seems to be that the file does not contain a gop file.

I updated to the last GOP
When i open the new updated gop vbios again, with gop update tool it says the gop file is note present in my database and that i have the latest gop.

Also the gop that meatwar provides it has offset 0xE850 for 512kb vbios.
There exist also the offset 0xe858 offset for the normally 256kb bios.
Can you make an extra tool specically for me,with my gop that i provide?
bottom is the gop with the right offset for my card.
234393-256.rom_newGOP.rar (114.0 KB)

1 Like

They are in the zip.

vbios_1638.dat -
AMDGopDriver.efi -

If I understand you correctly, you tried to update a VBios file with a GOP Bios file.
This is not possible. Please use the UBU tool for Update Motherboard-VBios.

The mod_CW56-58.rom is up to date, there you can still update RAIDXpert2 v9.3.2-00130.