AMD and Nvidia GOP update (No requests, DIY)

The re-link is not mine but its still working , the only browser not posting a warning is Edge… so take it or not, its user choice.
Contains the following:

Hello, I’m having difficulties getting the software to run correctly it would seem. I even did a fresh OS install on a spare partition but received similar non-results.

If this picture shows up, this is the best I can get out of the GOPupd.bat. It just tells me to exit and doesn’t perform the intended functions.

The latest version is being used, in a folder on my desktop. I’ve tried with python installed and uninstalled but when i drop the ROM file onto the BAT I get a windows10 pop up asking me to select a program to use with .VBS files.
The above picture is me going against the instructions and running the BAT as an adminstrator. The BAT opens and asks me to locate the ROM. Once the ROM is selected it just sits there saying to press any key to exit.

I’ve considered that my bios files are maybe to blame so I tried a confirmed working one that had been linked here in this chat and nothing changed or acted any differently.

Willing to admit my existing Win10 install has been mucked with too much for this process to go smoothly, I did a fresh install of Win10 on a free partition I had available. But even with a fresh OS the BAT file immediately closes.

I would greatly appreciate it if anyone could provide some guidance.

Cant you see, it lacks Python?
Its rigth in front of you…

EDIT: Python path when installing

Oh I’ve noticed. Thank you.
The result does not change, with or without python.

Interestingly enough, with no changes to system config, experimenting with mod 0.5.2 has produced a result. I’m still actively trying to resolve these issues and will document progress, even if PEBCAK. :wink:

EDIT: Made some progress and a new ROM file was produced but unfortunately after flashing and turning off CSM I was alerted at POST that my RX580 still does not support UEFI/GOP.
I am unable to compare or utilize the #AMD_ROM_Info.bat file as it too will just close immediately.

Ok, the issues with the software were resolved on the new OS install by using GOP_Updater_v1.9.6.5.k_mod_v0.5.2 so at least that’s out of the way.

However, the ROM file produced still does not allow for disabling of CSM. I’m concerned this is because of “Data after ROM and not part of EFI! Please report it!

Here are the results from #AMD_ROM_Info.bat

Link to stock ROM Stock
Link to modified ROM that I eventually intend to use with this Modded

Can be ignored, still make sure you know how to recover, this is a mod and no one can assure you that it works with all vbios around or all gpu cards around.

EDIT: Sir… cant you understand this kind of tools are user made and with limited tests… im not saying that cant work, you want to be sure of anything else, someone with the exact card model (RX580 is not enough, and i really dont care…) and done the same update with this tool, can confirm it to you, understood?
Good luck, over_n_out.

EDIT: No my friend, not frustrated i just cant understand why people seek 3rd party tools made by regular or advanced users, with or without proper knowledge, and expect assurances on risky operations…this is mod world and here everyone take their chances in success or not, simple. By the way the utility is not my work.
All we (users) here do, is trying to help the best we can…but please, with questions like that in a user forum…with such tools…

Recovery is no issue, thank you for the advice.

Do you mean to say that the XFX RX580 8GB, Part No. RX - 580P8DBDR, POLARIS XTX, Device ID 1002 67DF - 1682 C580, Memory Module Type: Samsung K4G80325FC is not supported by this process?

Edit: Meatwar, I can understand that you are frustrated and unwilling/unable to converse on this topic with the patients that some new users might require. It was my understanding that it was appropriate to ask questions in this space or seek assistance provided I’ve read the instructions. I apologize if I have misused this space but you should understand that being condescending is very unwelcoming and unhelpful. I am in possession of all relevant details and if I have not outright provided them I am happy to do so even if, as you say, you do not care. Again, apologies.

Edit: Meatwar, please do make make such assumptions that I have any expectations and then mistreat me for them. I’m aware you’re not the author of the utility. I’m aware it may not work for my application and have not indicated otherwise. You’ve been rude from your first reply and your conduct is abhorrent. Here’s what “I just can’t understand…” why people seek to be rude to individuals who have joined a community with the interest in 3rd party tools made by regular or advanced users, with or without proper knowledge, and expect them to have somewhere made demands of assurances on risky operations… in a mod world where everyone takes their chances in success or not, simple.
I came here to seek information and learn from the community, not to be lorded over by frustrated individuals on the opposite end of the internet.
I should think this interaction of yours and mine should come to an end now, understood?
Good luck, over_n_out.

If anyone is interested, here is the link to the resulting ROM produced from my stock ROM by 0.5.2
It works as normal, but will receive an error at POST notifying lack of UEFI/GOP function when CSM disabled.

1 Like

So you’re not having luck with that vbios and GOP1.70
Just flashed an older Club3D HD7870 with GOP1.70 and PURE UEFI system is ok…
See…thats it, its how it works.

I’d like to add GOP drivers to my Sapphire HD 7870 GHz edition and also overclock it as far as possible. Currently it has about the oldest original VBIOS listed on TPU. I plan to get the latest VBIOS from TPU, which happens to be for the OC edition (has higher power limits, but seems to be identical for RAM etc.) and add the GOP:

Should I first flash my current version with GOP to test it, or would it be reasonable to go straight for the newer version from TPU? I have an iGPU available if necessary.

I contacted Sapphire to get the latest VBIOS directly from them. Their customer support said that they don’t have this old card in their database anymore but that they would contact their engineers who would send me the latest file (but without GOP). Now one week passed and I haven’t received anything yet …

what worked on me is the one with GOP AMD REV: x x x x on version 1.70, it was posted here, the one that is 256kb (EFI Image Offset 0xE858, not E850.), this one should be able to boot with CSM OFF (or secure boot keys installed). here you go: (110.1 KB)

Here you go: (98.5 KB)

1 Like

Thank you for your insights! I’ll set some time aside to experiment and report back :slight_smile:

Unfortunately the bios did not work.
But I think I know what the problem is now. I wish to use a bios that I’ve modified, this means I must use the benefit of the GOP Magic version for a result. But that version doesn’t allow booting in UEFI either because the tool claims the GOP is already up to date and so will not perform any action on the bios file.

I could be mistaken but read that these tools are unable to downgrade or remove existing GOP, only update them.

For the moment, I can utilize an unmodified bios for an older version of my card that does work with UEFI - but the clocks are incorrect and the timings are slow.
Ellesmere MODDED TIMINGS.rar (107.5 KB)
This is the bios that is meant for my exact model with modified timings that I wish to have working UEFI with, but alas, I’m admittedly stuck.

Can you help me out too?

I have a Strix RX480 OC flashed to Strix RX580 OC and can’t also disable CSM or activate REBAR, both give black screen on bios and only shows image after windows loads…

You told me in other thread to use saphire bios, but that’s something I would like not to do.

I already tried updating GOP but it’s the exact same so I flashed again the old bios with old GOP…

This is the bios from my GPU (note: GOP not updated in this one):
bios.rar (106.9 KB)

ps: Could it be some UEFI module is needed? If so can someone please add?

biosroms.rar (107.8 KB)
bios_gopupd1=efirom from 256kb version (E858)
bios_gopupd2=efirom from 512kb version (E850)

both using gop 1.70, if you have a modded bios it needs a magic gop.

1 Like

EDIT: None of them worked.

But I checked that Magic GOP and BOOM, it’s working now haha :sunglasses:

I just changed “set PATCHED=0” to “set PATCHED=1” on the GOP updater app .bat file.

Captura de Ecrã (107)
Now I can make Resizable BAR to work on RX580 with regedit mod to test :smiley:

ps: Thanks a lot for the info!!!

I am currently having a similar issue. I have an Asus ROG STRIX RX580-OC 8G. When trying to enable UEFI and therefore disabling CSM the motherboard auto switches back to CSM because the GOP doesn’t work.

I have looked into this program but found that the modified bios showed no differences when comparing in AMD_ROM_INFO. The program also mentioned that I have the latest GOP and that the one I have isn’t in the database.

Also, trying to find a matching bios on TPU was difficult because the VRAM my card has is Hynix AJR, and only 2 of the total unverified bioses match, one of which I think is mine…

Any help would be greatly appreciated. Also, I will attach the stock bios and not the modified one because I can’t find it… Here