AMD and Nvidia GOP update (No requests, DIY)

Not really my “field” of expertise, wait for him… but indeed i surely like to know what is your opinion on that VENDOR ID DEVICE ID… from MARS or PLUTO?
Your saying that the 2 vbios images are from your VEGA card? With 2 different VEN/DEV HW ids?
Mining fuxxxxx??? I hate those fxxxxx, are you a …

I have two VEGA FE graphics cards, bought from ebay US
The time of purchase is different, 2019 and 2020 respectively

I don’t know if these graphics cards are ever used for mining, I hate mining too

Just to be on the safe side, I have consulted AMD technical support
I provided the manufacturing serial number of the graphics card to AMD, and AMD officially gave me an original vBIOS file after about 2 days, after which I used the Gop Updater to update the GOP of the vBIOS

I have been using Gop Updater for a long time, I have encountered the above problem, just wanted to come up for help or discussion

I have never used a graphics card for mining since I bought it, never

1 Like

Still dont get it how your Vega is NOT reported as 1002 6863… damm all the guys on TPU, going to be insane…


I think you may have misunderstood what I’m trying to say

Use #AMD_ROM_Info.bat to open amd_gop_vega.efirom in the #GOP_Files folder, and you will see the picture I just uploaded

So my question, amd_gop_vega.efirom this file
Although the version number is the same but some details are different?

Here are the two vBIOS files I got after replacing amd_gop_vega.efirom
The red frame is the difference between the two vBIOS

Sorry, i can’t answer to that difference on the AMD gops from 0.4.8 and 0.5.2, a lots of good users have taken this tool in hand since last update from Lordkag, and it has changed a bit from the original tool, wait for their help on this subject.

You just keep point in RED the offsets in the EFI image… and you keep asking about AMD GOP diffs…
in 2 vbios not dumped from the same card… you’re a hard person to understand, so sorry i may be the on seeing this in the wrong way… I NEED HELP here… you’re driving me nuts or im getting tired…

1 Like

thanks again for your help : )

I’m just worried about whether the GOP files with the same version number but different differences will affect the work of vBIOS


When I wanted to update my GPU GOP, i was told my card has the newest GOP not included in the forum.

So I share the VBIOS to the forum. Maybe someone can take the newest NV GOP file from it.

PS, my card is MSI Geforce RTX 3090 Ti Suprim X 24G. It is the original VBIOS.

The download address: VGA Bios Collection: MSI RTX 3090 Ti 24 GB | TechPowerUp

1 Like

for nvidia turing cards and newer, you could try this instead: GOP Update and Extraction Tool (NVIDIA Only)

i couldn’t decide which to pick. i have GTX 560 SE exactly this one ;GTX 560 SE specs it uses GF114 gpu , when i run BAT file it gives a screen like this ;

which one should i pick ? there is no GF1xx on the list ?

i also get this screen when i use bios updater downloaded from asus site for this series,
link to screenshot

Thanks for your time !

So… lets look again to the 2nd screenshot you have taken and put those brains working.
GF104B… does this looks like a GF119 chip?

Want to try the FERMI2.0 gop… its your choice if you know how to recover from a failed flash.

1 Like

I dropped my vbios on the GOPupd bat and got total blank. I then dropped it on #Nvidia_Rom_Info bat and got an instruction to drop it on the bat again ?

BIOS: VGA Bios Collection: Powercolor RX 6700 XT 12 GB | TechPowerUp

Trying to open it with GOPUpdater.bat results in

Using python from GOPupd

Dumping info from = Powercolor.RX6700XT.12288.210225.rom

ID of ROM file    = 1002-73DF

Found Unknown header before ROM start, size 0x14000

ID of ROM file    = 1002-73DF

Extra EFI ROM found at offset 0x14000!

***         Extracting with UEFIRomExtract by AndyV         ***

Found compressed EFI ROM start at 0x64
Input size: 38300, Output size: 65192, Scratch size: 13368
Found compressed EFI ROM start at 0x64
Input size: 39836, Output size: 72128, Scratch size: 13368


***                Extracting with GOPupd...                ***

Traceback (most recent call last):
  File "", line 2929, in <module>
  File "", line 1802, in efi_version
IndexError: list index out of range


The tool is not up to date for the latest and bigger vbios…we can say that stoped at POLARIS generation.


Hey guys. I have gotten an MSI AMD R7 370 Gaming 4G so i can finally retire the pretty much pre-historic GTX660 1.5G that came with this (pre-built) system, but apparently this card sends the installed OEM Medion (MSI) MS-7848 board (with an i7-4770 socketed in) on the fritz. The moment I boot my system after instelling the new card it’ll simply refuse to POST at all with 4 short beeps which according to MSI is an issue with the memory or the timer (and it’ll keep on doing that even with the old card, if I’m lucky It’ll kick back to life after some serious rapid repetitive power cycling. That gave me the impression its neither memory or timer related because if I swap the new card back in the problem just re-emerges).

People on the interwebs have suggested that this mobo doesn’t support UEFI-only video cards, and in the UEFI of the board there are no settings related to CSM leaving me unable to start it without legacy BIOS support. All I can do in UEFI related to this is swap OS from Win8 to Other OS and enable/disable secure boot.

Could this tool be of any help getting legacy support on the card? If so I’ll gladly take the card over to my friends so I can dump/fix any vBIOSes or UEFIs or whatever you need to be able to diagnose the possibilities for this GPU.

The motherboard may require the Legacy vbios image from the R7 370 but on this generation of Radeon the Legacy and EFI vbios images were present on it.
The GOP updater is a tool for keeping the EFI GOP driver updated on cards that have it or add it, nothing more and doesnt works with Legacy vbios image parts.


Usually Win 8/Other OS option is the one who triggers UEFI only board, but have you tried to update the bios? the latest bios i could find on ver .304 have the option to boot on UEFI:

Bios Link: Treiber & Updates

I would’ve thought the same thing, but apparently the precense of legacy support differs between the third party ones. The Sapphire ones for example have an actual switch to change between legacy/UEFI while these MSI ones supposedly don’t have legacy support at all (I can’t verify this information at this point though, I actually kinda hope that the last bit is poppycock or else I might need to find myself a retail board instead of this strange OEM one.)

I have been running that version since somewhere in 2017 or something :stuck_out_tongue: And clearly the board supports UEFI in some way if secure boot is available, legacy BIOS didn’t have secure boot at all if I am not mistaken.

1 Like

No… that switch were used as Backup vbios or some models as OC vs Standart vbios, not as Legacy or UEFI vbios.
The motherboard has Secure Boot, it has UEFI (as Optimal) or Legacy (as FAILSAFE) boot. Has Quiet boot Disable as FAILSAFE or Enable as default Optimal.

The stranger thing is that the Optimal settings has CSM Legacy with Win8 selection also as default Optimal on OS Configuration, being the Oprom loaded as Legacy priority, only in Failsafe is it set as UEFI boot as default, so you may want to play a little around this.
You can view this option with AMIBCP 4.x

pcloud is being treated as an attack domain, and it seems no longer hosts the most recent uploads for the toolset.