Anyone modded/unlocked CyberPower Tracer 2 laptop (Quanta NL5E chassis) with Insyde QP121 BIOS?

Hello,

I recently bought a CyberPower Tracer 2 gaming laptop (I7-8750H / RTX2070) and have found it has a locked BIOS as there are very few options for a gaming laptop - even a normal laptop at that!
I cannot find any BIOS updates from Quanta neither CyberPower.

Moptherboard: Quanta NL5E (U3E1)
Chipset: Intel ID3EC4 (Intel Mobile HM370 ? )
The current BIOS is: INSYDE QP121 Rev 5.0 - Build Time: 01/14/2019 - ME FW Version 12.0.6.1120

I wanted to find out if anyone has unlocked or flashed a modded BIOS to onme of these or similar laptops or to a Quanta barebones chassis like the NL5E which has an Insyde QP121 or similar BIOS.

I know the first step is to extract/dump the existing BIOS so it can be looked at.
I have searched through the forums for a beginners guide but haven’t found anything - I know there is one but I just can’t find it
Please could someone just point me in the right direction?

Another thing is I have recently discovered my laptop refuses to boot from USB.
I have contacted CyberPower UK support who suggested a few things but they didn’t work. As I bought it used the warranty isn’t transferable and they can’t help any further

Thanks,

Markiexxxx

@Markiexxxx - Please show me model stickers on the system, from what I can see only Tracer III has the CPU you mentioned. I’m trying to grab the stock BIOS to look at, do you have a link to download from anywhere?

USB Boot may not be needed, but surely it works, you just have to find compatible USB and method (USB port that works, USB Format that works - size and format FAT32/NTFS / DOS or UEFI, contents etc)

Anyway, lets dump some stuff and see if we can make any progress as-is! Please download this package, and from CMD prompt run the command below from each versions folder which directly contains the exe for each version, leave all contents in place and then upload back for me once done.
First, install this registry file, and then reboot. It will make it so you can right click anywhere and choose open CMD Prompt as Admin here, then all you have to do is select each versions folder and right click, open Admin CMD Prompt here and run the command
http://s000.tinyupload.com/index.php?fil…134606820377175

Then here is tool package - http://s000.tinyupload.com/index.php?fil…610455156831773

Here is command to run - H2OUVE.exe -gv vars.txt

Then, lets dump BIOS region with FPT, and test if you can write it back or not (probably not, at first, or possibly at all, we shall see, you may need flash programmer like CH341A + SOIC8 test clip w/ cable)

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required
> CLICK HERE TO DOWNLOAD CMD PROMPT REGISTRY ENTRY <

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

Hello Lost_N_BIOS,

Thank you for your reply.

There are no ‘Model Stickers’ or product identifiers on the unit. I visually identified it by looking at the CyberPower PC UK & US websites current & past models with same base spec as mine and decided it was closest to a Vector II-Z. It may be a Vector III with the RTX2070 card.
Doing a search ‘HotUKdeals’ had a link to a CyberPower UK page which looks like it on sale/special offer - simply called ‘Vector’ but it has my base (chassis barebones) spec:


I did contact UK CyberPower support requesting more info about my unit as searching the serial number on their website wasn’t returning any results. I also requested the ‘control centre’ software for controlling the lights etc and an updated BIOS. Their reply was;
“Its a custom build laptop so its not like a dell stock unit, we don’t have manuals either as most of the laptops we build are different.” "Its very rare we get BIOS updates for the whitebooks (barebone systems)."
Then the guy mentioned Clevo which suggested they also use the Quanta chasis & BIOS.
To be honest I’m quite dissapointed with CyberPower PC so far as they don’t seem very customer focussed (not to me at least) and not easy to find any info on older models or driver software on their website. The ‘control centre’ software support sent me is a bit buggy and they did say it was from a similar model.
Having said that this is the only label on my laptop (apart from Intel & Nvidia ones) - it has the laptop CyberPower S/N and Quanta model & S/N on it;


With booting from USB I tried allsorts, all the 3 laptop USB sockets and 3 different memory sticks (all Sandisk - 4gb, 8gb & 16gb).
All the USB sticks booted fine in all my other laptops; old manky Dell XPS M1730, Samsung X05, Toshiba Satellite A660, Alienware 13 R3 and an old Dell Vostro 200 desktop. I even tried in a friends Alienware 15 R3 (I7-7700 & GTX1070) and it worked as expected.

Right back to business.
I ran the H20UVE package and uploaded it: http://s000.tinyupload.com/index.php?fil…535883211851967

HWINFO Reported the ME (12.0, Build 1120 , Hot Fix 6):

Unmodified Factory BIOS dump: http://s000.tinyupload.com/index.php?fil…702393976035103

BIOS region dump write back error (Error 167):

Please let me know if all that is ok - can’t do anymore today as the battery is low.

Thanks for your help & efforts, much appreciated

Markiexxxx

@Markiexxxx - You’re welcome! Well main reason I wanted stock BIOS was just so I can save this in a proper folder, in case someone needs BIOS or work on this BIOS in future. I guess I will just name it CyberPower Tracer 2 I7-8750H-RTX2070-Quanta NL5E
Most models have some name like this, which is another way you can tell what’s what and what BIOS is compatible with what system (since same BIOS can be used across different re-branded same systems usually) >> GK5CN6Z << I bet I will find yours in your BIOS dump, I’ll let you know

Error 167 is often major pain, usually needing flash programmer to bypass or at least reflash with programmer if you don’t want to spend the time to try and bypass 167 (FPRR)
Hopefully we can get you past that with H20UVE! If not, you will need CH341A + SOIC8 test clip with cable to flash in mod BIOS.

Ohh! One more possible thing may help! Please try this as soon as you read. Put system to sleep (S3) for one minute, then wake it up and try the FPT write (#2 command) again and see if you still get 167 error or not.
Sometimes there is sleep bug in BIOS that disables all protection

Sadly, I can’t see the for sure menu edit in this BIOS
So, once we figure out for sure if you need flash programmer 100%, or not and you can do once disable some things with H2OUVE, you’ll have to ask the guys over at BIOS-mods.com forum to unlock the BIOS. Dudu2002 will be able to unlock for you
Insyde BIOS is a thorn in my side, I can’t get hidden menus on maybe 50%, need more skills. I will keep looking, but I don’t have high hopes (already spent maybe half hour, didn’t recognize anything in areas where it’s usually at, that I do recognize)

For now, lets see if I can help you bypass 167. If the above sleep method did not help, then download this and run the following command way as before
Errors will be shown for some areas, this is normal, reboot and once back in windows try the FPT write command again and see if you get success or 167
http://s000.tinyupload.com/index.php?fil…903102075450910

H2OUVE.exe -sv varsM.txt


I tried sending it into ‘sleep’ for a minute but got the 167 error again;

However, not sure if my system is going into an S3 state as it mentions ‘standby’ for S3 when I run powercfg -a;


Hurrah!!! this seems to have worked - some failed;


Retrying the FPT write command - “FPT operation successful”;


I have posted an unlock request on the BIOS-mods.com forum as suggested and am waiting for a response.

So how to proceed now - Do I need to update the other post with any info from your last suggestions and second successful FPT run?

Thanks again!

Markiexxxx

-----------------------------------

Errrmm… I now can’t access the BIOS with F2 or get into the boot menu with F12…

The bootup splashscreen no longer displays the rotating circle of fading balls under the ‘Quanta’ logo as it did before. It loads Windows and seems to ‘work’.

Is it time to worry?

EDIT: Dudu2002 has replied to my other post "Your bios is rewrite protected…you need a SPI-programmer+SOIC8 clip only…"
Does he need to know about the things we tried above? Does that change anything? (in addition to not being able to access the BIOS now)
I’m guessing the second H2OUVE package you sent me to run ‘unlocked’ something for the FPT process to complete successfully without 167 error?

---------------------------

Quick update: It has started responding to F2 & F12 again so I can get into BIOS and boot menu as before - but still no rotating circle of white dots on the splashscreen as before.

After you write vars, you can’t then write old BIOS region in again (this will reset vars back to original state). At least now we know you can write this BIOS without flash programmer
You need to write back in mod vars again, then dump the BIOS region again with FPT and send me the new file

Your windows boot stuff is related to BIOS UEFI/legacy BIOS settings, you can get into BIOS via advanced recovery options from advanced windows startup options - https://www.windowscentral.com/how-enter…-windows-10-pcs
Once in BIOS, change back to what you had set before, UEFI or legacy, CSM enabled I assume too.

You can tell Dudu2002 users can dump vars with H20UVE and he can unlock BIOS Lock + FPRR via vars edit, he will know what this means.

Rotating circles of dots? You mean you want to wait? Probably still you need to set boot method to legacy or UEFI, whichever you had before, and CSM too.

Now, do as I mentioned above, write back vars again to disable FPRR (167), then once in windows dump BIOS region with FPT and send me the new file (FPTw.exe -bios -d biosregnew.bin)
* Edit - Ohh! Sorry, I maybe still not be able to unlock BIOS menu, but I will look once more when you send me the new file. Otherwise Dudu2002 will unlock it for you for sure.
You can tell him you don’t need programmer due to 167 bypass with H20UVE, please unlock BIOS region only and send back to you.

Hello Lost_N_BIOS,

Thank you for your reply. I think we’re getting our wires crossed about the rotating dots thing. It is just an animation on the screen which stopped appearing after running your last H20UVE package.
BUT - it started working again today and this is what is looks like: https://tinyurl.com/yc8cp7p4
However, it seems tempremental because after 3 boot-up it no longer shows on the screen under the ‘Quanta’ logo.
It’s not too important - I just got used to seeing it on power on and it looks nice

Yes I did think not being able to boot from USB was maybe a hidden BIOS option.
I tried the Windows startup options and selected boot from USB but it gave me the message: - I do have USB set in position 1 of boot order.


Anyway we can leave that for later lets get down to business.

Can I just double check what you want me to do so I do not end up with a bricked laptop.

So far I have;
1. Dumped my factory unmodded BIOS using command ‘FPTw.exe -bios -d biosreg.bin’ to file biosreg.bin
2. Run your last H2OUVE package with command ‘H2OUVE.exe -sv varsM.txt’ which changed some regions successfully & others failed.
3. I then did a write back of the BIOS Region dump using command: ‘FPTw.exe -bios -f biosreg.bin’ which completed successfully without the 167 error.

Now you want me to;
1. “write back in mod vars again” - Please can you confirm what I am doing/running in this step?
2. Dump the BIOS again - 'FPTw.exe -bios -d biosregnew.bin’

Thanks,

Markiexxxx

Yeah, I knew that’s what you meant. This is “Windows Loading” dots, longer load times and the dots are there, faster load times and they are not, this all depends on how fast your windows loads, and or the settings I mentioned as well

For USB Boot, there is probably a hotkey to get boot menu at startup, instead of BIOS Key, where you can choose to boot directly to USB. That’s how it normally is on most systems. But usually it will boot to USB if you put USB first in one of the boot list priorites, but some BIOS have two and one really isn’t actual boot order, so you have to make sure it’s the correct one. Then, as above, depending on what boot mode you have set Legacy or UEFI, you may only be able to boot to certain USB depending on that setting and depening on what kind of bootable USB you created.

You should have done 1-2 only, then dumped BIOS again and tried to write it back, that’s where it went wrong. When you wrote 3, you overwrote the vars changes, so you put BIOS back to square one again.

So yes, do 1-2 in your last steps, as I mentioned at post #6 - here’s why.
1. Writing in the modified vars so you can bypass error 167
2. Dumping new BIOS region with the changes contained within, so they remain in place.

Then I will take the biosregnew.bin and modify it for you, then you program it back
Or this is what you have Dudu2002 modify to unlock menu, if I can’t find it, then you program it back



modified vars written in:

I think this is what you want: http://s000.tinyupload.com/?file_id=03261060709407838786

Thanks,

Markiexxxx

Did you get anywhere with this?

@Markiexxxx - Sorry, always buried and behind here now, I can’t keep up anymore
I looked again, and am still unable to find the area to bypass the locks for this BIOS, sorry You will have to ask the guys over at BIOS-mods.com for help on this one, Dudu2002 is great at unlocking Insyde