APTIO V unlock all menus


Can anyone help me unlock all menus in a bios? I tried but couldn’t make a correct bios file.


mod.23g.zip (5.42 MB)

Did you use the FPT tool?

I’ve tried FPT and efiflash

@graphine - SO I don’t have to look it up again >> Z170X-UD3

FPT or EFIFlash not needed here, you can use Qflash to flash in mod BIOS, however both of those will also work fine too, but we’ll use Qflash

The BIOS you posted above has broken FIT Table, so CPU microcodes currently in the BIOS may not be loading properly. This due to incorrect microcode editing usually, and yes, it’s this, I see bad microcode update due to missing padding there as well.
I will fix this, do you want all the microcodes updated to latest?

Please upload images for me of all your main BIOS pages, and any page you can already see that has hidden settings you need made visible. Show me root of Peripherals too, where I can see all the visible submenus, scroll up/down if needed. You can use F12 to screenshot BIOS to USB
What is your most desired additional mane sub-section? I assume you looked at this BIOS with AMIBCP already, correct? I can only add one more section, unless you don’t need any section (Such as security), then I could replace that with something else too.


Thank you for your answer.

I need FPT or mod EFIFlash because the bios is also modified to remove MSR lock (UEFIPatch), and that triggers a checksum error.
I tought all microcodes are already up to date because I used UBU to update modules.

Regarding the hidden menus I would like to show everything that it’s easy to show.
I looked with AMIBCP already, I’m mostly interested in PCH stuff and Thunderbolt (this board only has usb 3.1 alpine ridge), not really interested in security.

screens.zip (1.78 MB)

You’re welcome! Qflash can flash mod BIOS, you just have to mod it additionally to allow that (See this post), so FPT or EFIFlash is not required here
All microcodes may be up to date, I didn’t check (Just did, yes, all up to date) I just see it’s a bad microcode edit overall due to TWO issues at once (FIT table broken + Padding issue) during the microcode edit. Luckily your board booted, because one of them often causes a brick (padding added or removed, removed in your case)

I can give you one additional menu, is PCH-I/O the one you want? I mentioned security as a possible second section I could replace with something else. Everything hidden from you in already visible sections, no problem there, I will make all that visible and this is why I asked for the images so I could see what you see now.
Thunderbolt stuff is all in Peripherals which you can already see, so no problem there

Ahh! Looking at your BIOS, I’ve done these before, and if I add one due to the GUI stuck in place and already full across the top, usually the added menu will not be a visible tab (but you scroll past all current and it will be there).
Hope you get what I mean, if not let me know and I will explain differently Like if I add PCH, it will be before MIT or past Save and Exit

Also, give me your LAN MAC ID off the sticker, I will show you how to fix with FPT!
Never mind, it’s in the file you attached and it’s already in correct location in BIOS, so Ethernet should be working fine

PCH-I/O sounds good, no problem if it’s past save.

Thanks again.

@graphine - You’re welcome! So, sounds like you get what I mean, about tabbing over past visible menu (ie to the right of save, menu would be there but you can’t see a tab for it)
OK, lets test that alone for now, before I do the full settings unlock Please test each of these BIOS, stop when you get to the one that works (ie you enter PCH-I/O menu past Save and Exit, or Before Main).
Or, if you see PCH-IO as a menu visibly, but this I doubt can happen due to my past experience with this BIOS GUI layout

Flash via Qflash BIOS on Root of FAT32 USB (not in folder)
2. AMIT12

If this fails, I can just go ahead and replace something such as Isochronous Support in MISC, with PCH-I/O submenu, I’ve done this kind of edit on this BIOS before too, it just takes forever.

Due to this edit may possibly make BIOS entry impossible, get DOS FPT/EFIFlash and your previous MAC Fixed BIOS ready in advance in case you need to recover and can’t enter BIOS.
Don’t worry, I don’t mean brick here, I just mean BIOS menu broken so you can’t enter, totally different, just be ready in advance and you’ll be fine

BTW, all BIOS from me will have Qflash block removed and microcodes/FIT table fixed properly, if you want this base BIOS (Stock edit to unblock Qflash, + Update microcode properly w/ fixed FIT) let me know.
Keep in mind, all BIOS I send you are edited stock, DO NOT FLASH With FPT, unless you use the -bios switch! Actually, I included it for you in this first package (Z170XUD3M.23g)



Thanks for the files.
AMIT1O - can not see any difference from standard bios
AMIT12 - shows the extra menu past save and exit

If I want to further mod one of your bioses with UBU (update gop,vbt) and UEFIPatch (needed to boot macos), will it break the fit table? I will not further update microcode.

Thanks. Just wait till I’m done, then you can further mod and upload back for me to check and fix FIT if needed. Usually only microcode update breaks it, but not always, best to check once you are done.
You can check with UEFITool NA Alpha version (51-5x) “FIT” is shown at bottom area, compare what I sent you vs other BIOS you modify, when you see FIT Table empty it’s broken and needs fixed.

Thanks for test result, I will use that BIOS (AMIT12) and make the rest of hidden stuff visible for you