[ARCHIVE] Outdated UBU Tool related Questions, Reports and Suggestions

@SoniX News for the futur 1.71 version ?


He is obviously working on the first non-test version (look >here<). So please be patient.

Yes, that’s why I asked, since version 1.70 is no longer available


Excuse me. The release is delayed, the computer broke. :((

Arrgh. Sorry to hear that. Good luck getting it back together.


A little confused how to recreate the Asus Capsule with UBU?
I select save as usb flashback and UBU saves the file as mod-bios.bin.
Is that correct?

Thank you

@davidm71 :
Why do you want to recreate the original BIOS capsule of a modded ASUS BIOS?
Were you not able to flash the BIOS, which had been modified by the UBU tool?

Well Ubu Tool removed the capsule and saved the file as bios.bin and then I manually edited my bios and microcode file with UEFITool and saved the file.

So now I need to flash this capsuleless mod file using Asus Flashback technique and I do not remember if I need to re-encapsulate the file?

Thank you

@davidm71 :
I doubt, that UBU named the BIOS mod-bios.bin, when you had chosen the “USB Flashback” naming option.
Furthermore I don’t think, that the UBU tool changes the BIOS code itself by renaming it.

I swear to god that it did in fact rename it mod-bios.bin from bios.bin when I selected Bios flash back save option.

However I came up with a solution to re-encapsulating my bios file:
I opened up the original capsulated image in Uefitool and just replaced “as is” the ‘bios region’ with that of my modded bios region and saved.

That seems to work.

I would like to check it. Which BIOS for which mainboard and which UBU version did you use?

I was using version 1.70 rc20.1 updated 11.31.2019 and was for an Asus Z270-WS.

I just tried again in this order:

1. Open Z270WS.Cap and save as bios bin and exit
2. open bios.bin and save as flashback option

and got a mod-bios.bin file.

@davidm71 :
I just have downloaded the latest BIOS 0602 for your mainboard from the ASUS homepage, opened it by using the “UBU tool v1.70_rc20.1_updated 01.31.2019”, updated only the GopDriver (for testing purpose) and then chose the option “Save for USB Flashback”.
Result: The BIOS file within the UBU folder was named Z270WS.CAP.

EDIT: After having read your updated last post I have done the following:
1. I renamed the BIOS file named Z270WS.CAP, which was still within the UBU folder, to bios.bin.
2. Then I ran the UBU.bat again and finally chose the option to rename the modified BIOS according to the ASUS USB Flashback rules.
Result: Within the UBU tool folder I found again the BIOS named Z270WS.CAP.

I did not just rename the file I used the second exit option to save it as bios.bin. Then dragged that bios.bin file onto ubu.bat and when I saved it as Asus flashback I got mod-bios.bin.

I tried this a second time in a clean new folder and same thing happened.

Thanks for trying.

@davidm71 :
As I have written, I could not reproduce your reported UBU problem.
By the way: It is absolutely not necessary to re-add the capsule header, which has been removed by the UBU tool to make it easier to flash the modded BIOS later on without getting an “Invalid Image file” message.

So Flashback technique doesn’t need the capsule? I only ask because the official Asus instructions detail using a cap file. FWIW I am all done with that as was able to flash my mod without issues albeit using a cap file. Thank you.

It needs the capsule and has to be offered as *.CAP file, but it doesn’t need the capsule header (a small part of the capsule), which has been removed by the UBU tool.

UBU restores the Capsule Header (Asus) only if it is there and all the work goes inside the UBU.
If you saved as a bios bin, then the recovery Capsule Hedaer will not.

UBU v1.71 ready - 01 April 2019.