[ARCHIVE] Outdated UBU Tool related Questions, Reports and Suggestions

SoniX asked if anyone was using this feature
And the user is not on this forum

@DarkPoe @SoniX - I checked that mod BIOS, and MAC (in GbE) was not touched, remained default placeholder 88:88:88:88:87:88, so I did not find the cause of Qflash to give invalid MAC (If that is where you see the “Invalid MAC” warning message?)
So, I suggested to skip the Intel PXE rom update from UBU, problem solved. So, something in the rom itself, or the process it’s updated with cause the issue.
And sorry, DarkPoe, I didn’t notice you said it wasn’t hex edited yet to pass Qflash block, I thought maybe you sent wrong file is why I mentioned

People, as with you hard.
A lot of controversy and nothing essentially problems.
I agree more and more that the UBU project has outlived itself. :frowning:

Yes, you really do a great job

Hey @SoniX ,

In no way I am saying that this is the end of anything… I am just reporting an issue that is not critical, as updating RST is still what I really want (and the occasional microcode update, if it happens)… Just that Intel LAN doesn’t work FOR ME, and if I wanted to bash the tool, I would have bashed it… I am just reporting an issue, but your tool is great and has helped us a lot

Keep up the good work :>


Perhaps the problem is not critical, but we must at least understand why. There are some differences before and after replacing files.

The message "Bad MAC address" when there is, after flashing the BIOS image or during flash BIOS? It would be nice to see a screenshot.

@SoniX ,

Ok… Now this is weird… I went and made the modification again (I did try dozens of times before I had the problem with the MAC error) and now it flashed all right… I suspect it has to do with flashing the unlocked non-Intel-LAN modded BIOS and then flashing the modded Intel LAN BIOS…

Anyways… Pretty weird that it let me flash this now… Hope to not encounter any issues in the future if other updates happen or I will report them here :o


Well, well, well… I admit that there was some kind of failure when replacing files. This is rare, but it can be.

On the next update, check again. Moreover, there are new versions for LAN.

I also want to clarify that the patch in the hex-editor before flashing the BIOS? And then follow all the messages, I do not have time.


Hello guys! I’ll inform you that the new BIOS for ASRock Z390 Phantom Gaming 9 (http://asrock.pc.cdn.bitgravity.com/BIOS…09(4.00)ROM.zip) contain a Rev. B0 for CPU ID 906ED Platform 22 (1,5) (maybe Comet Lake?!) date 2019-02-04 that was not found in the DB.



Your MCE DB is outdated, you can update it from Github.


Thanks a lot plutomaniac, DB Updated!




@SoniX ,

I doubt it was rare, because I tried the edit many times, but never flashed because I didn’t know of the hex edit that @Lost_N_BIOS told me which basically is changing a 01 to a 00 in some specific header

I am more in favour of the flash of the non-LAN-modded-BIOS-but-hex-unlocked that somehow may have cleared this kind of error or something else

@SoniX - I’m not sure why you thought we wanted you to end project, no controversy or need to end project!
But yes always some compatibility issue or need to change/update something for some other brand BIOS etc, and BIOS are always changing so I can see that would be an ongoing chore possible
The patch @DarkPoe and I were talking about in hex editor is one byte change to allow Qflash of mod BIOS, sometimes this needed and other times already FF or 00 (only when it’s 01, Qflash block the flash of mod BIOS) - [OFFER] Gigabyte GA-Z370-Aorus Gaming 7 BIOS mod (6)

Clear. Attempt to bypass verification Boot Data Recovery.
In this case, it should work correctly like this:
- First flash patched BIOS image. (not modd)
- Then modd.

The link is not working.

@SoniX - no problem with the mod/method I linked, make the edit (if needed) then Qflash accepts mod BIOS first time without issue.
This was not part of the main issue DarkPoe was having with his UBU modified BIOS, although any mod BIOS for his model would need this edit done, but his issue was as described previously ie something relating to the PXE module replacement (unrelated to this)

In my experience, I have never used the built-in flashers. Always using only third-party BIOS flashing methods…

Qflash works good, like Asus EZ Flash, just some BIOS you have to make that one byte edit for Qflash to accept if you mod the BIOS.
I’m with you though too, prefer other methods when possible. For end user though, many get confused with advanced flashing tools, and mod BIOS often a struggle to flash for some too, so when built in method works good with mod BIOS especially, then it’s easier for them to use.


Next time, try to upload the BIOS file to another location. MSI links are not always correct for copying.