Are there any Generic NVMe Drivers for Virtual NVMe Controllers Windows 7 64?


I am having hard time making Windows 7 64bit work with NVMe drivers in VMWare Virtual Machine with an NVMe Virtual drive.

If I integrate MS Hotfixes into the Windows 7 installer, the setup hangs at Starting Windows. That’s it. It just stalls there forever.

Then I run the hotfix MSI file on a Working Windows 7 and looked for.ini, sys & cat files from Windows directories and tried to use them separately during installation, still it fails stating no signed driver found.

I opted for OpenFabrics NVMe Express 1.5 and downloaded the same from However this needs to be added during Custom Install where Windows fails to detect NVMe device. (Manually browse to a location) Now it says ‘No Signed Drivers are found’.

I press F8 during startup and disable Driver Signature Enforcement, still the same error.

I do not know what else to try and how to proceed. Any help would be nice to know.
Are there any generic Signed NVMe drivers available anywhere? The specific Intel or Samsung one’s won’t work unless their own device is attached. Here I am experimenting in VMWare with Virtual NVMe controller.

Fernando has signed OFA driver here somewhere, let me find you the thread - here in red link at bottom of post one - Which NVMe Drivers are the best (performance related)?

Thanks. However it is not loaded on Windows 7 64. Possibly it’s OS mismatch.

Yes, sorry about that, it says for Win10. Post in that thread, or wait here for @Fernando to reply, maybe he can mod that to Win7 for you?

@rohitg :
Welcome to the Win-RAID Forum!
According to my knowledge these are the available generic NVMe drivers (no Vendor/DeviceIDs of the NVMe Controller are required):
1. MS NVMe driver (Win10 in-box resp. as MS Hotfix for Win7)
2. OFA NVMe drivers (latest Win7/8/10 driver: v1.5.0.0 mod+signed, >here< is the download link to the 64bit Win10 driver)
3. Intel v16 platform RST drivers (latest: v16.5.5.1040 WHQL), >here< is the download link to the latest 64bit Win8-10 driver (Note: the installation has to be forced by choosing the file named iaStorAC.inf!).

If you don’t want or cannot use the MS NVMe Hotfix for Win7, please let me know it. Then I will try to modify the generic 64bit Intel and OFA NVMe drivers to make them usable with Win7 x64.

Dieter (alias Fernando)

Thank you Fernando for a detailed reply. Unfortunately MS Hotfix is not working with VMWare Virtaul NVMe Controller in VMWare Player 14. It may work fine on real hardware but it seems there’s some incompatibility between the two.

I also tried OFA NVMe drivers 64bit Win10 driver as per your link but it is not accepted on Windows 7. It still says No Signed Drivers found despite I have disabled Driver Signature Enforcement by pressing F8.

Finally with Intel RST, it was close but still did not work. Somehow in the list I did not find iaStorAC.inf anywhere. I tried all others but they could not detect the VMWare NVMe virtual drive.

Looks like VMWAre NVMe is expecting driver specifically designed and signed for Windows 7 only. At the moment my VMWAre is free for personal use license so I am not entitled for any specific tech support from VMWare.

Thanks and I appreciate your support.

You should better use the OFA driver, which has been mod+signed by me and to import the Win-RAID CA Certificate before going to install the driver.

If you couldn’t find the iaStorAC.inf within the driverpack, you haven’t chosen a v16 platform Intel RST driver. The related device is named “Intel(R) NVMe Controller”.

My bad. I selected wrong link. I downloaded v16 now. However v16 only works Windows 8 and up. It still fails on Windows 7, possibly soem modification may be needed to make it work on Windows 7.

I am in Windows 7 Setup on VMware VM with Virtual NVMe. I have no idea if there’s a way to import the certificate at this stage. Windows is not installed yet but asks you to select a driver because it does not natively have one during setup.

Is it possible?

If so I can also attempt your signed OFA. As of now it just says No Signed Drivers found.

@rohitg :
As long as you haven’t Win7 completely installed and running, you can neither import the Win-RAID CA Certificate nor load or integrate any modded or not WHQL certified NVMe driver.
The only generic NVMe driver, which will work, is the MS one. You can get it >here<.

I already tried MS Hotfix, but despite following the correct procedure to slipstream, the resulting setup hangs at Starting Windows. It just does not pass this point.

I there any way the Intel RST Generic NVMe v16 can be forced to work with Windows 7? That’s the only one that loads during setup.

You may need to search around on the VMware forum, surely this has been discussed and solved by now by their team?

If the driver you mentioned works with Win7, you can use ImageX and or DISM to create a new custom install.wim file to use in your install ISO, but that is an involved method you’d have to read up on and find a guide (There is plenty of good guides on using this method)
I use it often, and it’s easy once you do it a few times. This involves setting up a clean install, installing all the drivers and programs or anything else you want on the system, then grab the image and create install.wim, then take that and build a new installer.ISO to install windows with that will now include everything you put in before taking the wim image (Quick summary)

@ Lost_N_BIOS - I have not be able to find a driver that works with Windows 7 and VMWare NVMe Controller. Windows 10 supports VMWare NVMe controller out of the box.

I know the Slipstreaming procedure and despite correctly pushing the MS Hotfixes into Windows 7 using DISM tools and creating an ISO using OSCDIMG tool. Then the setup hangs at Starting Windows.

I was counting on OFA but they can not be added during Clean Installation stage. It will surely work if you have a working Windows and then you add a second NVMe device.

Intel v16 does load during setup but since it’s for Win 8 and above, it does not install.
As mentioned in my earlier post, it would be nice to know if there’s a way to mod Intel v16 to work with Windows 7.

Although I doubt, that such mod+signed driver will work for you, I have sent you a link to my freshly mod+signed “Generic 64bit Intel RST NVMe driver v16.5.5.1040 for Win7-10”.Please try it and report here about your result.

Good luck!

Confirm on virtualbox too.
I think it hangs due some incompatiblies in MS’s fixes (KB2990941 or else), if i remove nvme controller from VM, it run without hanging.
Some russian forums offer to replace boot.wim from win10 installation media, but i have not tried it
Win10 LiveCD in virtualbox boot normal with standart nvme drivers, but OS randomly hangs on hdd i/o activity

i have some idea:
- remove nvme controller
- install win7 on sata/ide
- install KBs on installed system usualy way
- add nvme controller
- dismount image file from sata/ide
- mount image file to nvme controller
- try boot (vm bios need nmve support)

@Mov_AX_0xDEAD - Yes, there seems to be some incompatibility between MS Hotfixes and VMWare NVMe Controller. That’s where I was looking for any other generic drivers. I am yest to test it on Virtualbox but seems you have already tried that.

In the mean time, first of all many thanks to you all and special thanks to @Fernando for even providing a modded Intel RST V16 Drivers for Windows 7.

Unfortunately it did not work with Windows 7 on VMWare Virtual NVMe controller.

1. During Clean Install – The setup still says No Signed Drivers Found
2. Then I attempted a different approach on an already installed Windows 7 VM. It’s on a Virtual SCSI Disk. I enabled Testing Mode and added a Virtual NVMe disk to it. After booting Windows of course it failed to detect NVMe disk. It showed as PCI Device. I force update the modded Win7 driver provided and it installs but with an error code 52. So it did not work as expected. See the screenshot.
Nevertheless it seems Windows 7 being almost near its end of extended support may no longer be supported anymore and no vendor one would now spend their efforts in designing drivers for Windows 7 anymore. I will continue my experiments with Windows 10 now on VMWAre NVMe controller.

@Mov_AX_0xDEAD - Will also try your suggestion this weekend and explore further and update.

Many thanks and best regards.

I was just wondering if there could be a way to extract the pure driver files ini, sys, cat etc from the MS Hotfix KB2990941?
If so, I can try to only slipstrem those rather than the entire msi package, just in case there are any other files causing the stall during setup.

@rohitg :
You cannot successfully integrate any generic MS storage driver into the ISO of a Windows OS, because these drivers don’t have an associated *.cat file.

This weekend I spent some time exploring your suggestion. I have some interesting results in VMWare 14.

I have 2 Windows-7 ISOs. One that was downloaded from MS with SP1 (X17-24395.iso) and then later sometime in 2016 I slipstreamed April 2015 servicing stack updates to it and created another Roll-Up ISO.

Now here’s what happened.

I installed Windows 7 in EFI Mode using original SP1 X17-24395.iso on Virtual SATA drive. Then installed both hotfixes and restarted as required. Then shutdown the machine and added NVMe virtual disk and booted into Windows. It successfully booted and detected NVMe drive and installed MS Driver automatically that hotfix had already added to the Windows installation. See the below screenshot.

I repeated the experiment with Roll-Up slipstreamed ISO. This time it only installed 2990941 and refused to install second hotfix 3087873.
I added NVMe disk and it refused to boot. Again stalled at Starting Windows.

So it seems experiment was just a partial success, not only hotfixes have boot level configuration issues on VMWare but looks like they may also not be compatible with April-2015 roll up updates. Possibly NVMe hotfixes might have been released before roll up and their impact with roll up updates might not have been ever established.

I still hope everything should work fine on a real hardware.

I do have a Linux laptop with Mint 64. I downloaded latest VMWare Player 15 for Linux and tried to install Windows 7 on Virtual NVMe. Again it stalled at Starting Windows even on Linux too!

I just want to have some news.
Since we can not modify signed driver, we can modify the PCI ID.
After I modify the virtual nvme controller, match to Intel P3605.
I can install Windows 7 using intel driver.
here is the result.


@istqian :
Welcome to the Win-RAID Forum!

Where/how did you modify the Virtual NVMe Controller and which "genreric" Intel driver did you use?
Dieter (alias Fernando)