ASRock DeskMini X300 Owners Thread

UPDATE September 11 2022
Latest ASROCK beta bios 1.79 05.July.22

Latest JZelectronci Beta BIOS L1.77 03.June.22

DeskMini/-Meet BIOS | r/ASRock Wiki (
JZelectronic - Shop - JZelectronic - Shop
ASRock > DeskMini X300 Series

I have an Asrock X300, 3400G, NH-L9a, 64GB BL2K32G32C16S4B.
Out of the box it works fantastic, enabling XMP with my specific setup does not always work the first try, you might need to set the ram speed to a slightly lower speed and then reboot and apply the full XMP speed.
Once the system correctly boots at XMP speeds I have never had a boot issue. Reminds me of early Ryzen memory overclocking.

The heatsink that Asrock bundled with the system is no good at all, way too small, I did not attempt to use it.

The Noctua NH-L9a fits with room to spare, no clearance issue at all with the VRM heatsink like some posts state there is, it has been reported that the slim fan the Noctua comes with is better than changing it for the 25mm variant.

I encountered some issues with the current public BIOS 1.40, 1.46 did not resolve the issues BUT it did appear to assist in increasing stability. I believe bios 1.40 is the only one that exists so far and is the version my unit shipped with.
Overclocking is not fun at all, I have only tried ram and iGPU overclocking. iGPU overclocking was impossible for me as it would cause thermal shutdowns from the VRM overheating.

Manually setting the SOC voltage or any of the GFX frequency or GFX voltage will cause dynamic frequency of the iGPU to be disabled (no downclock at idle) and also prevent throttling which and results in thermal shutdowns/resets under heavy load.

XMP disabled, all GFX settings auto, SOC voltage auto and a manual ram overclock applied the SOC voltage is too low and its unstable. (SOC voltage is 1.000V or less in HWinfo)

XMP enabled, all GFX settings auto, SOC voltage auto manually setting the ram speed and timings should be fine. (SOC voltage is 1.100V and drops to around 1.038V under load in HWinfo)

I have noticed strange behaviour of voltage settings not applying correctly when going to or from auto which may require removing power entirely or loading bios defaults, save and exit and then re applying all settings.

I was able to get my ram stable at 3466 C16-18-18-18 as long as the SOC voltage does not go below 1.050V (24 hour HCI Memtest and stressapptest) BUT under heavy loads (CPU + iGPU) it will shutdown/reset once it heats up which makes this overclock useless for me .

I tried replacing the VRM thermal pad with the 17Wmk Fujipoly in an attempt to help but it made no difference. The stock thermal pad appears to be 1.5mm.

Please note that the bios may behave differently between different CPUs\RAM and you may experience different behaviour or voltages.
Please post any findings you have, I would be interested to hear more.

My final ram overclock ended up being 3333 C16-18-18-18, limited by the SOC auto voltage with XMP enabled.

Just wanted to post this as it was hard to find the latest beta bios L1.46 and i wanted to put some information out there in case it helps somebody.
I got this bios from the jzelectronic website.

jzelectronic has the X300 L1.46 bios listed in their blog “31.12.20 19:13 BIOSe für ASRock Serie AM4”.

Bios L1.46 has PBO, XFR, CPB, TSME, Global C-State. AGESA ComboAM4v2PI SMU
Many of those features were not present in P1.40

I had no problem dumping the bios with flashrom, modifying with UBU and then flashing it back.
The flashrom version i used was from with the latest Rufus freedos (not recommended by some)

EDIT: Please see post below regarding flashrom on Ryzen 4000 series CPU’s. Thank you @headkaze

Thanks for posting this it’s much appreciated! It turns out your version of flashrom didn’t work with my ASRock DeskMini X300 with an AMD 4750G.

The output I got was:

Found chipset "AMD FP4/FP5/AM4"
Enabling flash write... FCH device found but SMBus revision 0x51 does not match known values.

I've compiled a version of flashrom that works with my configuration here.

Perhaps @Lost_N_BIOS might be able to help here but I can’t seem to add the “AMD CBS” menu specifically the “ACS Enable” option which is located in the CbsSetupDxeRN module.

I tried adding the “AMD CBS” menu (E3 35 45 B0 04 30 46 49 9E B7 14 94 28 98 30 53 00 70) to AMITSE but it doesn’t show. It seems that the tabs in the BIOS are from the Setup module but trying to insert anything into it will cause errors when opening in AMIBCP5.

L1.46 has the “IOMMU” option but I really need the “ACS Enable” option also. It’s important to have this for a fully functional virtualization host.

If anyone can help me modify the L1.46 BIOS to add this option it would be greatly appreciated.

Thanks so much for this, I have almost exactly the same setup as you except I’m running on 32gb ballistix 2666mhz with 3200mhz xmp profile. I’ll return with my stables when I get a chance to play around with the new bios

@clackersx :
Thanks for having tested different BIOS versions for the ASRock DeskMini X300 and for your advices, which seem to be very useful for all owners of a similar device.
Since it may not be clear for the Forum visitors why you started this thread within the Sub-Forum named "Interesting PC Hardware & Software" (they may expect a review about the DeskMini PC), I recommend to rename the thread title to "Interesting BIOSes for ASRock DeskMini X300". What is your opinion?

I think I have a stable system if you want to test run on yours. I wouldn’t recommend for everyone but since our systems are so similar I’ll post for you to try so here we go.
Bios/oc tweaker

Core Performance Boost = disabled
Global C-state Control = disabled
Xmp settings = XMP 2.0 ddr4 3200 16-18 -18 -36
Dram Frequency = DDR4 3466

Inside XFR Enhanhacement
Precision Boost Override = manual
PPT = 50
TDC = 65
SOC TDC = 50
EDC = 75
both the noctua inside and the wraith stealth cooler sitting on the case sucking air out are set to performance mode. I’m sure between us we can find a nice stable.

Thanks for posting your results @Hypershams

Unfortunately, i am unable to run over 3333 without changing the SOC voltage, as soon as i touch the SOC voltage it prevents the system throttling and messes with the iGPU clock dynamically adjusting most of the time… Eventually I hit thermal shutdown eventually even with manual PBO/XFR settings slightly reduced.
I am going to hold off in the hopes that a 5000 series CPU is launched and supported by the X300… If that does not happen i will spend a lot more time trying to get a little bit more performance out of it, i dont want to spend hours and hours on it only to replace the CPU and have to start from scratch.
I use it as a secondary system exclusively for work so it needs to be rock solid stable.

Please keep posting what you find, it will be useful for myself and i am sure other people that come across this post.

Here are the setting that have finally made it solid up and running for the last 3 days with gaming and what not. These you can apply but your ram settings will be different depending where you find stability
To begin I reset the bios fully (unplug battery and shorted the pins) and rebooted straight back into bios settings and set the following settings under OC Tweaker
Core boost: Disabled
Global C-state Control: Disabled
Leave all other settings on auto as I think it stops boosting the cpu past 3.7ghz and that stops the fans ramping up aswell.

Under XFR Enhanhacement with Precision Boost Override set to manual
PPT limit: 60
TDC Limit: 65
SOC TDC Limit: 50
EDC Limit: 75
SOC EDC Limit: 75
This is to mainly just reduce the amount of power being given to the cpu limiing how high clock can go and control the temperature aswell(don’t quote me on that) and once thats done save and boot into your Windows.
Here is where we use ryzen master to set the gpu to 1600 so it scales itself from 200mhz to 1600mhz. In ryzen master, advanced mode we go to the game mode profile and click on auto overclocking we exclude all settings that can be excluded except for Control Mode.
We set the same PPT/EDC/SOC numbers as we did in XFR Enhanhacement under Precision Boost Override in the bios and set Boost Override CPU to 0 and Boost Override APU GFX to 200 and hit apply and test and if all goes well after ryzen master finishes testing the cpu max frequency will stay between sleep and 3.7ghz and PPT will limit the power going to the cpu and won’t ramp up the fans when doing something trivial like exiting a game. I really think the second fan I have sitting on top thats connected to the second cpu fan socket inside helps extract the heat better . I hope this helps you set a base so you can play with ram settings to find your best stable. Boosting the cpu most of the time resulted in my motherboard overheating and shutting alot so I’ve given up on that completely .
If the goal to achieve is for the cpu to run at stock with no boost and scaling and the gpu to boost upto 1600mhz with scaling I think this achieves that while keeping the gpu around 60 to 62°C at max load. Ps idle temp is 29°C

After weeks of testing and trying to get a stable, i finally discovered it was my Crucial Ballistix BL2K16G32C1634B DDR4 3200MHZ CL16 1.35V 32gb that was causing the issues. So I put my HyperX 16gb KHX3200C20S4/8G DDR4 3200MHZ CL20 1.20V running at 3400MHZ@ 1.35V which i think is listed as compatible ram on the asrock website and everything is running butter smooth now sitting at 24°C idle and reaching 54°C when gaming. I can’t explain to you how much time and effort has gone to waste trying to make the Ballistix ram work on my Deskmini. Basically just make sure you have compatible ram because that was the root of all my issues.

I have similar RAM (KHX3200C20S4/32GX). What settings did you change in BIOS to run it at 3400MHZ? Do you only have to set DRAM Frequency and DRAM Voltage (like in the attached image)?


Best thing to do is reinstall bios/clear cmos/load UEFI defaults. I couldn’t believe my dumb luck when in bios I loaded the XMP 2.0 Profile 1 (3200mhz) and then directly underneath I set DRAM Frequency to 3400mhz. I forgot to set the DRAM Voltage to 1.35v and it just booted at 1.20v. These next settings are optional if you’re having issues with high temps. Disable Core Performance Boost and in XFR Enhanhacement use the settings in the photo. I had no luck messing with timings so best of luck brother and let us know how you get on





Thanks for showing me your BIOS settings. I’m now running at 3400 Mhz :slight_smile:

I believe we can push our memory to 3600 Mhz no problem and perhaps even as high as 3800 Mhz. From my research you need to do find out the die of your RAM chips. You can use Thaiphoon for that (I’ve attached my output from it).

You’ll see that mine are 16 Gb E-die. Once you know this you can check out the spreadsheet here and click on the “Zen 2 RAM Overclock” tab.

These are verified overclocks people have achieved on the various die’s. A guy named coffee on the Overclocking Discord (#ram-overclocking) channel made the following suggestion to me:

That’s about as far as I got as I don’t know how to set these values in the BIOS. If you have any luck please let me know. I’d be happy to get 3600 Mhz.


Awesome, I’m glad the settings worked for you. I’m pretty new to playing with bioses so I’ll take whatever help I can get. I had the ram running at 3600mhz with DRAM Voltage set to 1.35v using ryzen master but it was not happy and rebooted itself. I’m hoping i can get to 3600mhz+ on 1.20v if that’s even possible. I think my 3400G is zen+ architecture but I’ll have another look.
Here’s my thaiphoon screenshots, unfortunately the pcb revision shows as 00h and I have to use manual setting for die in DRAM calculator

I just tried 3600 Mhz 20-22-22-22-42 1.20v and it seems stable.

I looked up an entry in the spreadsheet and saw 14-8-17-11-32-53-1T (3800 MHz) which corresponds to these values:

Note that the tRCDWR/tRCDRD are in the reverse order in our BIOS and I believe the cmd2T is called Command Rate (CR).

I’m not game enough to try 3800 MHz though!


It seems I can’t boot 3600mhz with DRAM Voltage at 1.20v only at 1.35v and even then it’s not stable or its over heating unless I set the soc voltage to 1.156v. you must have lucked out with your ram

I’ve managed to push to 3600mhz with DRAM Voltage @ 1.35V and SOC voltage @ 1.2v but I can’t seem to boot any higher than that. I tried to boot 3800mhz DRAM Voltage 1.35v and I push the SOC voltage up to 1.3v and got scared and left it. I might get brave and try push it further.

Is there any way to increase the DRAM Voltage in bios I only have the options for 1.200v and 1.350v?

Is there an easier way to recover without having to power up with CMOS disconnected? Unless there’s an easier way to recover from a failed boot I think my overclocking days are over.

Honestly mate opening and closing the case is a hassle and a half, especially since it is mounted to the back of my monitor. I was looking at getting one of theses switches and routing it to the cmos switch through one of the holes till I’ve finished testing