ASRock H81 Pro BTC R2.0: How to made successful mod for Broadwell?

Hello everyone,

I would like to get Broadwell support on ASRock H81 Pro BTC R2.0 (low-cost board for crypto mining).

Main goal:
- insert BDW microcode (40671h) and HSW microcodes (306C1h to 306C3h)

mod_H81PBC21.40M3-microcodes.png


- update VBIOS EFI GOP for iGPU

mod_H81PBC21.40M3-modules.png



I have:
- Haswell: Celeron G1840, Core i5-4440
- Broadwell: Xeon E3-1265L v4 (ordered from Aliexpress, still on the way)

I was insert GPU modules to this pre-modified BIOS, but it doesn’t work at all.

Please read this post. I asked this some time ago and to this time the manufacturer needs to add ME FW 9.1. Without it will not work.

[Discussion] UBU Tool related Questions, Reports and Suggestions (107)

So did you or anyone never tested inserting 9.1 yourself on this board, sounds like some might be OK with it?

I didn´t try cause I sold my broadwell cpu before mod was finished.

Anyone that has flash programmer can try this ME swap to test if it’s OK or not. I would do this with older regularly compatible CPU and stock BIOS (no other mods done). That way you are only testing ME version change working or not.


Yes, I have Chinese programmer TL866CS.

I was flash official BIOS 1.40. Then update MEI to 9.0.31.1487 and to 9.1.37.1002 via Intel ME System tools v9.1. r7. Always with same result - board is bricked after flashing modified BIOS. Do you know better option?

MEI-v9.1.37.1002.jpg



Funny response from ASRock support:

Create BIOS from 1.40 with clean ME from repository following the guide, using 1.40 BIOS as setting source and clean ME 9.1 from repo. You mentioned system tools, what did you use in system tools in the test you mentioned, Flash image tool and the ME Clean guide?
It may not work, as they mentioned on the previously linked threads.

I wonder if now, that 3 years has passed since then, if either @SoniX or @plutomaniac know how to better accomplish this, or if it’s still just impossible

What is that image, I see ME 9.1, is that showing what’s currently flashed in the board or what’s in the BIOS you loaded to flash?

Accomplish what exactly?


You mean this guide?
[Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

@plutomaniac I think Lost_N_Bios was refering to this post from you in the past.

[Discussion] UBU Tool related Questions, Reports and Suggestions (107)

Well new BIOS code is required to support the newer firmware and processors. That includes whatever BIOS modules communicate with the ME. One would need to do comparisons between various BIOS and probably speculate on what needs to be updated as well. That hasn’t changed in the last 4.5 years since that platform’s release.

Plutomaniac - yes, I meant now that three years has past, is there any change for this situation based on what you guys said three years ago in that post linked at #2 [Discussion] UBU Tool related Questions, Reports and Suggestions (107)
Mainly, since it’s been three years now, has anyone found new or working method to insert 9.1 when 9.0 was original ME? This mod stuff aside, I was only concerned about the ME change and you guys comments in the above linked post.

@JanCerny - yes, I meant using that guide, but I mentioned that before knowing there was possible issue doing 9 to 9.1 change. Even so, that would be how I would attempt to test that, and do the test by itself with older CPU and no other changes to BIOS regarding this mod, only if you know you can recover

The ME upgrade from 9.0 to 9.1 was never the problem. Even FWUpdate tool could do it perfectly. Instead, the BIOS was. Because the BIOS source code (its modules) needed an update to communicate with the newer ME firmware, the user would see wrong BCLK (97 instead of 100MHz I think), broken fan control etc. If someone had the knowledge, time and system to test, they would need to compare different BIOS and figure out which modules need updating as well. Noone did that so nothing had changed since then.

I gotcha now, thanks! I know several bclk related settings can be adjusted within the ME settings, but I’m sure it’s much more than that. I don’t have a similar system so I can’t dig into this

No it’s not ME settings related, purely BIOS. One could take BIOS v1 for an OEM and the compare it to v2 which mentions specifically that support for BDW was added. Basically compare the BIOS before & after the OEM added BDW support to see what changed in the BIOS. It’s not as easy as it sounds because they usually used new AMI source code so a lot of things were different, not just the ones which cause the ME 9.1 issues.

I know that there is some embedded hardware on the market with q81 chipset and broadwell cpu. Maybe I can find which manufacturer offered this system and we can get a bios file. And if I remember correctyl there was some ASRock mainboard, offered only on chinese market, that has Broadwell Support at the product page. But this page dissapeared very fast and I never figured out if it was just false advertising or if they did something that intel didn´t like.

I can offer a lot of time to dig into it and will have a z87 board in a few days. But I need more knowlegde or in other words help from other user, maybe more then they are willing to spend.

That would be good starting point, but may only apply to the brand/board you find it for and it’s previous model. Maybe the page you mention can be found in google cache?

Even years ago I never found the page a second time.

Only thing I actually found is that some other people tried the mod and failed, even with changed ME. One user suggested to clean the ME but the thread stopped.

https://forum.qnap.com/viewtopic.php?t=111084

BTW: I found a chinese gigabyte product page from b85 board with broadwell support listed, but can´t find the suitable microcode in bios files that are for download.

http://www.gigabyte.cn/Motherboard/GA-B85M-D3H-rev-12#ov

what can’t you find in that BIOS oldirdey? I mean, do you need something extracted from the Gigabyte BIOS you linked above? if yes, what, all microcodes? You can do that with MC Extractor
Does that BIOS have 9.1 ME?

There is only Haswell Microcode and older ME in the bios file, I checked all downloadable versions from all revisions. I mentioned a few posts before thats maybe false advertising what I found years ago.