ASRock P67 Extreme4 B2 revision, BIOS 3.10 Win10 issues

Hello everyone! Will be very grateful if someone can help me with this board.

The situation is as follows:
I have I5-3470 (Ivy Bridge) and ASRock P67 Extreme4 B2 revision. P1.30 BIOS

as I started the system, its work, but there was no image on the screen and showed 55 error on the motherboard

replacing CPU to sandy bridge helped to solve this and everything worked in win10

later I found out that revision B2 is actually no longer serviced by the manufacturer and does have a number of defects at all. however, there was very little information about this and the manufacturer did not indicate at all that there are two versions of the revision.

I downloaded the only available BIOS from the ASROC site for this motherboard version P3.10 which has support (Ivy Bridge) and I launched it from win10, but I received a message that you have a B2 revision which is not supported Ivy bridge, BIOS updates will be terminated. however, a little later I started it again, but at the same time I had a browser open, the program suggested to first close all applications and to my great surprise it started flashing the BIOS to 3.10 for my B2 revision. I couldn’t do anything or stop it somehow.

after restarting, I entered BIOS 3.10 but just saved the default settings and exit the computer turned off and did not start at all. however, after resetting cmos, it starts and I can get into a new bios, but win10 goes to the Blue Screen of Death at startup. ide / ahci no matter.

so I put my hdd to sata3 with win 7 and it started and worked stably. but as soon as I turn off , it cannot start again and i have to reset cmos.

all this time I used sandy bridge cpu.

-------------------------------

- I don’t understand how I can switch to win10 again and is it possible at all?
- Where to find some other version of the BIOS, all links which I found do not work or lead to an asrock site where only 3.10
- Is it possible to return to the old version by flashing through Windows or by writing dos files to a USB flash drive?
- Is it possible to achieve a successful launch of win 10 on the B2 revision using 3.10 bios and Ivy Bridge CPU?
- What can I do to avoid constantly resetting cmos before new start?

will be sincerely grateful for any help
this case disappointed me a lot, it all looks like a joke from asrok

small addition …

managed to start win10 by switching to marvel Sata. at first glance, no problems.

but still need to reset cmos at system startup, what can I do to fix it?

Are u sure its B2…this boards were recalled due to Intel BUG in SATA…but i think u r aware of this!
I would try to extract the content of the 3.10 exe, put in USB and flash again in bios interface by Instant flash, NOT from Windows, do not go to bios until the machine reboots itself 2 times at least.
Didnt the EXE asked u to do a USB drive updater? Very strange wot u described…
Check later if ME version in bios is 8.02.xxxx.
After that update to the latest Intel MEI 8.1.70.1590 firmware, reboot, and then using FPT from ME 8 r3 tools, perform a ME reset status with cmd/Admin: FPT -greset.

OR:

p67_me.jpg

http://forum.asrock.com/forum_posts.asp?..-10-bios-update
Also here mention that cannot go back in version after the 3.10 update

Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

EDIT: [Solved] How to extract Asrock P67 extreme4 official bios?



Thanks for your post.

yes i’m, sure - https://gyazo.com/05dbd886a0824d8ef7f8a2b7605ed5f2

And I am having trouble finding and installing Intel MEI.
BIOS and system device is empty, I suppose that it is not installed now? - https://gyazo.com/0883043cb998422f10b5303733eb264a

as I start to install MEI v2117.15.0.2272 DCH (Windows 10> = 1709), i get - “this platform is not supported” OS build 19041

I can probably try to solve it by flashing the same BIOS version again but now from the usb drive (if it is possible, 3.10 is already installed).
I suppose that I need to first unpack the files from the exe that asrok provides for Windows. don’t know that very well, how to do it correctly?


btw, reset cmos comes only after turning off PC but when i reboot everything is fine.

No, MEI 8 is a bit old now…latest driver is 11.0.5.1189, its valid in any Windows 10 build.
Do not know the bios menu of that board, see if u see it reported in bios tabs (Advanced tab maybe).
Also if u run HWinfo it will show…or not and indeed ur MEi is corrupted.

To run the Intel MEi 8 tools and Firmware update u need this driver installed, if the operation fails also confirms bad ME.
Do NOT confuse ME Firmware (HW based), with MEI driver (OS interface), 2 different things that overall is the MEI8 itself.

EDIT: Section D for driver, and u should read this topic for further troubleshooting ME status Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

1,5Mb Consumer: https://downloadmirror.intel.com/26127/e…11.0.6.1194.zip

HWinfo does not show anything
https://gyazo.com/4363d3cb576bbb737e78a8bcaff9bd88

could you please kindly provide an exact link to the driver that I need


Edit:
launched MEI Setup, result - https://gyazo.com/76b1459945f156c6c1a55fc365ce29b6


in section D are different versions of drivers, how to understand what I need?

U can simply install driver only
ME_Consumer_Win7_8.1_10_11.0.6.1194.zip\WINDOWSDriverPackages\MEI

Lets do some tests

From same link, download Intel ME8 r3 tools, in folder FPT, copy contents to root c: and run as CMD Admin fptw64 -d spi.bin
If command succeed, the new file is created, share it here to analyze.

If it fails get AMI IV Flash tools here https://www.ami.com/download/aptio-4-ami…update-utility/
Search inside folder Aptio_4_AMI_Firmware_Update_Utility.zip\AMI AFU For Aptio 4\afuwin, extract zip contents to root c: Run AFUWINGUIx64.EXE as Admin e save a backup, share it here to analyze.

EDIT: In same folder ME8 r3 tools, fold MEINFO, run the tool also in root as CMD Admin: meinfowin64 -fwsts, paste the output and will see it status operational.

ok so i downloaded ME System Tools v8 r3, copied the contents of the Flash Programming Tool (FPT) to C:, there was a windows64 folder and inside 4 files. from the Windows folder I run fptw64.exe, -d and it just closes, no logs files. the same if i run it from C: directory.


https://mega.nz/file/oLpGVTbR#rImx9otyJG…NEhlhx9__qPZFe4


Error 9459: Internal error (Could not determine FW features information)
https://gyazo.com/09666a2172983d9c99cb8dda65707a92

Edit:

ME_Consumer_Win7_8.1_10_11.0.6.1194 - installed successfully heci.inf

First of all please try install the driver (Driver package only) again by right clicking in the driver INF (HECI.inf) and select install.
Then go to device manager again and check if any Intel(R) Management Engine Interface is listed now. U can also check in device manager the option to show Hidden devices.
And as i said…with no device present and driver loaded the ME8 tools will always fail.
The command is: FPTW64.exe -d spi.bin, it will write the file on the root drive, it should be 8mb.
The Afuwin backup is not valid for this sorry, as it doesnt contain the ME image to analyze.

I suspect that indeed u have a bad flash and a corrupted ME FW, remotely u need a full dump of the system SPI to check the integrity of bios region and ME region or a report of MEinfo --fwsts oi -i
U can try to re-flash as i said in UEFI bios by Instant flash again and then we may try perform a [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

This is the report of ME Analyzer of the bios 3.10 update file for ur motherboard, as u see it comes with the ME image that its always upgraded in a SPI update action. (if needed).
If u can get a full dump of ur current SPI bios, this is wot ull get reported from ME Analyzer tool.

p67mei8.jpg

that’s exactly what i did!
HECI.inf was successfully installed. and yes appeared Intel(R) Management Engine Interface in device manager.

a little confused with FPTW64.exe
here are 4 files in the directory - https://gyazo.com/7972c8a3a1ed4f7de2e86ba36b2a3d9a
if i run FPTW64.exe as administrator and press any key, it closes immediately

if i run cmd and write there FPTW64.exe -d spi.bin
https://gyazo.com/9589ebc4cbf7d746351c767980ff563c

sorry i don’t know all these things very well, maybe i’m doing something wrong?

Good, device present and driver installed.
My friend…as u can see the EXE is in the root c: NOT in Users\RAV10…hehehe get it?
Now before the dumps with the tool FPT check the report with “c:\meinfowin64 -fwsts” and “-i,” paste the output and will see it status operational.

EDIT: Did u rebooted the machine after driver installation, if not do it now.
The commands must be run in a Command Prompt window, as Administrator.
CD \ goes to root drive, perform operations now.

How to: Press Windows+R to open the “Run” box. Type “cmd” into the box and then press Ctrl+Shift+Enter to run the command as an administrator.


https://mega.nz/file/EbAkQBoK#dGcU67luSI…2L0B1Y8XGANQg3o


I still can’t run it, all 4 files are located in C: I run as administrator and it immediately closes with the error log
https://gyazo.com/427876ffef77fb08ec77e0273d2630e5
log:
Error 9470: Fail to load driver (PCI access for Windows)
Tool needs to run with an administrator privilege account.


EDIT:
after reboot and as Administrator
https://gyazo.com/a6acb6687d0d4461af936df15e7d56a7

Not good… perform the command: fptw64 -greset
This system will auto reboot itself, do not interrupt till u get back to windows again. After that do a shutdown and AC plug off, 2 minutes and then power back the system.
Back to windows perform again the c:\meinfowin64 -fwsts and show the results.

EDIT: Well this things must be done with eyes open…cant u see…again…from wich location ur doing the command, where is the FPTW64.EXE…isnt in the root drive c:

Perform extra command: meinfowin64.exe -verbose, attach a txt file as report.

EDIT: My friend… i always refereed ROOT DRIVE…not system folder.

very strange, copied to the windows folder all 4 files
https://gyazo.com/19f3b257345b41c4150a9931b51caa4a


I’m not sure if I’m doing everything right but -greset doesn’t work all files in the root drive now
https://gyazo.com/d39f6ea7ab05f08d3cf8751bb2cf30a9

meinfowin64.exe -verbose
https://gyazo.com/3f0e21fbbcb557040f896689291b3412

Upon successful reboots/shutdown operations:

Go to section B1 of Intel (Converged Security) Management Engine: Drivers, Firmware and Tools
and get the FW update ME 8 1.5MB v8.1.70.1590
Extract the content file to root c and rename it to: newME.bin, extract the file FWUpdLcl64.exe of folder Intel ME System Tools v8 r3\FWUpdate\Local-Win64 from ME8 r3 tools to root c
Perform the command FWUpdLcl64.exe -save default.bin
Perform the command FWUpdLcl64.exe -F newME.bin, upon finished successful action reported by the flash tool, close all and reboot.
Back to windows again 3 commands: meinfowin64.exe -fwsts ; meinfowin64.exe -verbose ; fptw64 -i

Sorry but have to be away about 1 hour.


https://gyazo.com/670ee3eb2bff1629c3b80ffc6b5fb3d1

both files in the root c:

sorry if i’m doing something wrong but i try very hard

What…it cannot be, dont tell me that the device is not present anymore in device manager???
Go check it if u plz

I think I understand what the problem is
https://gyazo.com/5f63fcc3f6d9ca00167717fe31a54dd5

I made a restart but nothing changed

Its unloaded/not present anymore.

Lets get some things straight my friend…the past operations had success because the device was present and the device driver was installed and loaded.
Dont need to report all the errors that is present to u, as u already noticed, u just need to insure that that the device is present before execute all the explained commands as i gave u in the past posts.
So…if the system upon reboots/shutdowns does not has the device/driver loaded it will fails all the commands by Intel tools MEINFO/FPT then u have a HW issue, an SPI bios chip issue or a possible corrupted ME region on the bios.

Last resource action for u, treating this as a corrupted ME image, is the [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization but i do not believe this will fix it.
But also it wont do worst if performed and if u think u got nothing to loose.
Also as suggested before, u still can try the re-flash (Instant Flash not Windows EXE) and then proceed to the last FW update already pointed but if the ME is corrupted its no good at all.

U may need to get in touch with Plutomaniac as he masters this area of Intel Engine (CS)ME/(CS)TXE, he may have a better view as i do not not have his experience in this area.
Sorry i couldn’t help u more, good luck.

Thanks for the help. The driver will probably install normally, but the manager will display it as an unconnected device, even if the driver is reinstalled. and you are right in mentioning that the possible corrupted ME region on the bios. since the installation of the BIOS, in my opinion, was not successful.

I planned to use the board as a temporary solution for the next year and I need it for work, but can I constantly reset the cmos every time I turn it on, what is the risk of using such a BIOS and errors?? to be honest, any interference can lead to unpredictable actions on this board. but I would like to try something else that can be reversed in case of failure.

Asrock site provides only windows version of 3.10 BIOS I can.t run it through a Instant Flash ( usb flash drive), as far as I understand, I need another version of this BIOS, but how can I convert it or remove the necessary files from the win version?

In any case, thanks for your help and your time, we have definitely made some headway in our understanding.